OpenMW fails to load after 2 separate updates today via Synaptic Package Manager

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
User avatar
Cl3v3rP0tat0
Posts: 59
Joined: 14 Jul 2023, 03:03

OpenMW fails to load after 2 separate updates today via Synaptic Package Manager

Post by Cl3v3rP0tat0 »

So, I finished yesterday evening with a working minimally modded OpenMW version 48...this morning I was prompted with a MyGui Openmw update from Synaptic and an hour later a (release?) OpenMW update. Version number in launcher didn't change - launcher worked but I can't load a test character at all and loading screens do not appear only a brownish screen. To troubleshoot, I removed my mods, only running base game. There's no error, the log just stops as it loads the Tradehouse cell. I drop straight to Linux desktop with no fanfare. :(

My OpenMW Log from last attempt:

Code: Select all

[11:30:13.780 I] OpenMW version 0.48.0
[11:30:13.782 I] Using default (English) font encoding.
[11:30:13.782 I] OSG version: 3.6.5
[11:30:13.783 I] SDL version: 2.0.20
[11:30:13.784 I] Loading shader settings file: "/home/cl3v3r/.config/openmw/shaders.yaml"
[11:30:14.389 I] OpenGL Vendor: Intel
[11:30:14.389 I] OpenGL Renderer: Mesa Intel(R) HD Graphics (CHV)
[11:30:14.389 I] OpenGL Version: 4.6 (Compatibility Profile) Mesa 22.2.5-0ubuntu0.1~22.04.3
[11:30:14.390 I] Using reverse-z depth buffer
[11:30:14.394 I] Adding BSA archive /home/cl3v3r/.steam/debian-installation/steamapps/common/Morrowind/Data Files/Morrowind.bsa
[11:30:14.410 I] Adding BSA archive /home/cl3v3r/.steam/debian-installation/steamapps/common/Morrowind/Data Files/Tribunal.bsa
[11:30:14.414 I] Adding BSA archive /home/cl3v3r/.steam/debian-installation/steamapps/common/Morrowind/Data Files/Bloodmoon.bsa
[11:30:14.416 I] Adding data directory /usr/share/games/openmw/resources/vfs
[11:30:14.417 I] Adding data directory /home/cl3v3r/.steam/debian-installation/steamapps/common/Morrowind/Data Files
[11:30:14.417 I] Adding data directory /home/cl3v3r/.local/share/openmw/data
[11:30:14.947 I] Lua version: Lua 5.1.4 (LuaJIT 2.1.0-beta3)
[11:30:14.947 I] Loading keybindings file: /home/cl3v3r/.config/openmw/input_v3.xml
[11:30:14.960 I] Loading font file magic_cards_regular.fnt
[11:30:14.998 I] Loading font file daedric_font.fnt
[11:30:15.027 I] Loading font file DejaVuLGCSansMono.omwfont
[11:30:15.133 W] Warning: no splash screens found!
[11:30:15.180 I] Initializing OpenAL...
[11:30:15.290 I] Opened "Built-in Audio Headphones + Speakers"
[11:30:15.290 I]   ALC Version: 1.1
[11:30:15.290 I]   ALC Extensions: ALC_ENUMERATE_ALL_EXT ALC_ENUMERATION_EXT ALC_EXT_CAPTURE ALC_EXT_DEDICATED ALC_EXT_disconnect ALC_EXT_EFX ALC_EXT_thread_local_context ALC_SOFT_device_clock ALC_SOFT_HRTF ALC_SOFT_loopback ALC_SOFT_output_limiter ALC_SOFT_pause_device
[11:30:15.357 I]   Vendor: OpenAL Community
[11:30:15.357 I]   Renderer: OpenAL Soft
[11:30:15.357 I]   Version: 1.1 ALSOFT 1.19.1
[11:30:15.357 I]   Extensions: AL_EXT_ALAW AL_EXT_BFORMAT AL_EXT_DOUBLE AL_EXT_EXPONENT_DISTANCE AL_EXT_FLOAT32 AL_EXT_IMA4 AL_EXT_LINEAR_DISTANCE AL_EXT_MCFORMATS AL_EXT_MULAW AL_EXT_MULAW_BFORMAT AL_EXT_MULAW_MCFORMATS AL_EXT_OFFSET AL_EXT_source_distance_model AL_EXT_SOURCE_RADIUS AL_EXT_STEREO_ANGLES AL_LOKI_quadriphonic AL_SOFT_block_alignment AL_SOFT_deferred_updates AL_SOFT_direct_channels AL_SOFTX_events AL_SOFTX_filter_gain_ex AL_SOFT_gain_clamp_ex AL_SOFT_loop_points AL_SOFTX_map_buffer AL_SOFT_MSADPCM AL_SOFT_source_latency AL_SOFT_source_length AL_SOFT_source_resampler AL_SOFT_source_spatialize
[11:30:15.358 I] HRTF disabled
[11:30:15.358 I] Allocated 256 sound sources
[11:30:15.358 I] Low-pass filter supported
[11:30:15.358 I] EAX Reverb supported
[11:30:15.369 I] Enumerated output devices:
[11:30:15.369 I]   Built-in Audio Headphones + Speakers
[11:30:15.369 I] Enumerated HRTF names:
[11:30:15.369 I]   default-44100  default-48000  Built-In 44100hz  Built-In 48000hz
[11:30:15.376 I] Loading content file builtin.omwscripts
[11:30:15.376 I] Loading content file Morrowind.esm
[11:30:16.886 I] Loading content file Tribunal.esm
[11:30:17.075 I] Loading content file Bloodmoon.esm
[11:30:18.551 W] Bullet was not compiled with multithreading support, 1 async thread will be used
[11:30:18.552 I] Using 1 async physics threads
[11:30:18.583 V] Using idle priority for thread=139710133970496
[11:30:18.589 V] Disabling Multiview (disabled by config)
[11:30:18.687 I] Preferred locales: en
[11:30:19.012 V] Fallback locale: en
[11:30:19.027 V] Language file "l10n/SettingsMenu/en.yaml" is enabled
[11:30:19.165 V] Fallback locale: en
[11:30:19.167 V] Language file "l10n/DebugMenu/en.yaml" is enabled
[11:30:19.172 V] Fallback locale: en
[11:30:19.174 V] Language file "l10n/PostProcessing/en.yaml" is enabled
[11:30:19.222 V] Lua scripts configuration (8 scripts):
[11:30:19.222 V] #0 PLAYER : scripts/omw/mwui/init.lua
[11:30:19.222 V] #1 GLOBAL : scripts/omw/settings/global.lua
[11:30:19.222 V] #2 PLAYER : scripts/omw/settings/player.lua
[11:30:19.222 V] #3 PLAYER : scripts/omw/camera/camera.lua
[11:30:19.222 V] #4 NPC CREATURE : scripts/omw/ai.lua
[11:30:19.223 V] #5 PLAYER : scripts/omw/console/player.lua
[11:30:19.223 V] #6 GLOBAL : scripts/omw/console/global.lua
[11:30:19.223 V] #7 CUSTOM : scripts/omw/console/local.lua
[11:30:19.223 I] Loading Lua storage ""/home/cl3v3r/.config/openmw/global_storage.bin"" (3 bytes)
[11:30:19.223 I] Loading Lua storage ""/home/cl3v3r/.config/openmw/player_storage.bin"" (366 bytes)
[11:30:19.231 I] Starting a new game
[11:30:19.249 V] Fallback locale: en
[11:30:19.250 V] Language file "l10n/Interface/en.yaml" is enabled
[11:30:19.254 V] Fallback locale: en
[11:30:19.257 V] Language file "l10n/OMWCamera/en.yaml" is enabled
[11:30:19.301 I] Changing to interior
[11:30:19.301 I] Loading cell Seyda Neen, Arrille's Tradehouse

I have reinstalled OpenMW (openmw, openmw-data, openmw-launcher, libmygui.dev via Synaptic Package Manager.

Splash screens are not listed as missing but they do not show at all - only a gradient browwn screen before CTD.

Code: Select all

[12:49:40.992 I] OpenMW version 0.48.0
[12:49:40.992 I] Using default (English) font encoding.
[12:49:40.992 I] OSG version: 3.6.5
[12:49:40.992 I] SDL version: 2.0.20
[12:49:40.993 I] Loading shader settings file: "/home/cl3v3r/.config/openmw/shaders.yaml"
[12:49:41.661 I] OpenGL Vendor: Intel
[12:49:41.661 I] OpenGL Renderer: Mesa Intel(R) HD Graphics (CHV)
[12:49:41.661 I] OpenGL Version: 4.6 (Compatibility Profile) Mesa 22.2.5-0ubuntu0.1~22.04.3
[12:49:41.661 I] Using reverse-z depth buffer
[12:49:41.665 I] Adding BSA archive /home/cl3v3r/.steam/debian-installation/steamapps/common/Morrowind/Data Files/Morrowind.bsa
[12:49:41.678 I] Adding BSA archive /home/cl3v3r/.steam/debian-installation/steamapps/common/Morrowind/Data Files/Tribunal.bsa
[12:49:41.681 I] Adding BSA archive /home/cl3v3r/.steam/debian-installation/steamapps/common/Morrowind/Data Files/Bloodmoon.bsa
[12:49:41.684 I] Adding data directory /usr/share/games/openmw/resources/vfs
[12:49:41.684 I] Adding data directory /home/cl3v3r/.steam/debian-installation/steamapps/common/Morrowind/Data Files
[12:49:41.685 I] Adding data directory /usr/games/ModData/Load Screens
[12:49:41.685 I] Adding data directory /home/cl3v3r/.local/share/openmw/data
[12:49:42.350 I] Lua version: Lua 5.1.4 (LuaJIT 2.1.0-beta3)
[12:49:42.350 I] Loading keybindings file: /home/cl3v3r/.config/openmw/input_v3.xml
[12:49:42.361 I] Loading font file magic_cards_regular.fnt
[12:49:42.396 I] Loading font file daedric_font.fnt
[12:49:42.428 I] Loading font file DejaVuLGCSansMono.omwfont
[12:49:42.526 I] Initializing OpenAL...
[12:49:42.629 I] Opened "Built-in Audio Headphones + Speakers"
[12:49:42.629 I]   ALC Version: 1.1
[12:49:42.629 I]   ALC Extensions: ALC_ENUMERATE_ALL_EXT ALC_ENUMERATION_EXT ALC_EXT_CAPTURE ALC_EXT_DEDICATED ALC_EXT_disconnect ALC_EXT_EFX ALC_EXT_thread_local_context ALC_SOFT_device_clock ALC_SOFT_HRTF ALC_SOFT_loopback ALC_SOFT_output_limiter ALC_SOFT_pause_device
[12:49:42.664 I]   Vendor: OpenAL Community
[12:49:42.664 I]   Renderer: OpenAL Soft
[12:49:42.664 I]   Version: 1.1 ALSOFT 1.19.1
[12:49:42.664 I]   Extensions: AL_EXT_ALAW AL_EXT_BFORMAT AL_EXT_DOUBLE AL_EXT_EXPONENT_DISTANCE AL_EXT_FLOAT32 AL_EXT_IMA4 AL_EXT_LINEAR_DISTANCE AL_EXT_MCFORMATS AL_EXT_MULAW AL_EXT_MULAW_BFORMAT AL_EXT_MULAW_MCFORMATS AL_EXT_OFFSET AL_EXT_source_distance_model AL_EXT_SOURCE_RADIUS AL_EXT_STEREO_ANGLES AL_LOKI_quadriphonic AL_SOFT_block_alignment AL_SOFT_deferred_updates AL_SOFT_direct_channels AL_SOFTX_events AL_SOFTX_filter_gain_ex AL_SOFT_gain_clamp_ex AL_SOFT_loop_points AL_SOFTX_map_buffer AL_SOFT_MSADPCM AL_SOFT_source_latency AL_SOFT_source_length AL_SOFT_source_resampler AL_SOFT_source_spatialize
[12:49:42.665 I] HRTF disabled
[12:49:42.665 I] Allocated 256 sound sources
[12:49:42.665 I] Low-pass filter supported
[12:49:42.665 I] EAX Reverb supported
[12:49:42.677 I] Enumerated output devices:
[12:49:42.677 I]   Built-in Audio Headphones + Speakers
[12:49:42.678 I] Enumerated HRTF names:
[12:49:42.678 I]   default-44100  default-48000  Built-In 44100hz  Built-In 48000hz
[12:49:42.695 I] Loading content file builtin.omwscripts
[12:49:42.696 I] Loading content file Morrowind.esm
[12:49:44.342 I] Loading content file Tribunal.esm
[12:49:44.551 I] Loading content file Bloodmoon.esm
[12:49:45.960 W] Bullet was not compiled with multithreading support, 1 async thread will be used
[12:49:45.961 I] Using 1 async physics threads
[12:49:45.977 V] Using idle priority for thread=140093343749696
[12:49:45.980 V] Disabling Multiview (disabled by config)
[12:49:46.066 I] Preferred locales: en
[12:49:47.534 V] Fallback locale: en
[12:49:47.958 V] Language file "l10n/SettingsMenu/en.yaml" is enabled
[12:49:48.963 V] Fallback locale: en
[12:49:48.964 V] Language file "l10n/DebugMenu/en.yaml" is enabled
[12:49:48.975 V] Fallback locale: en
[12:49:48.977 V] Language file "l10n/PostProcessing/en.yaml" is enabled
[12:49:48.999 V] Lua scripts configuration (8 scripts):
[12:49:48.999 V] #0 PLAYER : scripts/omw/mwui/init.lua
[12:49:48.999 V] #1 GLOBAL : scripts/omw/settings/global.lua
[12:49:48.999 V] #2 PLAYER : scripts/omw/settings/player.lua
[12:49:48.999 V] #3 PLAYER : scripts/omw/camera/camera.lua
[12:49:48.999 V] #4 NPC CREATURE : scripts/omw/ai.lua
[12:49:48.999 V] #5 PLAYER : scripts/omw/console/player.lua
[12:49:48.999 V] #6 GLOBAL : scripts/omw/console/global.lua
[12:49:48.999 V] #7 CUSTOM : scripts/omw/console/local.lua
[12:49:48.999 I] Loading Lua storage ""/home/cl3v3r/.config/openmw/global_storage.bin"" (3 bytes)
[12:49:49.041 I] Loading Lua storage ""/home/cl3v3r/.config/openmw/player_storage.bin"" (366 bytes)
[12:49:49.270 I] Starting a new game
[12:49:49.294 V] Fallback locale: en
[12:49:49.295 V] Language file "l10n/Interface/en.yaml" is enabled
[12:49:49.302 V] Fallback locale: en
[12:49:49.308 V] Language file "l10n/OMWCamera/en.yaml" is enabled
[12:49:50.016 I] Changing to interior
[12:49:50.017 I] Loading cell Seyda Neen, Arrille's Tradehouse

I'm running with just game files no mods...and minimal settings:

Code: Select all

# This is the OpenMW user 'settings.cfg' file.  This file only contains
# explicitly changed settings.  If you would like to revert a setting
# to its default, simply remove it from this file.  For available
# settings, see the file 'files/settings-default.cfg' in our source repo or the documentation at:
#
#   https://openmw.readthedocs.io/en/master/reference/modding/settings/index.html

[Camera]
viewing distance = 20480

[Fog]
sky blending start = 0.8

[GUI]
color topic enable = true
stretch menu background = true

[Game]
NPCs avoid collisions = true
always allow stealing from knocked out actors = true
barter disposition change is permanent = true
followers attack on sight = true
only appropriate ammunition bypasses resistance = true
prevent merchant equipping = true
rebalance soul gem values = true
shield sheathing = true
show owned = 2
smooth movement = true
strength influences hand to hand = 1
swim upward correction = true
trainers training skills based on base skill = true
turn to movement direction = true
unarmed creature attacks damage armor = true
uncapped damage fatigue = true
use additional anim sources = true
use magic item animations = true
weapon sheathing = true

[Input]
toggle sneak = true
always run = true

[Map]
allow zooming = true
global = false

[Saves]
timeplayed = true
max quicksaves = 3

[Shadows]
enable indoor shadows = false

[Terrain]
object paging min size = 0.035

[Video]
resolution x = 1366
resolution y = 768
window mode = 0
window border = false
antialiasing = 2

[General]
texture mipmap = linear

[Sound]
music volume = 0.332233

[Water]
shader = true

[Shaders]
apply lighting to environment maps = true
auto use object specular maps = true
auto use terrain specular maps = true
auto use object normal maps = true
auto use terrain normal maps = true

[Windows]
inventory h = 0.420573
inventory w = 0.431918
inventory x = 0
inventory y = 0
map h = 0.528646
map w = 0.431186
map x = 0
map y = 0.421875
spells h = 0.951823
spells w = 0.24817
spells x = 0.75183
spells y = 0
stats h = 0.951823
stats w = 0.32284
stats x = 0.430454
stats y = 0

[Post Processing]
enabled = false
User avatar
psi29a
Posts: 5355
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: OpenMW fails to load after 2 separate updates today via Synaptic Package Manager

Post by psi29a »

I've been trouble shooting some things...

I recommend purging/remove anything openmw and mygui related. Then updating using the PPA, then pulling in openmw again.

Should be good to go (just tested on Lunar 23.04).

If you're still having issues, then try to get gdb installed, then via terminal run gdb openmw, it should trip up. In the terminal you can type 'bt' to get a backtrace and post it here if it's a crash.

User avatar
Cl3v3rP0tat0
Posts: 59
Joined: 14 Jul 2023, 03:03

Re: OpenMW fails to load after 2 separate updates today via Synaptic Package Manager

Post by Cl3v3rP0tat0 »

I recommend purging/remove anything openmw and mygui related. Then updating using the PPA, then pulling in openmw again.

I got some progress with the game - it now loads but for some reason no loading screens before it gets my test char in the game. But, I think you are right, I need to purge/remove do a clean install from the PPA again - something is not right. It was running perfect yesterday before the update today.

=========UPDATE===========

Ok, so I removed my Openmw install and deleted all my configs and stuff to start clean. Strangely, upon reinstall I have ended up with version 47 - I had 48 Release before. I got 48 release the first time I installed...?

Code: Select all

sudo apt-get update
sudo apt-get install openmw openmw-launcher

Image

I am not interested in 47, so I took a closer look...and followed this in order to get 48...I was using the regular install method, confusing! Still get 47 - something changed.

OpenMW packages for Ubuntu

Note: All the libs that are necessary to run OpenMW are included here, including the -dev packages for building it yourself.

Code: Select all

To use/install:
$ sudo apt-get install software-properties-common
$ sudo add-apt-repository ppa:openmw/openmw
$ sudo apt-get update
$ sudo apt-get install openmw openmw-launcher
User avatar
psi29a
Posts: 5355
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: OpenMW fails to load after 2 separate updates today via Synaptic Package Manager

Post by psi29a »

Are you running Jammy 22.04 ?

If you are, give it about 30 minutes from this post :)

User avatar
Cl3v3rP0tat0
Posts: 59
Joined: 14 Jul 2023, 03:03

Re: OpenMW fails to load after 2 separate updates today via Synaptic Package Manager

Post by Cl3v3rP0tat0 »

Linux Mint 21 is based on Ubuntu 22.04, that's jammy - I literally had 48 installed now it's only 47 coming down from the repo :(

If you are, give it about 30 minutes from this post :)

:P :P :P :P :P :P

UPDATE

The good news: I see and can install version 48 from my repo manager.

The bad news: I still am getting the weird issue of missing splash screens (purplish tinted blank screen) - even though the default splash folder is still in my Morrowind data file location and on top of that, I can't EXIT game via exit button, have to alt+F4 out.

I attribute/hunch that these UI type issues have something to do with squirrely with a MyGui update this morning that installed upon my once working Version 48...

Lastly, I located a lingering MyGui related package in Synaptic Manager that still showed installed after the complete removal of the 47, 49 and 48 installs: libmyguiengine3debian1v5 For some reason, removing openmw didn't remove that item.

I will install 48 again, that's all I want - I want to start building a Morrowind Rebirth short mod build - on 48 release.

....
Installed 48 -
I get this error:

The problem may be due to an incomplete installation of OpenMW.
Reinstalling OpenMW may resolve the problem.
Default settings already initialized

Post Reply