Page 1 of 1

Seems to not load mods on Steam Deck (Luxtorpeda)

Posted: 13 Nov 2022, 17:40
by Tomash

I've got OpenMW 0.48 RC2/RC4 running on both my Windows desktop and Linux laptop (Manjaro), syncing saves through pCloud, everything works peachy.

Now the last stage is adding Steam Deck to the set. I've got Luxtorpeda and OpenMW installed version 96a4108a16 - don't know which RC it is but must be 0.48 since it loads saves from Windows and Manjaro machines.

The only problem, and only on Deck, is that it seems to not load one single mod that I use, RunFaster -- -- for both new games and loading saved ones (on loading of course there's a dialog about save made with different set of mods). I've tried putting the mod in same directory as original data files, even renaming the mod files to lowercase, but still no cookie. How can I diagnose what's wrong?

Re: Seems to not load mods on Steam Deck (Luxtorpeda)

Posted: 21 Nov 2022, 14:53
by LoneWolf
luxtorpeda does things very different from typical openmw install methods.

The sourcecode for their scripts is on github ,
The openmw scripts can be found in the ... er/engines folder ( they provide 3 variants) .

You will have to ask luxtorpeda developers how/where to add mods.

Re: Seems to not load mods on Steam Deck (Luxtorpeda)

Posted: 23 Nov 2022, 10:48
by Tomash
I'm going to try OpenMW from a regular binary download and compare the results. I had no idea luxtorpeda customizes so heavily.