OpenMW Won't Run

General discussion regarding the OpenMW project.
For technical support, please use the Support subforum.
Post Reply
digitig
Posts: 3
Joined: 16 May 2022, 01:40

OpenMW Won't Run

Post by digitig »

I've created a fresh installation of Morrowind on a new computer (which won't run, which is why I tried OpenMW), installed OpenMw, ran the wizard, and everything seemed to go OK. But when I select "Play" in OpenMw I get a couple of notes of the theme and it minimises to the taskbar. If I open it from the taskbar I get the same couple of notes from the theme and it minimises again.

Where do I go from here?
mikeprichard
Posts: 100
Joined: 16 Dec 2018, 19:42

Re: OpenMW Won't Run

Post by mikeprichard »

I'm not a dev, but I suspect you'll need to post a lot more details (your config, operating system, exact version of OpenMW, possibly a video or logs if requested, etc.) so they can help you identify the issue. Good luck.
digitig
Posts: 3
Joined: 16 May 2022, 01:40

Re: OpenMW Won't Run

Post by digitig »

It's a Windows 11 system, with the Morrowind GotY files. I don't know how to find the version of OpenMW - it was the latest stable release when I downloaded it a few days ago.
digitig
Posts: 3
Joined: 16 May 2022, 01:40

Re: OpenMW Won't Run

Post by digitig »

It runs once when I first set it up. It fails on subsequent attempts to run it. If I run it from a console, I get the following. It seems some resources are not found, but I've not moved or deleted anything, just exited and restarted OpenMW.

[01:38:54.244 I] Loading config file: D:\Users\digit\Documents\My Games\OpenMW/openmw.cfg
[01:38:54.247 I] Loading config file: C:\Program Files\OpenMW 0.47.0/openmw.cfg [01:38:54.249 I] OpenMW version 0.47.0
[01:38:54.249 I] Revision: bac679d5f5
[01:38:54.249 I] Using default (English) font encoding.
[01:38:54.250 I] OSG version: 3.6.5
[01:38:54.250 I] SDL version: 2.0.12
[01:38:54.250 I] Loading settings file: C:\Program Files\OpenMW 0.47.0/defaults.bin
[01:38:54.251 I] Loading settings file: D:\Users\digit\Documents\My Games\OpenMW/settings.cfg
[01:38:55.075 I] Adding BSA archive C:\Program Files (x86)\Bethesda Softworks\Morrowind\Data Files\Morrowind.bsa
[01:38:55.085 I] Adding BSA archive C:\Program Files (x86)\Bethesda Softworks\Morrowind\Data Files\Tribunal.bsa
[01:38:55.088 I] Adding BSA archive C:\Program Files (x86)\Bethesda Softworks\Morrowind\Data Files\Bloodmoon.bsa
[01:38:55.101 I] Adding data directory resources\vfs
[01:38:55.105 I] Adding data directory C:\Program Files (x86)\Bethesda Softworks\Morrowind\Data Files
[01:38:55.138 I] Loading keybindings file: D:\Users\digit\Documents\My Games\OpenMW/input_v3.xml
[01:38:55.234 I] Initializing OpenAL...
[01:38:55.239 I] Opened "OpenAL Soft on Speakers (Realtek(R) Audio)"
[01:38:55.239 I] ALC Version: 1.1
[01:38:55.239 I] ALC Extensions: ALC_ENUMERATE_ALL_EXT ALC_ENUMERATION_EXT ALC_EXT_CAPTURE ALC_EXT_DEDICATED ALC_EXT_disconnect ALC_EXT_EFX ALC_EXT_thread_local_context ALC_SOFT_device_clock ALC_SOFT_HRTF ALC_SOFT_loopback ALC_SOFT_output_limiter ALC_SOFT_pause_device
[01:38:55.331 I] Vendor: OpenAL Community
[01:38:55.331 I] Renderer: OpenAL Soft
[01:38:55.331 I] Version: 1.1 ALSOFT 1.20.1
[01:38:55.331 I] Extensions: AL_EXT_ALAW AL_EXT_BFORMAT AL_EXT_DOUBLE AL_EXT_EXPONENT_DISTANCE AL_EXT_FLOAT32 AL_EXT_IMA4 AL_EXT_LINEAR_DISTANCE AL_EXT_MCFORMATS AL_EXT_MULAW AL_EXT_MULAW_BFORMAT AL_EXT_MULAW_MCFORMATS AL_EXT_OFFSET AL_EXT_source_distance_model AL_EXT_SOURCE_RADIUS AL_EXT_STEREO_ANGLES AL_LOKI_quadriphonic AL_SOFT_bformat_ex AL_SOFT_block_alignment AL_SOFT_deferred_updates AL_SOFT_direct_channels AL_SOFT_direct_channels_remix AL_SOFTX_effect_chain AL_SOFTX_events AL_SOFTX_filter_gain_ex AL_SOFT_gain_clamp_ex AL_SOFT_loop_points AL_SOFTX_map_buffer AL_SOFT_MSADPCM AL_SOFT_source_latency AL_SOFT_source_length AL_SOFT_source_resampler AL_SOFT_source_spatialize
[01:38:55.333 I] HRTF disabled
[01:38:55.334 I] Allocated 256 sound sources
[01:38:55.334 I] Low-pass filter supported
[01:38:55.334 I] EAX Reverb supported
[01:38:55.336 I] Enumerated output devices:
[01:38:55.336 I] OpenAL Soft on Speakers (Realtek(R) Audio) OpenAL Soft on DELL S2421HS (HD Audio Driver for Display Audio) OpenAL Soft on Speakers (Focusrite Usb Audio) OpenAL Soft on BenQ PD2710QC (2- HD Audio Driver for Display Audio)
[01:38:55.337 I] Enumerated HRTF names:
[01:38:55.337 I] Built-In HRTF
[01:38:55.337 E] Failed to open video: Resource 'video/bethesda logo.bik' not found
[01:38:55.343 I] Loading content file Morrowind.esm
[01:38:56.318 I] Loading content file Tribunal.esm
[01:38:56.405 I] Loading content file Bloodmoon.esm
[01:38:56.762 V] Using idle priority for thread=32064
[01:38:56.842 I] Playing music/special/morrowind title.mp3
[01:38:56.845 E] Failed to open video: Resource 'video/mw_logo.bik' not found
EvilEye
Posts: 29
Joined: 12 Feb 2014, 13:45
Gitlab profile: https://gitlab.com/Assumeru

Re: OpenMW Won't Run

Post by EvilEye »

If the location where you installed Morrowind is any indication, you're using the disk version. Which is fine, but it doesn't install the non-expansion videos because it expects to read those from the disk while you're playing. You can just copy them off the disk and put them in the Video folder.

OpenMW should start without those though...
Post Reply