Linux build - cursor invisible after updating some system packages

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
syscall
Posts: 6
Joined: 11 Sep 2018, 09:25

Linux build - cursor invisible after updating some system packages

Post by syscall » 05 Nov 2018, 10:58

Using the 0.44 x64 build on my gentoo system, built from source.

Last weekend i did a standard system update, just a few packages, everything went smooth.

Yesterday when i started openmw, i saw, that the mouse cursor became invisible.
I can navigate trough the menus but i can't see the cursor.

Tried the following things:
- rebuild and even downgrade mesa
- rebuild openmw
- rebuild libsdl2

other things work normally, but the strangest thing is that i suspesct the problem is because of the update of system packages BUT in the meantime openmw was NOT rebuilt.
looked over the log file and everything seemed normal.
it's not a mod/plugin problem either and nothing was changed in the config file for the game.

syscall
Posts: 6
Joined: 11 Sep 2018, 09:25

Re: Linux build - cursor invisible after updating some system packages

Post by syscall » 06 Nov 2018, 19:48

update:
weird thing is, that if i apply this mod: https://www.nexusmods.com/morrowind/mod ... escription
the Arena cursor shows up
i copied the esm and bsa files over again thinking it's a corruption, but the cursor still does not show up

i30817
Posts: 17
Joined: 07 Nov 2018, 05:56
Github profile: https://github.com/i30817

Re: Linux build - cursor invisible after updating some system packages

Post by i30817 » 11 Nov 2018, 00:27

How are you installing mods? I recently had trouble with 'missing' files (including the cursor) after some mod upgrades, and it turns out that a bsa wasn't registered and that short circuited even unrelated things before (somehow).

syscall
Posts: 6
Joined: 11 Sep 2018, 09:25

Re: Linux build - cursor invisible after updating some system packages

Post by syscall » 11 Nov 2018, 10:34

i just copied files over into the data folder, when installed any mod.

before the bug happening, i did absolutely no modification to the game installation, no mod/texture/mesh/plugin was installed or removed.
i played the game for a long time until this, just finished the tribunal quest after finishing the main quest.

what is even stranger, that i found an old tool, called bsaextract, used wine to extract all files from the bsa file into a temporary directory, then copy the 4 cursor files over.
it still did not work.
then i renamed them with case-sensitivity to look like then files from the arena cursor package and it still does not work.
yet when i copied the arena cursor mod, it works instantly.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests