Missing or Garbled Cursor when Building on High Sierra

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
User avatar
Posts: 4
Joined: 10 Mar 2018, 22:26

Missing or Garbled Cursor when Building on High Sierra

Post by tobin » 16 May 2018, 03:24

Hi all, sorry if this is the wrong place for this post. I just wanted to discuss a build issue that I think I finally resolved.

I spent the past few days trying to build OpenMW on my 13" 2015 MacBook Pro running High Sierra, but I kept getting an issue where the cursor would be missing or garbled on load. The cursor worked fine on the release binaries, so clearly something was up with my build. After fiddling with things, making and re-making, I finally remembered that the ReadMe for openmw-deps-mac noted that only the SDK's for 10.11 and 10.12 were supported. After using a tool to download the 10.12 SDK, I built the project using that and the pre-built dependencies and sure enough it worked! I didn't see this noted on the build instructions on the wiki page, so I didn't think to try it until pretty late in the process.

Has anyone else run into this issue trying to build on High Sierra (10.13)? At a glance the stderr output for a build on 10.12 and 10.13 is similar, but I'd have to run another build on 10.13 to take the diff.

Post Reply