OpenMW 0.47.0

Anything related to PR, release planning and any other non-technical idea how to move the project forward should be discussed here.
User avatar
Ace (SWE)
Posts: 863
Joined: 15 Aug 2011, 14:56

Re: OpenMW 0.47.0

Post by Ace (SWE) »

User avatar
AnyOldName3
Posts: 2216
Joined: 26 Nov 2015, 03:25

Re: OpenMW 0.47.0

Post by AnyOldName3 »

And it's been done as a release build with the extra flags to generate PDBs added to the build flag settings rather than being a RelWithDebInfo build with the setting to have the console disabled, right?
AnyOldName3, Master of Shadows
User avatar
Ace (SWE)
Posts: 863
Joined: 15 Aug 2011, 14:56

Re: OpenMW 0.47.0

Post by Ace (SWE) »

AnyOldName3 wrote: 25 Aug 2021, 22:26 And it's been done as a release build with the extra flags to generate PDBs added to the build flag settings rather than being a RelWithDebInfo build with the setting to have the console disabled, right?
Yep, and I realized I'd forgotten to enable LTO as well, so it's a full Release build with LTO and /Zi or /debug flags where necessary.
User avatar
psi29a
Posts: 5131
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: OpenMW 0.47.0

Post by psi29a »

User avatar
AnyOldName3
Posts: 2216
Joined: 26 Nov 2015, 03:25

Re: OpenMW 0.47.0

Post by AnyOldName3 »

It's probably worth posting the PDBs somewhere so we can diagnose crashes in the RC (if any more of them happen).
AnyOldName3, Master of Shadows
K1ll
Posts: 164
Joined: 06 Aug 2011, 21:54

Re: OpenMW 0.47.0

Post by K1ll »

Linux generic targz package RC7:

64 Bit
halcyon
Posts: 17
Joined: 05 Dec 2018, 00:32

Re: OpenMW 0.47.0

Post by halcyon »

The macOS RC7 has worked for me on a 2017 MacBook running OS 11.4. Loading times are longer than in 0.46 and play is sometimes a little choppy, but that may reflect this machine's age and Intel graphics. Editing some plugin scripts in the CS worked fine, again with noticeably longer load times.

Unlike earlier RC's (and like 0.46 and before), the game launched without a "too many open files" error, without requiring system tweaks... I don't know whether this is due to changes in the code since the last RC or because I've simplified my mod list in the meantime, but it is welcome either way.
User avatar
psi29a
Posts: 5131
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: OpenMW 0.47.0

Post by psi29a »

halcyon wrote: 29 Aug 2021, 09:13 The macOS RC7 has worked for me on a 2017 MacBook running OS 11.4. Loading times are longer than in 0.46 and play is sometimes a little choppy, but that may reflect this machine's age and Intel graphics. Editing some plugin scripts in the CS worked fine, again with noticeably longer load times.
Possibly because of changes in lighting system and also other features that are now online. We also take more care in setting things up, as to make sure we're not in a crashy state. We've been working on performance in 0.48... the basic: implement feature for release, then polish for next release.

You have OP/AG turned on? Have you tried messing around with the types of lighting? We default to shader based lighting by default now in 0.47
halcyon
Posts: 17
Joined: 05 Dec 2018, 00:32

Re: OpenMW 0.47.0

Post by halcyon »

Thanks for the response! I don't think performance has suffered much compared to 0.46, apart from loading times. This is a pretty underpowered machine for gaming. I have gone to legacy mode for lighting, which may have helped a little, and disabling "build nav mesh" in the options at startup did away with much of the increase in load times. No complaints here, though further optimization in later versions would be welcome, too.
HelloWorld
Posts: 2
Joined: 18 Jul 2021, 05:42

Re: OpenMW 0.47.0

Post by HelloWorld »

halcyon wrote: 03 Sep 2021, 10:35 Thanks for the response! I don't think performance has suffered much compared to 0.46, apart from loading times. This is a pretty underpowered machine for gaming. I have gone to legacy mode for lighting, which may have helped a little, and disabling "build nav mesh" in the options at startup did away with much of the increase in load times. No complaints here, though further optimization in later versions would be welcome, too.
HelloWorld wrote: 18 Jul 2021, 09:47 Hello, dears! I'm openmw user since 0.45.0 version. It is cool! I use it with Full Rest plugins of _AL_.
How to get 0.47.0 RC5 for Windows x86_64?
Linux is cool but Windows is stil more popular for games.

I also use save\load abuse to get better loot from Balmora boxes (enchated rings, weapon, etc). AND i feel that openmw 0.47.0 is slower than 0.46.0 which i have along on my windows 8.1. When I load F9 then i see message (build navigation mesh) in load screen. I guess this is new feature that allow to move NPC more freely on gorund and build its route as it wants. But building navigation mesh feature is slow down quickload process (more time demanding, and i feel it exactly when i play in 0.47 rather than 0.46). I hope it was noticed and fixed in RC5-6 or I can try to describe it more detailed to help fix.

Sorry for my bad grammar, I'm not native eng speaker.
Post Reply