Android part 2

For new and upcoming OpenMW branches and ports; move fast and break things!
xyzz
Posts: 156
Joined: 14 Jan 2018, 22:25

Re: Android part 2

Post by xyzz »

https://github.com/xyzz/openmw-android/ ... 37-nightly
- Updated OpenMW to 99ab629a03cbe22e24568dd91734983bec45c3d3
WelcomeToDie
Posts: 1
Joined: 12 Sep 2020, 13:01

Re: Android part 2

Post by WelcomeToDie »

For some reason, a few UI elements dissapeared after multiple APK re-intallations. I decided to download custom UI (Monochrome user inteface), and it partially fixed the problem. Now only map markers are missing. What is the name of the red map marker file and which folder it should be in? I have made a .dds file for it already.

I don't know if this is the right thread to ask that question, so please tell me if I should ask on other boards.
pulion
Posts: 40
Joined: 26 Dec 2018, 07:45

Re: Android part 2

Post by pulion »

xyzz wrote: 07 Sep 2020, 04:13 https://github.com/xyzz/openmw-android/ ... 37-nightly
- Updated OpenMW to 99ab629a03cbe22e24568dd91734983bec45c3d3
Are you planning to update your nightly APK file based on OpenMV 0.47 in the playmarket? there have been a lot of changes over the last month.
DarkSpectre
Posts: 9
Joined: 11 May 2020, 06:58

Re: Android part 2

Post by DarkSpectre »

Anyone managed to get any port of OpenMW to work on Android 11? I get either force closes or black screens.
DarkSpectre
Posts: 9
Joined: 11 May 2020, 06:58

Re: Android part 2

Post by DarkSpectre »

*checks the thread, two weeks later*

*SMH*
reddragon72
Posts: 59
Joined: 06 Apr 2019, 20:11

Re: Android part 2

Post by reddragon72 »

So I am trying something totally different.

I am attempting to run OMW in desktop mode and here are my findings so far on my LG V60

The app opens on the monitor but the game kicks over to the phone screen.
Opening the app within the LG Games app results in the app opening on the monitor and the game stays in a window on the monitor but
1. the window is to small for the game so it is all cut off.
2. any attempt to resize or full screen the game results in the game disappearing.
3. can get the game to play but cannot see the whole screen and the overlay UI is all squashed

Will attch some screenshots later.
Also going to try the latest download here as well.

I am very interested in getting this working in Android Desktop Mode
DarkSpectre
Posts: 9
Joined: 11 May 2020, 06:58

Re: Android part 2

Post by DarkSpectre »

I just received an OTA update for my device. OMW Nightly from Google Play Store is now working again. I'd still prefer using the debug version due to compatibility with vtastek's shaders. Unfortunately, it crashes when I try to choose the game files, unlike the Play Store version.
pulion
Posts: 40
Joined: 26 Dec 2018, 07:45

Re: Android part 2

Post by pulion »

greetings! Xyzz, on your latest APK 0.47-41, errors occur on my device, which later lead to game crashes. Is it possible to fix them in your next builds?

Code: Select all

[12:18:48.698 W] Warning: detected OpenGL error 'invalid enumerant' at after RenderBin::draw(..)
[12:18:48.743 W] Warning: detected OpenGL error 'invalid enumerant' at after RenderBin::draw(..)
[12:18:48.944 W] Warning: detected OpenGL error 'invalid enumerant' at after RenderBin::draw(..)
[12:18:49.242 W] Warning: detected OpenGL error 'invalid enumerant' at after RenderBin::draw(..)
[12:18:49.527 W] Warning: detected OpenGL error 'invalid enumerant' at after RenderBin::draw(..)
[12:18:50.332 W] Warning: detected OpenGL error 'invalid enumerant' at after RenderBin::draw(..)
Clement
Posts: 9
Joined: 03 Jul 2018, 10:41

Re: Android part 2

Post by Clement »

Hi, I want to install OpenMW on Android using the data files from a desktop OpenMW installation, not a Morrowind installation. There is no Morrowind.ini so the documented method does not work. I have a openmw.cfg ready, how should I proceed? I am using f-droid nightly version if that matters.
Clement
Posts: 9
Joined: 03 Jul 2018, 10:41

Re: Android part 2

Post by Clement »

I had a look at the source code, and if I understood correctly, there is always a check for Morrowind.ini on startup even if openmw.cfg is not being generated.

So I imported a full Morrowind installation, then I placed my openmw.cfg in /storage/emulated/0/omw_nightly/config. But the data= lines are not used. The file is read (at least the content= lines) because it tries to load plugins but fails when it cannot find them (because of the missing data directories).

Code: Select all

[11:31:22.157 I] Loading config file: /storage/emulated/0/omw_nightly/config/openmw.cfg
[11:31:22.173 I] Loading config file: /data/user/0/is.xyz.omw_nightly/files/config/openmw.cfg
[11:31:22.192 I] OpenMW version 0.47.0
[11:31:22.192 I] Using default (English) font encoding.
[11:31:22.195 I] OSG version: 3.6.5
[11:31:22.195 I] SDL version: 2.0.12
[11:31:22.197 I] Loading settings file: /data/user/0/is.xyz.omw_nightly/files/config/settings-default.cfg
[11:31:22.199 I] Loading settings file: /storage/emulated/0/omw_nightly/config/settings.cfg
[11:31:22.235 W] Warning: GraphicsContext::WindowingSystemInterfaces::getWindowingSystemInterface() failed,
[11:31:22.239 I] Adding BSA archive /storage/emulated/0/openmw/Morrowind/Data Files/Morrowind.bsa
[11:31:22.332 I] Adding BSA archive /storage/emulated/0/openmw/Morrowind/Data Files/Tribunal.bsa
[11:31:22.346 I] Adding BSA archive /storage/emulated/0/openmw/Morrowind/Data Files/Bloodmoon.bsa
[11:31:22.358 I] Adding data directory /data/user/0/is.xyz.omw_nightly/files/resources/vfs
[11:31:22.358 I] Adding data directory /storage/emulated/0/openmw/Morrowind/Data Files
[11:31:22.942 I] Loading keybindings file: /storage/emulated/0/omw_nightly/config/input_v3.xml
[11:31:23.187 I] Initializing OpenAL...
[11:31:23.189 I] Opened "OpenSL"
[11:31:23.190 I]   ALC Version: 1.1
[11:31:23.190 I]   ALC Extensions: ALC_ENUMERATE_ALL_EXT ALC_ENUMERATION_EXT ALC_EXT_CAPTURE ALC_EXT_DEDICA
[11:31:23.212 I]   Vendor: OpenAL Community
[11:31:23.212 I]   Renderer: OpenAL Soft
[11:31:23.212 I]   Version: 1.1 ALSOFT 1.19.1
[11:31:23.212 I]   Extensions: AL_EXT_ALAW AL_EXT_BFORMAT AL_EXT_DOUBLE AL_EXT_EXPONENT_DISTANCE AL_EXT_FLO
[11:31:23.212 I] HRTF disabled
[11:31:23.212 I] Allocated 256 sound sources
[11:31:23.213 I] Low-pass filter supported
[11:31:23.213 I] EAX Reverb supported
[11:31:23.213 I] Enumerated output devices:
[11:31:23.213 I]   OpenSL
[11:31:23.213 I] Enumerated HRTF names:
[11:31:23.213 I]   Built-In 44100hz  Built-In 48000hz
[11:31:23.218 E] Failed to open video: Resource 'video/bethesda logo.bik' not found
[11:31:23.242 I] Loading content file Morrowind.esm
[11:31:24.430 I] Loading content file Tribunal.esm
[11:31:24.689 I] Loading content file Bloodmoon.esm
[11:31:27.501 E] Error: Failed loading Patch for Purists.esm: the content file does not exist
Only two data directories are added and I am not sure where they are from: /storage/emulated/0/openmw/Morrowind/Data Files is in /data/user/0/is.xyz.omw_nightly/files/config/openmw.cfg but not /data/user/0/is.xyz.omw_nightly/files/resources/vfs. None of the data directories from /storage/emulated/0/omw_nightly/config/openmw.cfg are added.
Post Reply