Simple Picture Frame (Solved)

Learn about OpenMW mod compatibility, check for problematic mods, discuss issues, and give us feedback about your experience with modded OpenMW.
Post Reply
UnderSunandSky
Posts: 4
Joined: 10 Dec 2019, 22:56

Simple Picture Frame (Solved)

Post by UnderSunandSky » 11 Dec 2019, 00:17

Hi guys

Im trying to make the house I made OpenMW friendly. Theres only one problem, thats a map I made.

Heres what it should look like

https://imgur.com/AJfq86M

Heres what it does look like

https://imgur.com/d1v0Zbw

Any suggestions? Im an utter beginner, but I have NifSkope, Blendr and Paint.net
Last edited by UnderSunandSky on 11 Dec 2019, 19:25, edited 1 time in total.

User avatar
akortunov
Posts: 689
Joined: 13 Mar 2017, 13:49
Location: Samara, Russian Federation

Re: Simple Picture Frame

Post by akortunov » 11 Dec 2019, 05:52

Check your openmw.log. Your texture may be missing, or use unsupported data format.

UnderSunandSky
Posts: 4
Joined: 10 Dec 2019, 22:56

Re: Simple Picture Frame

Post by UnderSunandSky » 11 Dec 2019, 15:41

Yep, missing texture.

Failed to open image: Resource 'textures/f:/openmorrowind/data files/textures/usas/usas_map.dds' not found

but the texture is definitely in there.

Its saved as a .DDS file, BC1, Linear, DXT1, with BC6H / BC7 Compression Mode. Perceptual Error Metric, no cube maps, no mip maps.
(Im just reading out the export settings on Paint.net)

https://imgur.com/g7WXJSR

My Nifskope settings are here

https://imgur.com/eLjAhkW

So why does it work in normal'wind, and not OpenMW?

Also, nifskope is saying that the mesh is looking for the texture in F:\OpenMorrowind\Data Files\Textures\USaS\

Does that mean, if someone on the internet downloads my mod, theyll probably be installing it into a different directory and the textures definitely wont work for them? Shouldnt the mesh just look in the Data Files parent directory?

User avatar
Capostrophic
Posts: 713
Joined: 22 Feb 2016, 20:32

Re: Simple Picture Frame

Post by Capostrophic » 11 Dec 2019, 18:56

The path is broken, make it relative, not absolute. It was never going to work on any PC but your own either way.
Remove the part before the second "textures" in the mesh file path.

UnderSunandSky
Posts: 4
Joined: 10 Dec 2019, 22:56

Re: Simple Picture Frame

Post by UnderSunandSky » 11 Dec 2019, 19:24

IT WORKS!

So I changed the file path. Turns out you can just double click that part and erase the text manually.

It then looked like this

https://imgur.com/RA5VVml

the NifSkope preview couldnt load the textures, but when I loaded OpenMW, I have a map on the wall! I made a mesh work!

Thankyou both for your help. May you walk on warm sands!

UnderSunandSky
Posts: 4
Joined: 10 Dec 2019, 22:56

Re: Simple Picture Frame (Solved)

Post by UnderSunandSky » 12 Dec 2019, 10:15

My house mod is up on Nexus and it works on OpenMW.

https://www.nexusmods.com/morrowind/mods/46138

Thankyou for your help.

Post Reply