Crash on launch, related to playing video

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
bably
Posts: 9
Joined: 24 May 2019, 22:42

Crash on launch, related to playing video

Post by bably » 29 May 2019, 23:33

Hello o/

So, as I mentioned in this thread, after compiling successfully a very recent commit from 0.46, my game is crashing when I press the "Play" button from the launcher.

For some info: I'm using Ubuntu 18.04 on a 32 bit architecture, with an ARM processor (it's a chroot running in a chromebook using crouton).
I managed to compile the master very recently, and never got the game working in this machine before.

I'd like to note that the logs I have are virtually the same as the ones from this person:
viewtopic.php?t=5743
But unlike him, I haven't tweaked any source file.

The logs I'm getting from the console are the following:

Code: Select all

QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
libEGL warning: DRI2: failed to authenticate
Loading config file: launcher.cfg
Loading config file: /home/blupiac/.config/openmw/launcher.cfg
Loading config file: /home/blupiac/.config/openmw/openmw.cfg
Loading config file: /usr/local/etc/openmw/openmw.cfg
QFile::setFileName: File (/home/blupiac/.config/openmw/openmw.cfg) is already opened
Loading config file: ./openmw.cfg
Loading config file: /home/blupiac/.config/openmw/openmw.cfg
Loading settings file: ./settings-default.cfg
The current profile is:  "2019-05-29T18:40:57"
(morrowmachine)[email protected]:~/openmw/build$ Crash handler installed
Loading config file: /home/blupiac/.config/openmw/openmw.cfg
Loading config file: ./openmw.cfg
OpenMW version 0.46.0
Revision: e0fb411fc8
Using default (English) font encoding.
OSG version: 3.4.1
SDL version: 2.0.8
Loading settings file: ./settings-default.cfg
Adding BSA archive /home/blupiac/Morrowind/Data Files/Morrowind.bsa
Adding BSA archive /home/blupiac/Morrowind/Data Files/Tribunal.bsa
Adding BSA archive /home/blupiac/Morrowind/Data Files/Bloodmoon.bsa
Adding data directory /home/blupiac/Morrowind/Data Files
Got an X11ErrorHandling call display=0x33594c0 event=0xbeab43dc
BadMatch (invalid parameter attributes)
Major opcode: 130
Minor opcode: 3
Error code: 8
Request serial: 46
Current serial: 47
  ResourceID: 62914566
Got an X11ErrorHandling call display=0x3755ac0 event=0xbeab43dc
BadMatch (invalid parameter attributes)
Major opcode: 130
Minor opcode: 3
Error code: 8
Request serial: 46
Current serial: 47
  ResourceID: 62914566
Got an X11ErrorHandling call display=0x3822bb8 event=0xbeab43dc
BadMatch (invalid parameter attributes)
Major opcode: 130
Minor opcode: 3
Error code: 8
Request serial: 46
Current serial: 47
  ResourceID: 62914566
Got an X11ErrorHandling call display=0x3822ba8 event=0xbeab43dc
BadMatch (invalid parameter attributes)
Major opcode: 130
Minor opcode: 3
Error code: 8
Request serial: 46
Current serial: 47
  ResourceID: 62914566
Got an X11ErrorHandling call display=0x3822ba8 event=0xbeab43dc
BadMatch (invalid parameter attributes)
Major opcode: 130
Minor opcode: 3
Error code: 8
Request serial: 46
Current serial: 47
  ResourceID: 62914566
Got an X11ErrorHandling call display=0x3822ba8 event=0xbeab43dc
BadMatch (invalid parameter attributes)
Major opcode: 130
Minor opcode: 3
Error code: 8
Request serial: 46
Current serial: 47
  ResourceID: 62914566
Initializing OpenAL...
Opened "cras"
  ALC Version: 1.1
  ALC Extensions: ALC_ENUMERATE_ALL_EXT ALC_ENUMERATION_EXT ALC_EXT_CAPTURE ALC_EXT_DEDICATED ALC_EXT_disconnect ALC_EXT_EFX ALC_EXT_thread_local_context ALC_SOFTX_device_clock ALC_SOFT_HRTF ALC_SOFT_loopback ALC_SOFT_output_limiter ALC_SOFT_pause_device
  Vendor: OpenAL Community
  Renderer: OpenAL Soft
  Version: 1.1 ALSOFT 1.18.2
  Extensions: AL_EXT_ALAW AL_EXT_BFORMAT AL_EXT_DOUBLE AL_EXT_EXPONENT_DISTANCE AL_EXT_FLOAT32 AL_EXT_IMA4 AL_EXT_LINEAR_DISTANCE AL_EXT_MCFORMATS AL_EXT_MULAW AL_EXT_MULAW_BFORMAT AL_EXT_MULAW_MCFORMATS AL_EXT_OFFSET AL_EXT_source_distance_model AL_EXT_SOURCE_RADIUS AL_EXT_STEREO_ANGLES AL_LOKI_quadriphonic AL_SOFT_block_alignment AL_SOFT_deferred_updates AL_SOFT_direct_channels AL_SOFT_gain_clamp_ex AL_SOFT_loop_points AL_SOFT_MSADPCM AL_SOFT_source_latency AL_SOFT_source_length AL_SOFT_source_resampler AL_SOFT_source_spatialize
HRTF disabled
Allocated 256 sound sources
Low-pass filter supported
EAX Reverb supported
Enumerated output devices:
  cras
Enumerated HRTF names:
  default-44100  default-48000
Input #0, bink, from 'video\bethesda logo.bik':
  Duration: 00:00:16.00, start: 0.000000, bitrate: 2324 kb/s
    Stream #0:0[0x0]: Video: binkvideo (BIKi / 0x694B4942), yuv420p, 640x480, 30.06 fps, 30.06 tbr, 30.06 tbn, 30.06 tbc
    Stream #0:1[0x0]: Audio: binkaudio_rdft, 44100 Hz, stereo, flt
[swscaler @ 0xa2671af0] No accelerated colorspace conversion found from yuv420p to rgba.


*** Fatal Error ***
Invalid address alignment (signal 7)
Address: 0x98ed3008

Generating /home/blupiac/.config/openmw/openmw-crash.log and killing process 16600, please wait... 46	../sysdeps/unix/sysv/linux/arm/libc-do-syscall.S: No such file or directory.

I should also say that the Morrowind files I'm using are from a window installation from Steam. Will this cause any problem?

Also, the guy from the other thread mentions that skipping the menu is a workaround that works for him. Any idea of what arguments would allow me to do that?

Besides that, any idea on how to solve this problem? Looks like it's related to ffmpeg and playing videos, but I don't really know what's happening.

Any help with this would be greatly appreciated! :)

User avatar
AnyOldName3
Posts: 1553
Joined: 26 Nov 2015, 03:25

Re: Crash on launch, related to playing video

Post by AnyOldName3 » 30 May 2019, 01:35

I think skip menu is just --skipmenu as a command-line option, or

Code: Select all

skipmenu=true
in OpenMW.cfg
AnyOldName3, Master of Shadows

User avatar
akortunov
Posts: 621
Joined: 13 Mar 2017, 13:49
Location: Samara, Russian Federation

Re: Crash on launch, related to playing video

Post by akortunov » 30 May 2019, 04:42

Post your openmw-crash.log

bably
Posts: 9
Joined: 24 May 2019, 22:42

Re: Crash on launch, related to playing video

Post by bably » 30 May 2019, 04:52

Hello again AnyOldName3,

I'll answer both your replies here to avoid having to go back and forth between those threads :)

For the dependencies: I didn't compile anything in the first place, so I figured that an apt-get update + apt-get install of the libs listed in this section of the Developer Environment Setup would be enough.
For openmw itself, I deleted the build folder after upgrading to 18.04.
Should I try to build any one of the dependencies with any parameter in particular?

And sadly the game crashed with the same error when I used the skipmenu argument :/

bably
Posts: 9
Joined: 24 May 2019, 22:42

Re: Crash on launch, related to playing video

Post by bably » 30 May 2019, 05:36

Hi akortunov,

I'm sending the crash log as an attachment.
Attachments
openmw-crash.log
(60.69 KiB) Downloaded 46 times

User avatar
Capostrophic
Posts: 660
Joined: 22 Feb 2016, 20:32

Re: Crash on launch, related to playing video

Post by Capostrophic » 30 May 2019, 06:12

Seems to be the same crash as the one here

Post Reply