Failed to Open Audio Device on Windows 10

Everything having to do with OpenMW's TES3MP branch.
Post Reply
dogmellow
Posts: 5
Joined: 27 Mar 2019, 20:38

Failed to Open Audio Device on Windows 10

Post by dogmellow » 27 Mar 2019, 20:42

I recently installed OpenMW a couple of days ago and have been having consistent issues with the client not recognizing my audio output device. Any help would be appreciated. Below is what displays on my log when I boot it up.

Code: Select all

Loading config file: C:\Users\theoa\Documents\My Games\OpenMW/openmw.cfg... done.
Loading config file: ./openmw.cfg... done.
TES3MP client 0.7.0-alpha (Windows 32-bit)
Protocol version: 7
Oldest compatible commit hash: 292536439e
------------------------------------------------------------
OpenMW version 0.44.0
Using default (English) font encoding.
[2019-03-27 15:41:22] [INFO]: tes3mp started
Loading settings file: ./tes3mp-client-default.cfg
[2019-03-27 15:41:23] [WARN]: Received ID_CONNECTION_REQUESTED_ACCEPTED from 52.15.227.77|25565
idx: 0  checksum: 7B6AF5B9      file: C:\Program Files (x86)\Steam\steamapps\common\Morrowind\Data Files\Morrowind.esm
idx: 1  checksum: F481F334      file: C:\Program Files (x86)\Steam\steamapps\common\Morrowind\Data Files\Tribunal.esm
idx: 2  checksum: 43DD2132      file: C:\Program Files (x86)\Steam\steamapps\common\Morrowind\Data Files\Bloodmoon.esm
OSG version: 3.4.1
Loading settings file: ./settings-default.cfg
Loading settings file: C:\Users\theoa\Documents\My Games\OpenMW/settings.cfg
Adding BSA archive C:\Program Files (x86)\Steam\steamapps\common\Morrowind\Data Files\Morrowind.bsa
Adding BSA archive C:\Program Files (x86)\Steam\steamapps\common\Morrowind\Data Files\Tribunal.bsa
Adding BSA archive C:\Program Files (x86)\Steam\steamapps\common\Morrowind\Data Files\Bloodmoon.bsa
Adding data directory C:\Program Files (x86)\Steam\steamapps\common\Morrowind\Data Files
Initializing OpenAL...
Failed to open "Speaker/Headphones", trying default
Failed to open default audio device
Failed to initialize audio output, sound disabled
Loading content file Morrowind.esm
Loading content file Tribunal.esm
Loading content file Bloodmoon.esm
Loading settings file: ./tes3mp-client-default.cfg

User avatar
AnyOldName3
Posts: 1531
Joined: 26 Nov 2015, 03:25

Re: Failed to Open Audio Device on Windows 10

Post by AnyOldName3 » 27 Mar 2019, 20:48

That's a log from TES3MP, which isn't quite the same thing as OpenMW. I'm not sure of the specific cause of this issue, but it may be easier to get the attention of someone who can by mentioning that it's TES3MP. If I can figure out how, I'll move this to the right forum section, too.
AnyOldName3, Master of Shadows

dogmellow
Posts: 5
Joined: 27 Mar 2019, 20:38

Re: Failed to Open Audio Device on Windows 10

Post by dogmellow » 27 Mar 2019, 20:56

Ah thank you, figured this was the right place to put it, my mistake.

davidcernat
Posts: 198
Joined: 19 Jul 2016, 01:02

Re: Failed to Open Audio Device on Windows 10

Post by davidcernat » 27 Mar 2019, 21:19

One easy way to find out... can you install regular singleplayer OpenMW and check if the sound works fine in it?

dogmellow
Posts: 5
Joined: 27 Mar 2019, 20:38

Re: Failed to Open Audio Device on Windows 10

Post by dogmellow » 27 Mar 2019, 21:34

I have just installed it and I am able to hear audio. Should I post the log?

davidcernat
Posts: 198
Joined: 19 Jul 2016, 01:02

Re: Failed to Open Audio Device on Windows 10

Post by davidcernat » 27 Mar 2019, 21:37

Please do.

dogmellow
Posts: 5
Joined: 27 Mar 2019, 20:38

Re: Failed to Open Audio Device on Windows 10

Post by dogmellow » 27 Mar 2019, 21:38

Code: Select all

Loading config file: C:\Users\theoa\Documents\My Games\OpenMW/openmw.cfg... done.
Loading config file: ./openmw.cfg... done.
OpenMW version 0.44.0
Revision: ef85b1393a
Using default (English) font encoding.
OSG version: 3.4.1
StatsHandler::StatsHandler() Setting up GL2 compatible shaders
Loading settings file: ./settings-default.cfg
Loading settings file: C:\Users\theoa\Documents\My Games\OpenMW/settings.cfg
Adding BSA archive C:\Program Files (x86)\Steam\steamapps\common\Morrowind\Data Files\Morrowind.bsa
Adding BSA archive C:\Program Files (x86)\Steam\steamapps\common\Morrowind\Data Files\Tribunal.bsa
Adding BSA archive C:\Program Files (x86)\Steam\steamapps\common\Morrowind\Data Files\Bloodmoon.bsa
Adding data directory C:\Program Files (x86)\Steam\steamapps\common\Morrowind\Data Files
Initializing OpenAL...
AL lib: (EE) ALCmmdevPlayback_open: Device init failed: 0x80004005
Failed to open "Speaker/Headphones", trying default
Opened "OpenAL Soft on Speaker/Headphone (Realtek High Definition Audio)"
  ALC Version: 1.1
  ALC Extensions: ALC_ENUMERATE_ALL_EXT ALC_ENUMERATION_EXT ALC_EXT_CAPTURE ALC_EXT_DEDICATED ALC_EXT_disconnect ALC_EXT_EFX ALC_EXT_thread_local_context ALC_SOFTX_device_clock ALC_SOFT_HRTF ALC_SOFT_loopback ALC_SOFT_pause_device
  Vendor: OpenAL Community
  Renderer: OpenAL Soft
  Version: 1.1 ALSOFT 1.17.2
  Extensions: AL_EXT_ALAW AL_EXT_BFORMAT AL_EXT_DOUBLE AL_EXT_EXPONENT_DISTANCE AL_EXT_FLOAT32 AL_EXT_IMA4 AL_EXT_LINEAR_DISTANCE AL_EXT_MCFORMATS AL_EXT_MULAW AL_EXT_MULAW_BFORMAT AL_EXT_MULAW_MCFORMATS AL_EXT_OFFSET AL_EXT_source_distance_model AL_LOKI_quadriphonic AL_SOFT_block_alignment AL_SOFT_buffer_samples AL_SOFT_buffer_sub_data AL_SOFT_deferred_updates AL_SOFT_direct_channels AL_SOFT_loop_points AL_SOFT_MSADPCM AL_SOFT_source_latency AL_SOFT_source_length
HRTF disabled
Allocated 256 sound sources
Low-pass filter supported
EAX Reverb supported
Enumerated output devices:
  OpenAL Soft on Speaker/Headphone (Realtek High Definition Audio)
Input #0, bink, from 'video\bethesda logo.bik':
  Duration: 00:00:16.00, start: 0.000000, bitrate: 2324 kb/s
    Stream #0:0[0x0]: Video: binkvideo (BIKi / 0x694B4942), yuv420p, 640x480, 30.06 fps, 30.06 tbr, 30.06 tbn, 30.06 tbc
    Stream #0:1[0x0]: Audio: binkaudio_rdft, 44100 Hz, stereo, flt
[binkaudio_rdft @ 0000020cee43d4a0] Multiple frames in a packet.

testman
Posts: 74
Joined: 30 Nov 2015, 15:05

Re: Failed to Open Audio Device on Windows 10

Post by testman » 28 Mar 2019, 12:09

Does it maybe help if you install latest OpenAL?

dogmellow
Posts: 5
Joined: 27 Mar 2019, 20:38

Re: Failed to Open Audio Device on Windows 10

Post by dogmellow » 28 Mar 2019, 16:13

I don't know why I didn't do that earlier. I'm now able to hear sounds in the game.

Post Reply