OpenMW 0.24.0

Anything related to PR, release planning and any other non-technical idea how to move the project forward should be discussed here.
User avatar
Zini
Posts: 5538
Joined: 06 Aug 2011, 15:16

Re: OpenMW 0.24.0

Post by Zini »

We need to come to a conclusion here relatively soon. Is anyone actively working on this problem? If not, then there is no point in waiting. I dislike the idea of releasing 0.24.0 without sound for Windows, but if a fix is not going to happen any time soon, then we may have no other option.
jbo_85
Posts: 10
Joined: 26 Jan 2012, 23:34
Location: Germany

Re: OpenMW 0.24.0

Post by jbo_85 »

It's only a problem for Win32. I don't really get the crash in my MSVC-builds with ffmpeg.
jbo_85
Posts: 10
Joined: 26 Jan 2012, 23:34
Location: Germany

Re: OpenMW 0.24.0

Post by jbo_85 »

The Win32-build probably has to be recompiled. There is a problem in SoundManager::lookup() in soundmanagerimp.cpp for example. The ASM for that function differs between OpenMW 0.23 and my 0.24 MSVC build. But in the RC it's the same as in OpenMW 0.23.
By patching some issues in the RC I was able to get ingame with working sound.
wheybags
Posts: 207
Joined: 21 Dec 2012, 19:41

Re: OpenMW 0.24.0

Post by wheybags »

I just compiled master on windows and it works perfectly, sound and all.
http://wheybags.netsoc.ie/openmw.rar

EDIT:
Shit, just realised it should be 0.24 branch, will compile that now.

EDIT2:
http://wheybags.netsoc.ie/openmw-0.24-win32.rar
Works perfectly for me.
User avatar
Br0ken
Posts: 241
Joined: 02 Apr 2012, 05:54
Location: Siberia

Re: OpenMW 0.24.0

Post by Br0ken »

wheybags wrote:http://wheybags.netsoc.ie/openmw-0.24-win32.rar
Works perfectly for me.
It's alive! :D
Runs excellent for me too.

Now, nothing prevents to release 0.24.0?
User avatar
psi29a
Posts: 5102
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: OpenMW 0.24.0

Post by psi29a »

So something is amiss in Ace's sound libs or boost libs?

I suggest you list the versions of everything used to compile, same for Ace so we can see the differences.
wheybags
Posts: 207
Joined: 21 Dec 2012, 19:41

Re: OpenMW 0.24.0

Post by wheybags »

boost_1_51
bullet-2.81-rev2613
ffmpeg-git-1eabd71-win32-dev
GnuWin32
MyGUI_3.2.0
OgreSDK_vc10_v1-8-1
OpenAL 1.1 SDK

^contents of my deps folder
User avatar
Berandas
Posts: 96
Joined: 28 Oct 2012, 11:23
Location: Prague, Czech Republic
Contact:

Re: OpenMW 0.24.0

Post by Berandas »

EDIT2:
http://wheybags.netsoc.ie/openmw-0.24-win32.rar
Works perfectly for me.
Seems to be working for me as well. I just found one bug - sounds have reversed front/rear directions (I'm using 5.1 sound), that means, things in front of me are making noise from my rear reproductors and vice versa, center seems to be working fine. Can someone confirm this?
User avatar
Ace (SWE)
Posts: 860
Joined: 15 Aug 2011, 14:56

Re: OpenMW 0.24.0

Post by Ace (SWE) »

boost_1_51
bullet_2.77
ffmpeg-git-1eabd71
MyGUI-3.2.0
Ogre-hg rev 3593 (d4f8b8f036f6, v1-8 branch)
OpenAL-1.1 SDK

Perhaps something went wrong in my original build, I could recreate the build directory and try another one, see if that helps?
Also, sorry for being gone. Was my birthday so I was away without access to my development machine.
corristo
Posts: 495
Joined: 12 Aug 2011, 08:29

Re: OpenMW 0.24.0

Post by corristo »

Post Reply