Openmw build error + possible fix

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Locked
edmondo
Posts: 36
Joined: 14 May 2012, 14:04
Contact:

Openmw build error + possible fix

Post by edmondo » 30 May 2012, 21:52

Build error with gcc-4.5.3 on my gentoo linux:

Code: Select all

[ 34%] Building CXX object apps/openmw/CMakeFiles/openmw.dir/__/__/libs/openengine/ogre/mouselook.cpp.o
cd /var/tmp/portage/games-rpg/openmw-9999/work/openmw-9999_build/apps/openmw && /usr/lib64/ccache/bin/x86_64-pc-linux-gnu-g++  -DOPENMW_USE_MPG123  -DNDEBUG -march=amdfam10 -O2 -pipe -ggdb  -I/var/tmp/portage/games-rpg/openmw-9999/work/openmw-9999/. -I/usr/include/OGRE -I/usr/include/OGRE/Ogre -I/usr/include/OGRE/OGRE -I/usr/include/OGRE/Terrain -I/usr/include/OIS -I/usr/include/boost-1_49 -I/usr/include/MYGUI -I/usr/include/AL -I/var/tmp/portage/games-rpg/openmw-9999/work/openmw-9999/libs -I/usr/include/bullet    -Wall -Wextra -Wno-unused-parameter -Wno-reorder -Wno-ignored-qualifiers -o CMakeFiles/openmw.dir/__/__/libs/openengine/ogre/mouselook.cpp.o -c /var/tmp/portage/games-rpg/openmw-9999/work/openmw-9999/libs/openengine/ogre/mouselook.cpp
/var/tmp/portage/games-rpg/openmw-9999/work/openmw-9999/libs/openengine/ogre/renderer.cpp: In member function ‘void OEngine::Render::OgreRenderer::configure(const std::string&, const std::string&, const std::string&, bool)’:
/var/tmp/portage/games-rpg/openmw-9999/work/openmw-9999/libs/openengine/ogre/renderer.cpp:98:15: error: ‘runtime_error’ is not a member of ‘std’
make[2]: *** [apps/openmw/CMakeFiles/openmw.dir/__/__/libs/openengine/ogre/renderer.cpp.o] Error 1
Possible patch to fix it:

Code: Select all

--- a/libs/openengine/ogre/renderer.cpp
+++ b/libs/openengine/ogre/renderer.cpp
@@ -10,6 +10,7 @@
 #include "OgreHardwarePixelBuffer.h"
 
 #include <assert.h>
+#include <stdexcept>
 
 using namespace Ogre;
 using namespace OEngine::Render;

User avatar
Zini
Posts: 5446
Joined: 06 Aug 2011, 15:16

Re: Openmw build error + possible fix

Post by Zini » 31 May 2012, 08:10

These old source files are so messy in some places. :(

Anyway, that looks like a reasonable fix. Care to put it on github?

edmondo
Posts: 36
Joined: 14 May 2012, 14:04
Contact:

Re: Openmw build error + possible fix

Post by edmondo » 31 May 2012, 10:11

I've sent a pull request. Can you please check, if you've got it (this is my first pull request with github, so I hope I've done it right).

Thanks! :-)

PS. This is my github repository:
https://github.com/edmondo/openmw

User avatar
Zini
Posts: 5446
Joined: 06 Aug 2011, 15:16

Re: Openmw build error + possible fix

Post by Zini » 31 May 2012, 10:33

All good.

Locked

Who is online

Users browsing this forum: No registered users and 1 guest