OpenMW won't launch (Linux Mint 20.1)

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
argonvegell
Posts: 218
Joined: 08 Dec 2015, 23:45

OpenMW will not launch on Xubuntu 20.04

Post by argonvegell »

I've tried to launch OpenMW from it's launcher, but it didn't launch, and I've tried to launch OpenMW Launcher from Terminal and this is the result:

Code: Select all

openmw-launcher
Loading config file: launcher.cfg
Loading config file: /home/~/.config/openmw/launcher.cfg
Loading config file: /home/~/.config/openmw/openmw.cfg
Loading config file: /etc/openmw/openmw.cfg
Loading config file: /usr/games/openmw.cfg
Loading config file: /home/~/.config/openmw/openmw.cfg
Loading settings file: /etc/openmw/settings-default.cfg
Loading settings file: /home/~/.config/openmw/settings.cfg
The current profile is:  "2021-02-26T16:29:57"
./openmw: symbol lookup error: ./openmw: undefined symbol: _ZNK3osg6Camera25computeLocalToWorldMatrixERNS_7MatrixdEPNS_11NodeVisitorE
User avatar
heilkitty
Posts: 155
Joined: 11 Aug 2011, 07:57
Location: Vivec City, MW
Contact:

Re: OpenMW will not launch on Xubuntu 20.04

Post by heilkitty »

Which OpenMW version? Is it from the PPA?
In Soviet MoЯЯowind, Almalexia kills YOU!!
argonvegell
Posts: 218
Joined: 08 Dec 2015, 23:45

Re: OpenMW will not launch on Xubuntu 20.04

Post by argonvegell »

OpenMW 46.0.

I installed from here: https://launchpad.net/~openmw/+archive/ubuntu/openmw
someguy
Posts: 2
Joined: 03 May 2021, 23:49

Re: OpenMW will not launch on Xubuntu 20.04

Post by someguy »

argonvegell wrote: 03 May 2021, 13:12 I've tried to launch OpenMW from it's launcher, but it didn't launch, and I've tried to launch OpenMW Launcher from Terminal and this is the result:

Code: Select all

openmw-launcher
Loading config file: launcher.cfg
Loading config file: /home/~/.config/openmw/launcher.cfg
Loading config file: /home/~/.config/openmw/openmw.cfg
Loading config file: /etc/openmw/openmw.cfg
Loading config file: /usr/games/openmw.cfg
Loading config file: /home/~/.config/openmw/openmw.cfg
Loading settings file: /etc/openmw/settings-default.cfg
Loading settings file: /home/~/.config/openmw/settings.cfg
The current profile is:  "2021-02-26T16:29:57"
./openmw: symbol lookup error: ./openmw: undefined symbol: _ZNK3osg6Camera25computeLocalToWorldMatrixERNS_7MatrixdEPNS_11NodeVisitorE
+1
Same error mint 20.04 focal
After updating to:
libopenscenegraph161=3.6.5+dfsg1-2~focal2
libopenthreads21=3.6.5+dfsg1-2~focal2
User avatar
psi29a
Posts: 5091
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: OpenMW will not launch on Xubuntu 20.04

Post by psi29a »

Packages were updated in prep for 0.47 RC phase.

So if you are waiting for a working nightly, just wait another day for a build to trigger and it should resolve itself.

For openmw 0.46 you'll need to unininstall mysql; apt update; then apt install mysql again.
User avatar
heilkitty
Posts: 155
Joined: 11 Aug 2011, 07:57
Location: Vivec City, MW
Contact:

Re: OpenMW will not launch on Xubuntu 20.04

Post by heilkitty »

mygui?
In Soviet MoЯЯowind, Almalexia kills YOU!!
User avatar
psi29a
Posts: 5091
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: OpenMW will not launch on Xubuntu 20.04

Post by psi29a »

libmygui.openglplatform0debian1v5
libmyguiengine3debian1v5

and anything else mygui related:

apt search mygui | grep installed

But that's only necessary for those running 0.46

0.47 fixes itself
someguy
Posts: 2
Joined: 03 May 2021, 23:49

Re: OpenMW will not launch on Xubuntu 20.04

Post by someguy »

mygui wasn't proposed for updates that time.
for now I hold those packages.

Guys, may i ask leave in ppa old versions of packages? Had to timeshift because cannot roll back to old version of libs.
Qndzia
Posts: 4
Joined: 05 May 2021, 07:34
Location: Warsaw, Poland

Ubuntu - problem with opening a game

Post by Qndzia »

Hello everyone,

I tried for the first time to play OpenMW on Ubuntu.
This approach took my like 5 hours and still cannot make it work.
Everything seems working untill moment of pressing PLAY on OpenMW launcher.

Always have same error:

Code: Select all

[email protected]:~$ openmw
openmw: symbol lookup error: openmw: undefined symbol: _ZNK3osg6Camera25computeLocalToWorldMatrixERNS_7MatrixdEPNS_11NodeVisitorE
[email protected]:~$ openmw-wizard 
"/home/qndzia/.config/openmw/wizard.log"
Loading config file: /home/qndzia/.config/openmw/openmw.cfg
Loading config file: /home/qndzia/.config/openmw/openmw.cfg
QFile::setFileName: File (/home/qndzia/.config/openmw/openmw.cfg) is already opened
Loading config file: openmw.cfg
Loading config file: /etc/openmw/openmw.cfg
Loading config file: /home/qndzia/.config/openmw/launcher.cfg
add installation in:  "/home/qndzia/SteamLibrary/steamapps/common/Morrowind/Data Files"
IMPORT SETTINGS
Loading config file: /home/qndzia/.config/openmw/openmw.cfg
Loading config file: /home/qndzia/.config/openmw/openmw.cfg
QFile::setFileName: File (/home/qndzia/.config/openmw/openmw.cfg) is already opened
Loading config file: openmw.cfg
Loading config file: /etc/openmw/openmw.cfg
[email protected]:~$ openmw-launcher 
Loading config file: launcher.cfg
Loading config file: /home/qndzia/.config/openmw/launcher.cfg
Loading config file: /home/qndzia/.config/openmw/openmw.cfg
Loading config file: /etc/openmw/openmw.cfg
Loading config file: /usr/games/openmw.cfg
Loading config file: /home/qndzia/.config/openmw/openmw.cfg
Loading settings file: /etc/openmw/settings-default.cfg
Loading settings file: /home/qndzia/.config/openmw/settings.cfg
The current profile is:  "2021-05-05T08:33:14"
[email protected]:~$ ./openmw: symbol lookup error: ./openmw: undefined symbol: _ZNK3osg6Camera25computeLocalToWorldMatrixERNS_7MatrixdEPNS_11NodeVisitorE
Thx a lot and have a nice day!
User avatar
psi29a
Posts: 5091
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: Ubuntu - problem with opening a game

Post by psi29a »

Known issue, posted elsewhere in forums. Merging topic.
Post Reply