Some texture/mesh replacers not loading?

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
NameGoesHere
Posts: 7
Joined: 02 Mar 2021, 04:39

Some texture/mesh replacers not loading?

Post by NameGoesHere »

I'm trying to run OpenMW on Ubuntu 18.04 with just a few texture replacers (mostly following modding-openmw.com's I Heart Vanilla list). I can clearly tell some of the textures/meshes I want to use are being loaded into the game, just by comparing screenshots with a vanilla config file that doesn't references any of the ones I'm trying to use. The logs also show that the data paths, and more importantly the .esp/.esm files are being loaded into the game:

Code: Select all

Adding data directory Games/Morrowind/Data Files
Adding data directory Games/openmw_mods/PatchforPurists
Adding data directory Games/openmw_mods/UnofficialMorrowindOfficialPluginsPatched
Adding data directory Games/openmw_mods/MorrowindOptimizationPatch/00 Core
Adding data directory Games/openmw_mods/MorrowindOptimizationPatch/01 Fixed Vanilla Textures
Adding data directory Games/openmw_mods/MorrowindOptimizationPatch/02 Lake Fjalding Anti-Suck
Adding data directory Games/openmw_mods/GlowintheDahrk/00 Core
Adding data directory Games/openmw_mods/GlowintheDahrk/01 Hi Res Window Texture Replacer
Adding data directory Games/openmw_mods/GlowintheDahrk/02 Interior Sunrays
Adding data directory Games/openmw_mods/GlowintheDahrk/03 Nord Glass Windows Interior Sunrays
Adding data directory Games/openmw_mods/GlowintheDahrk/04 Telvanni Dormers on Vvardenfell
Adding data directory Games/openmw_mods/GlowintheDahrk/05 Raven Rock Glass Windows
Adding data directory Games/openmw_mods/GraphicHerbalism/00 Core + Vanilla Meshes
Adding data directory Games/openmw_mods/GraphicHerbalism/01 Optional - Smoothed Meshes
Adding data directory Games/openmw_mods/ProjectAtlas/00 Core
Adding data directory Games/openmw_mods/ProjectAtlas/10 Glow in the Dahrk Patch - Interior Sunrays
Adding data directory Games/openmw_mods/ProjectAtlas/20 BC Mushrooms - Smoothed
Adding data directory Games/openmw_mods/ProjectAtlas/30 Redware - Smoothed
Adding data directory Games/openmw_mods/ProjectAtlas/40 Urns - Smoothed
Adding data directory Games/openmw_mods/ProjectAtlas/50 Wood Poles - Hi-Res Texture
Adding data directory Games/openmw_mods/GH-AtlasPatches/10 Atlas - Vanilla BC Mushrooms
Adding data directory Games/openmw_mods/GH-AtlasPatches/12 Atlas - Smoothed BC Mushrooms
Adding data directory Games/openmw_mods/IntelligentTextures/00 Core
Adding data directory Games/openmw_mods/IntelligentTextures/01 Atlas Textures
Adding data directory Games/openmw_mods/Facelift/Main
...
Loading content file Morrowind.esm
Loading content file Tribunal.esm
Loading content file Bloodmoon.esm
Loading content file Patch for Purists.esm
Loading content file Patch for Purists - Book Typos.ESP
Loading content file Patch for Purists - Semi-Purist Fixes.ESP
Loading content file Unofficial Morrowind Official Plugins Patched.ESP
Loading content file Lake Fjalding Anti-Suck.ESP
When I open the console and click on a building's exterior that I know is in Project Atlas, though, it seems to still be loading the one from the vanilla data files instead:

Code: Select all

Report time: 2021.03.02 03:28:20 UTC
Content file: Morrowind.esm
RefNum: 6867
RefID: ex_hlaalu_b_07
Memory address: 0x5623abb296f0
Cell: Balmora
Grid: -3 -2
Coordinates: -21922.5 -15480.7 674.204
Model: meshes\x\Ex_hlaalu_b_07.NIF
Whereas that particular .nif file from Project Atlas in the "meshes\x\" directory is all lowercase, like the RefID itself.

Am I doing something wrong?
User avatar
AnyOldName3
Posts: 2150
Joined: 26 Nov 2015, 03:25

Re: Some texture/mesh replacers not loading?

Post by AnyOldName3 »

Because Windows filesystems aren't case-sensitive by default, modders and Bethesda have never had to bother making sure the case matches between what's referenced in the game data and what's on disk. That means that OpenMW has to have case insensitive file access by default, too. There's a setting to change that, but most of Morrowind won't load with it enabled - it's only really there for if you're creating a new game from scratch with OpenMW.
AnyOldName3, Master of Shadows
NameGoesHere
Posts: 7
Joined: 02 Mar 2021, 04:39

Re: Some texture/mesh replacers not loading?

Post by NameGoesHere »

Would I be better off using a Windows system to drag and drop the textures and meshes into the appropriate Data Files directories so they overwrite the originals, and then porting that back to my Linux system then? Would it still result in the same problem, or would OpenMW handle the textures and meshes in Data Files correctly after that?
User avatar
AnyOldName3
Posts: 2150
Joined: 26 Nov 2015, 03:25

Re: Some texture/mesh replacers not loading?

Post by AnyOldName3 »

OpenMW knows that it's got a case-insensitive virtual file system, so if you've got file.ext in a low-priority data directory, and File.EXT in a high-priority data directory, any references the game data makes to anything that's file.ext when made lower case will go to the version in the high-priority data directory, which is what you want. The issue here is not caused by or related to anything being lower or upper case.

Something that would be a good idea is sharing the part of your log that has things going wrong instead of the part of your log that has things working. Error messages tend to be much more useful for fixing errors than the success messages which preceded them. Just upload your whole log file (ideally in a pastebin, GitHub Gist, or GitLab Snippet).
AnyOldName3, Master of Shadows
User avatar
AnyOldName3
Posts: 2150
Joined: 26 Nov 2015, 03:25

Re: Some texture/mesh replacers not loading?

Post by AnyOldName3 »

I've just had another look at your original post, and I now realise there are probably not error messages for this. As far as I can tell, you think there's a problem because when using Project Atlas, a mod intended to make the game run faster while looking exactly the same, your game looks exactly the same. Is this correct?
AnyOldName3, Master of Shadows
NameGoesHere
Posts: 7
Joined: 02 Mar 2021, 04:39

Re: Some texture/mesh replacers not loading?

Post by NameGoesHere »

That's correct, yeah, and you're right: my log file doesn't have any errors at all. The path listed by ori in the console for a building I know there's an Atlas mesh for lists the same path with both a vanilla config and the one that references Project Atlas' data paths, which leads me to believe that other meshes I'm trying to load in aren't actually being loaded in either, but I can tell that some of them are being used, because there's obvious visible differences from the vanilla config I loaded to test and compare.
NameGoesHere
Posts: 7
Joined: 02 Mar 2021, 04:39

Re: Some texture/mesh replacers not loading?

Post by NameGoesHere »

Well, to clarify, it's more that I would expect Project Atlas' pathname to be listed by the ori command in the console for the building, but there's no difference between the vanilla config and the one I'm trying to use with Project Atlas. That's what's making me question whether or not the meshes are actually being loaded at all.
User avatar
AnyOldName3
Posts: 2150
Joined: 26 Nov 2015, 03:25

Re: Some texture/mesh replacers not loading?

Post by AnyOldName3 »

ori is giving you a relative path, so it's quite clearly not actually telling you it's from the base game. We've actually changed it recently so it also tells you which data directory it's loading from, so if you try with a 0.47 development build (either the generic Linux one from our downloads page or one from an OpenMW nightly PPA/AUR/whatever your distro uses) it should give you more information.
AnyOldName3, Master of Shadows
NameGoesHere
Posts: 7
Joined: 02 Mar 2021, 04:39

Re: Some texture/mesh replacers not loading?

Post by NameGoesHere »

When I try to install the nightly build from the PPA listed in the Downloads section, even after installing qt512base, it tells me that it's missing three packages that I can't seem to find available at all for 18.04, even in PPAs:

Code: Select all

E: Package 'libbullet2.88' has no installation candidate
E: Package 'libopenscenegraph161' has no installation candidate
E: Package 'libopenthreads21' has no installation candidate
The generic linux download doesn't seem to want to run at all either, because Ubuntu's treading them as shared libraries rather than executables. I know it's outside the original topic of this thread, but could you direct me to instructions on what I might need to do to get the generic Linux download to run?
User avatar
psi29a
Posts: 5089
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: Some texture/mesh replacers not loading?

Post by psi29a »

You'll need to install those libs, they are there are on the repo as well.. please use our regular PPA which carries those libs. Yes you can use both our regular PPA and nightly PPA.
Post Reply