Strange polygons around player model

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
mzry
Posts: 10
Joined: 06 Nov 2017, 11:19

Strange polygons around player model

Post by mzry »

OpenMW version 0.46.0
Revision 0abcb54f51

Recently re-installed OpenMW in my Manjaro Linux 20.2.1 after not playing for a while, when loading my save my player model is surrounded by these odd transparent polygons. Pictures attached. I have disabled any plugins/mods, just Bloodmoon & Tribunal enabled.

Any suggestions welcome :)
screenshot001.png
screenshot000.png
User avatar
silentthief
Posts: 449
Joined: 18 Apr 2013, 01:20
Location: Currently traversing the Ascadian Isles

Re: Strange polygons around player model

Post by silentthief »

This is due to some kind of missing resource error. I have attached an example of a picture that shows what the engine is trying to display. To get a better understanding of what the issue is, you should reply with a copy of your openmw log file

ST
ps the log file is found in
windows -> C:\Users\***yourUserName***\Documents\My Games\OpenMW
linux -> /home/***YourUserName***/.config/openmw
Attachments
Screenshot 2021-02-01 at 8.18.47 PM.png
100% not a dev, but I know a little about Linux, MW, and scripting. I try to help. LMK if you have any questions.

Current MW quote: "I don't recall using teleportation. Yet there I was. Alone. Naked."
mzry
Posts: 10
Joined: 06 Nov 2017, 11:19

Re: Strange polygons around player model

Post by mzry »

silentthief wrote: 02 Feb 2021, 02:28 This is due to some kind of missing resource error. I have attached an example of a picture that shows what the engine is trying to display. To get a better understanding of what the issue is, you should reply with a copy of your openmw log file

ST
ps the log file is found in
windows -> C:\Users\***yourUserName***\Documents\My Games\OpenMW
linux -> /home/***YourUserName***/.config/openmw
Thank you silent, I managed to fix the issue, was my own silliness. I basically lost my original morrowind.ini and these days I only use Linux, so to get OpenMW working I quickly installed Morrowind on my Dads computer, copied the morrowind.ini and used that as a base - and of course the discrepancy of my save games and this 'stock' morrowind.ini caused the issue - even though my Morrowind Data folder was 100% identical. To fix I deleted my openmw configuration files (which were backed up from my old installation, which used the old morrowind ini) and re-run the settings importer fresh. Now the weird polygons are gone and all my plugins/mods are working fine.

Thanks again,
mzry
Posts: 10
Joined: 06 Nov 2017, 11:19

Re: Strange polygons around player model

Post by mzry »

silentthief wrote: 02 Feb 2021, 02:28 ps the log file is found in
windows -> C:\Users\***yourUserName***\Documents\My Games\OpenMW
linux -> /home/***YourUserName***/.config/openmw
Sorry I'm still having problems, seems with dark brotherhood meshes/models. I've attached my log.
openmw_log.zip
(4.05 KiB) Downloaded 34 times
Loriel
Posts: 169
Joined: 28 May 2015, 00:44

Re: Strange polygons around player model

Post by Loriel »

The log reveals errors such as "Failed to load 'meshes/a/a_darkbrotherhood_helmet.nif': Resource 'meshes/a/a_darkbrotherhood_helmet.nif' not found, using marker_error.nif instead" (at line 152).
Presumably either that particular item is missing or is installed in the wrong place - and it appears to apply to a series of similar items in lines 152-168.

There are similar errors:
103-109 "Failed to open image: Resource 'textures/tx_a_glass_curiass01_nm.dds' not found" and similar
98-99 "Failed to load 'meshes/snow.nif': Resource 'meshes/snow.nif' not found, using marker_error.nif instead" and similar

Possible problem at 146:"Warning: Can't find enchantment 'hair shirt' on item expensive_shirt_hair"

Possible problem at 130-2: "Out of bounds UV set 2 on shape "Tri light_tikitorch00 0" in meshes/l/light_tikitorch00.nif"

Hope that helps

Loriel
User avatar
akortunov
Posts: 812
Joined: 13 Mar 2017, 13:49
Location: Samara, Russian Federation

Re: Strange polygons around player model

Post by akortunov »

Or Tribunal.bsa and Bloodmoon.bsa just are not registered.
Post Reply