OpenMW renders nothing of the game world.

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Locked
ezzetabi
Posts: 407
Joined: 03 Feb 2012, 16:52

OpenMW renders nothing of the game world.

Post by ezzetabi » 07 May 2012, 14:48

The game renders nothing... I am using a version downloaded few hour ago via git. (This package)

Code: Select all

$ uname -a
Linux naee 3.3.4-1-ARCH #1 SMP PREEMPT Sat Apr 28 00:21:22 CEST 2012 x86_64 Intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GHz GenuineIntel GNU/Linux
$ glxinfo | grep '^dir\|^Ope'
direct rendering: Yes
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTS 250/PCIe/SSE2
OpenGL version string: 3.3.0 NVIDIA 295.40
OpenGL shading language version string: 3.30 NVIDIA via Cg compiler
$ openmw (enclosed)
The console seems working, in fact the character is in balmora over one of the bridges.
Attachments
2012-05-07-154404_1920x1080_scrot.png

User avatar
scrawl
Posts: 2152
Joined: 18 Feb 2012, 11:51
Contact:

Re: OpenMW renders nothing of the game world.

Post by scrawl » 07 May 2012, 18:19

Show your settings.cfg, please. I have a suspicion.

ezzetabi
Posts: 407
Joined: 03 Feb 2012, 16:52

Re: OpenMW renders nothing of the game world.

Post by ezzetabi » 07 May 2012, 22:02

Code: Select all

$ cat .config/openmw/settings.cfg 

[Shadows]
enabled = false

[Water]
shader = false

User avatar
scrawl
Posts: 2152
Joined: 18 Feb 2012, 11:51
Contact:

Re: OpenMW renders nothing of the game world.

Post by scrawl » 07 May 2012, 22:05

The problem seems to be fog-related, because the minimap displays fine (and the minimap has fog disabled). But you didn't change any fog-related settings. Maybe it's using a wrong settings-default file? Is the problem fixed when you add this to your settings.cfg ?

Code: Select all

[Viewing distance]
max viewing distance = 5600
fog start factor = 0.5
fog end factor = 1.0
Edit: Got it. The PKGBUILD doesn't install the settings-default.cfg file, so it didn't read the settings in there. As a quick "fix" you can copy everything from settings-default.cfg to settings.cfg.

I'll also add a runtime error that is thrown when there is no available settings-default.cfg, because that can lead to funny results as yours.

ezzetabi
Posts: 407
Joined: 03 Feb 2012, 16:52

Re: OpenMW renders nothing of the game world.

Post by ezzetabi » 08 May 2012, 15:57

Thanks. Using this patch solved the problem.

Code: Select all

--- PKGBUILD.orig	2012-03-28 23:12:37.000000000 +0200
+++ PKGBUILD	2012-05-08 16:56:27.928408147 +0200
@@ -53,6 +53,8 @@
   install -m644 openmw.cfg.install "$pkgdir"/etc/openmw/openmw.cfg
   install -m644 plugins.cfg "$pkgdir"/etc/openmw/
   install -m644 files/launcher.cfg "$pkgdir"/etc/openmw/
+  install -m644 files/settings-default.cfg "$pkgdir"/etc/openmw/
+  install -m644 files/transparency-overrides.cfg "$pkgdir"/etc/openmw/
 
   # Desktop file and icon
   install -d -m755  "$pkgdir"/usr/share/applications

Locked

Who is online

Users browsing this forum: No registered users and 2 guests