Is the nightly PPA broken?

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
User avatar
SmartGuar
Posts: 45
Joined: 04 Aug 2017, 20:33

Is the nightly PPA broken?

Post by SmartGuar » 27 Sep 2020, 11:39

The nightly PPA doesn't work for me anymore on Linux Mint. Everything got uninstalled except openmw-data.
It now says it lacks the dependencies: qt512base and libopenscenegraph161.
Is the problem on my side or is there a problem with the nightly PPA?

Not sure if this is better as a topic or a single post. So I posted both.
viewtopic.php?f=20&t=1808&p=68970#p68970
Ascended Lurker

User avatar
SmartGuar
Posts: 45
Joined: 04 Aug 2017, 20:33

Re: Is the nightly PPA broken?

Post by SmartGuar » 27 Sep 2020, 13:11

I've tested it and the Linux (Generic) nightly versions have the problem too.
The nightly builds from the 10th of July still work perfectly. The nightly builds from the 13th of July don't work.
Ascended Lurker

User avatar
SmartGuar
Posts: 45
Joined: 04 Aug 2017, 20:33

Re: Is the nightly PPA broken?

Post by SmartGuar » 27 Sep 2020, 17:59

So this is a problem with Ubuntu Bionic (I hate these names which you just can't tell apart) not having the new package versions in the official software sources.
Ascended Lurker

User avatar
psi29a
Posts: 4932
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: Is the nightly PPA broken?

Post by psi29a » 28 Sep 2020, 08:46

Yeah, Bionic has the problem of not only having a bad version of OSG but also an old version of Qt. So... as I stated in the other nightly thread, I worked around this by hosting our own version of OSG you'll need from ppa:openmw/openmw along with a custom build of Qt as well.

viewtopic.php?f=20&t=2042&p=68639#p68639

Post Reply