CI failed due to FFMPEG not downloading

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
hapythecoder
Posts: 2
Joined: 26 Sep 2020, 09:19

CI failed due to FFMPEG not downloading

Post by hapythecoder » 26 Sep 2020, 09:55

When I run the command through git bash shell inside the repo it fails when trying to download FFMPEG.

FFmpeg 4.2.2...
Downloading ffmpeg-4.2.2-win64.zip... Failed!

User avatar
AnyOldName3
Posts: 1946
Joined: 26 Nov 2015, 03:25

Re: CI failed due to FFMPEG not downloading

Post by AnyOldName3 » 26 Sep 2020, 16:19

The guy who's been providing FFMEPG builds to the world for years stopped doing it a few days ago. We've not found a replacement yet.
AnyOldName3, Master of Shadows

hapythecoder
Posts: 2
Joined: 26 Sep 2020, 09:19

Re: CI failed due to FFMPEG not downloading

Post by hapythecoder » 27 Sep 2020, 08:06

Ah cool thanks! Please let me know when its fixed or if there are alternate ways to build it. Just joined the discord too. Will check for updates often :)

User avatar
akortunov
Posts: 760
Joined: 13 Mar 2017, 13:49
Location: Samara, Russian Federation

Re: CI failed due to FFMPEG not downloading

Post by akortunov » 27 Sep 2020, 10:32

AnyOldName3 wrote:
26 Sep 2020, 16:19
We've not found a replacement yet.
Can we just host used dependencies on OpenMW site to do not rely on 3d-party sources?

User avatar
AnyOldName3
Posts: 1946
Joined: 26 Nov 2015, 03:25

Re: CI failed due to FFMPEG not downloading

Post by AnyOldName3 » 27 Sep 2020, 14:43

That's probably what we're going to go for, but we also need to either build and package the dependencies ourselves or find a new source for them. The usual way to use FFMPEG on Windows was to use Zeranoe's builds until a few days ago when he shut down his service.
AnyOldName3, Master of Shadows


User avatar
psi29a
Posts: 4921
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: CI failed due to FFMPEG not downloading

Post by psi29a » 28 Sep 2020, 08:40

I was thinking that perhaps it isn't such a bad idea to have our own gitlab repo to handle our dependency issues. Enable LFS and we get to handle our own versioning. It would also save us from having to host deps from downloads.openmw.org like we've been doing for MacOS.

User avatar
AnyOldName3
Posts: 1946
Joined: 26 Nov 2015, 03:25

Re: CI failed due to FFMPEG not downloading

Post by AnyOldName3 » 28 Sep 2020, 12:49

It's my understanding that FFMPEG only had the Zeranoe link a few days ago, and only just added replacements. Either way, what we're saying here is just rehashing what we've already discussed on Discord.
AnyOldName3, Master of Shadows


korreckj328
Posts: 3
Joined: 27 Apr 2020, 06:43

Re: CI failed due to FFMPEG not downloading

Post by korreckj328 » 28 Sep 2020, 19:17

psi29a wrote:
28 Sep 2020, 13:38
Jup, done: https://gitlab.com/OpenMW/openmw-deps
Hey, new user that just started looking at the code, and I can confirm that this works. I downloaded from your link, popped them in the deps folder and everything built and runs.

Post Reply