.46 crash on launch

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
Posts: 1
Joined: 28 Jun 2020, 21:00

.46 crash on launch

Post by Mightymuffin » 28 Jun 2020, 21:24

Not sure what the problem is the log file doesn't indicate anything is wrong but when I run the game, either through the launcher or directly using openmw.exe there is a garbled sound like the intro video is failing to run and it crashes. I glanced as the issue tracker and didn't see my specific issue listed there.

I tried removing the intro video from the folder to get further and get to the morrowind.esm loading bar but it does not progress and the game still crashes. Without the video there is an error in the log saying its missing but no errors to indicate what the problem is.

Other things I've tried:
Reinstalling .46 multiple times
Clearing out the mygames openmw folder to force that to get rebuild as well
Running on only the morrowind.esm file
Reinstalling Morrowind
Ran as admin (didn't expect this to work but the permissions on install are odd and I had to change them)

I pasted in the log file below though it doesn't seem to be indicating what's going wrong however the last two lines only appear when I've removed the bethesdalogo.bik file. When the file is there the log is the same minus those last two lines.

I am hesitant to uninstall .44 as that one still works and an outdated working engine is better than one that crashes on launch

Loading config file: C:\Program Files\OpenMW 0.46.0/openmw.cfg
Loading config file: C:\Users\redacted\Documents\My Games\OpenMW/openmw.cfg
OpenMW version 0.46.0
Revision: 0abcb54f51
Using default (English) font encoding.
OSG version: 3.4.2
SDL version: 2.0.12
Loading settings file: C:\Program Files\OpenMW 0.46.0/settings-default.cfg
Adding BSA archive C:\Program Files (x86)\Steam\steamapps\common\Morrowind\Data Files\Morrowind.bsa
Adding BSA archive C:\Program Files (x86)\Steam\steamapps\common\Morrowind\Data Files\Tribunal.bsa
Adding BSA archive C:\Program Files (x86)\Steam\steamapps\common\Morrowind\Data Files\Bloodmoon.bsa
Adding BSA archive C:\Program Files (x86)\Steam\steamapps\common\Morrowind\Data Files\TR_Data.bsa
Adding BSA archive C:\Program Files (x86)\Steam\steamapps\common\Morrowind\Data Files\PT_Data.bsa
Adding data directory resources\vfs
Adding data directory C:\Program Files (x86)\Steam\steamapps\common\Morrowind\Data Files
Loading keybindings file: C:\Users\redacted\Documents\My Games\OpenMW/input_v3.xml
Initializing OpenAL...
Opened "OpenAL Soft on Speakers (High Definition Audio Device)"
ALC Version: 1.1
Vendor: OpenAL Community
Renderer: OpenAL Soft
Version: 1.1 ALSOFT 1.19.1
Extensions: AL_EXT_ALAW AL_EXT_BFORMAT AL_EXT_DOUBLE AL_EXT_EXPONENT_DISTANCE AL_EXT_FLOAT32 AL_EXT_IMA4 AL_EXT_LINEAR_DISTANCE AL_EXT_MCFORMATS AL_EXT_MULAW AL_EXT_MULAW_BFORMAT AL_EXT_MULAW_MCFORMATS AL_EXT_OFFSET AL_EXT_source_distance_model AL_EXT_SOURCE_RADIUS AL_EXT_STEREO_ANGLES AL_LOKI_quadriphonic AL_SOFT_block_alignment AL_SOFT_deferred_updates AL_SOFT_direct_channels AL_SOFTX_events AL_SOFTX_filter_gain_ex AL_SOFT_gain_clamp_ex AL_SOFT_loop_points AL_SOFTX_map_buffer AL_SOFT_MSADPCM AL_SOFT_source_latency AL_SOFT_source_length AL_SOFT_source_resampler AL_SOFT_source_spatialize
HRTF disabled
Allocated 256 sound sources
Low-pass filter supported
EAX Reverb supported
Enumerated output devices:
OpenAL Soft on Speakers (High Definition Audio Device) OpenAL Soft on Digital Audio (S/PDIF) (High Definition Audio Device) OpenAL Soft on Speakers (Steam Streaming Microphone) OpenAL Soft on BenQ XL2420TE (NVIDIA High Definition Audio) OpenAL Soft on Speakers (Steam Streaming Speakers)
Enumerated HRTF names:
Built-In 44100hz Built-In 48000hz
Failed to open video: Resource 'video/bethesda logo.bik' not found
Loading content file Morrowind.esm

User avatar
Posts: 760
Joined: 13 Mar 2017, 13:49
Location: Samara, Russian Federation

Re: .46 crash on launch

Post by akortunov » 29 Jun 2020, 06:36

Did you try to move your Morrowind setup to an another folder? I remember that for some users OpenMW refused to start from Program Files (presumably due to access rights). Also OneDrive (where some users store their user folders) may be an issue - Boost can not work with it.

User avatar
Posts: 1946
Joined: 26 Nov 2015, 03:25

Re: .46 crash on launch

Post by AnyOldName3 » 29 Jun 2020, 15:17

Boost usually can work with OneDrive. It would be pretty bad if it couldn't work with the default Documents location on Windows for the last five years.
AnyOldName3, Master of Shadows

Post Reply