On VirtualBox, Fix for Camera/Mouse/Cursor Control Problem

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
linuxbill
Posts: 2
Joined: 25 Apr 2020, 04:26

On VirtualBox, Fix for Camera/Mouse/Cursor Control Problem

Post by linuxbill » 25 Apr 2020, 17:31

I've just installed Morrowind for the first time, and I ran into a small issue that made it unplayable on Virtualbox. As soon as I moved the mouse, the view would go crazy, as if I were spinning round and round while staring at the floor. I could use the keyboard to move around, but every attempt to change my view with the mouse would fail.

Here's what the fix was, in case it helps anyone else.

To be clear, this is:

- The GOTY edition purchased from GOG.com (a massive .exe file download)
- Installed on Xubuntu 16.04 in VirtualBox using PlayOnLinux, to get access to the MW data files.
- Then installed with openmw-launcher

I could open openmw-launcher and click Play, and MW would launch beautifully and go through the whole opening sequence. But again, when I tried to move the mouse, I was staring at the floor.

The fix, on VirtualBox, is to go into Fullscreen mode. This is distinct from whether openmw itself is running in windowed or fullscreen mode, although it's probably better to keep openmw in fullscreen mode. But I mean that VirtualBox itself has to be in Fullscreen mode, so that your mouse CANNOT move outside the running instance of Xubuntu.

You can do this on the VirtualBox menu under "View -> Full-Screen Mode"

Or the keyboard shortcut is "Host+F", where "Host" is the key shown in the bottom right of your VirtualBox. It defaults to "Right Ctrl."

So if you press "Right Ctrl + F", you should be able to toggle VirtualBox into fullscreen mode, and then you can move your mouse around and view things properly. Whew.

If you need to mouse out of VirtualBox, you press "Host" (probably Right Ctrl) and then you have your mouse back.

When you want to return to VirtualBox, make sure to click on it before trying to move around.

I hope this helps! This is probably an issue common to playing games in Virtualbox, because I couldn't find anything specific to openmw, but maybe someone else will find this helpful.

Bill

testman
Posts: 82
Joined: 30 Nov 2015, 15:05

Re: On VirtualBox, Fix for Camera/Mouse/Cursor Control Problem

Post by testman » 26 Apr 2020, 08:11

Last time I checked, looking at floor and spazzing out is caused because "mouse integration" (seamless transition of mouse cursor between host and guest OS)
Disabling that through either key combination or though menu should make things better. But then you will have to press Host key every time you want your mouse back.
Going fullscreen works because muse integration getting disabled is a side effect of that (no need for smooth transition between host and guest if there is no host because whole screen is taken up by giest)

linuxbill
Posts: 2
Joined: 25 Apr 2020, 04:26

Re: On VirtualBox, Fix for Camera/Mouse/Cursor Control Problem

Post by linuxbill » 28 Apr 2020, 23:35

Thanks testman! This is helpful.

Since that post, I tried installing openmw on an older laptop running Ubuntu 16.04. Installed natively, without VirtualBox, openmw is MUCH smoother.

So, even though I was able to at least navigate around while running openmw on Virtualbox, it seems better to install it natively if it all possible, even if it's on older hardware.

But, it's also possible that there is some arcane setting in VirtualBox that I'm not setting correctly, especially in regards to simulating a graphics card.

Thanks!

sirkope
Posts: 1
Joined: 03 Jun 2020, 19:50

Re: On VirtualBox, Fix for Camera/Mouse/Cursor Control Problem

Post by sirkope » 03 Jun 2020, 19:59

Hi all

I've found OpenMW recently, and I wanted to instal my Morrowind GOTY DVD-s with it on an ArchLinux PC natively.
The install was smooth, but when I tried to move the mouse, I was staring at the floor. So I can't get out off the boat and start the game.
I've try run it full screen, not windowed mode, not help. Is there any setup in OpenMW, or any other solution?

Thanks.

Post Reply