Some problem to solve

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Locked
beta
Posts: 13
Joined: 24 Feb 2012, 13:34

Some problem to solve

Post by beta » 12 Apr 2012, 21:10

first of all I'm gentoo user and there is no ebuild for mygui so it was better when you provided it because it's a pain in the ass to installed it :p !

Now the real reason why i post it's because since three week i receive this message when i try to compile :

[ 0%] Building CXX object components/CMakeFiles/components.dir/bsa/bsa_archive.cpp.o
/Partage/Jeux/OpenMW/openmw/components/bsa/bsa_archive.cpp: In member function ‘Ogre::FileInfoListPtr<unnamed>::BSAArchive::findFileInfo(const Ogre::String&, bool, bool) const’:
/Partage/Jeux/OpenMW/openmw/components/bsa/bsa_archive.cpp:310:22: erreur: invalid conversion from ‘const Ogre::Archive*’ to ‘Ogre::Archive*’
/usr/include/boost-1_46/boost/system/error_code.hpp: At global scope:
/usr/include/boost-1_46/boost/system/error_code.hpp:214:36: attention : ‘boost::system::posix_category’ defined but not used
/usr/include/boost-1_46/boost/system/error_code.hpp:215:36: attention : ‘boost::system::errno_ecat’ defined but not used
/usr/include/boost-1_46/boost/system/error_code.hpp:216:36: attention : ‘boost::system::native_ecat’ defined but not used
make[2]: *** [components/CMakeFiles/components.dir/bsa/bsa_archive.cpp.o] Erreur 1
make[1]: *** [components/CMakeFiles/components.dir/all] Erreur 2
make: *** [all] Erreur 2


If someone can help, just ask if you need more information about my system !

User avatar
scrawl
Posts: 2152
Joined: 18 Feb 2012, 11:51
Contact:

Re: Some problem to solve

Post by scrawl » 12 Apr 2012, 21:16

Error looks like your ogre version is wrong. You need exactly version 1.8 RC1 at this point.

I don't think mygui is hard to install. It's a simple cmake . && make && make install.

beta
Posts: 13
Joined: 24 Feb 2012, 13:34

Re: Some problem to solve

Post by beta » 12 Apr 2012, 22:24

in fact in gentoo if you want mygui to work you need to change some path and conf otherwise it's not recognize by the system, so neither by openmw configuration script.

I wasn't aware that need the 1.8 rc1 because it was said that we wait for a release before move to the next version so i'm on the 1.7 !

Thank for help i will try !

Locked

Who is online

Users browsing this forum: No registered users and 5 guests