Can't seem to fix that old animation bug that makes NPCs fall off cliffs

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
cspuobau
Posts: 2
Joined: 15 Dec 2019, 16:26

Can't seem to fix that old animation bug that makes NPCs fall off cliffs

Post by cspuobau » 15 Dec 2019, 16:34

Everyone knows about that age-old animation bug where if you play a save for enough hours NPCs that are normally static (like siltstrider caravaneers) will eventually edge themselves off of platforms, cliffs and whatever else. You can reset them with "ra" in the console, but you have to enter that every single time it happens. It's only a temporary solution.

There's a mod for the original Morrowind that fixes this that you can get off the Nexus. I haven't been able to get it to work with OpenMW though. I'm not too familiar with running mods in OpenMW, but I edited my openmw.cfg and added a "data=" line that leads to where the mod is located. The mod is just some folders you drop in, not a .esp or .esm so I can't just select it in the launcher.

I really need this one mod to work because so many people are falling in my save game right now and ruining it.

Thanks.

User avatar
DestinedToDie
Posts: 1156
Joined: 29 Jun 2015, 09:08

Re: Can't seem to fix that old animation bug that makes NPCs fall off cliffs

Post by DestinedToDie » 15 Dec 2019, 16:58

What directory is your mod in and what does your "data=" line look like? The line should navigate into the data file folder where you have mesh folder.

For example, you have mods folder that leads into data files that leads into meshes which contains the anim.nifs. Then you want to navigate like this: mods/data files. If you navigate like this mods/data files/meshes, then OpenMW will not load the mod.

cspuobau
Posts: 2
Joined: 15 Dec 2019, 16:26

Re: Can't seem to fix that old animation bug that makes NPCs fall off cliffs

Post by cspuobau » 15 Dec 2019, 18:57

That may have been my problem. I forgot to make a "Data Files" folder inside of the "mods" folder. Thanks for the help. Now I can enjoy the game as it should be hopefully. Thank you very much for taking the time to help.

By the way I like your username.

Post Reply