Manjaro build has broken launcher

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
unelsson
Posts: 140
Joined: 17 Mar 2018, 14:57

Manjaro build has broken launcher

Post by unelsson » 11 Sep 2019, 01:09

Some things, like foreach keyword (Qt) don't work correctly with Manjaro as of 11.9.2019. This results in a symptom where the launcher doesn't find the config files, and always pops up the first run -dialog, asking for running the installation wizard. This can be fixed by forcing a build to Qt5, I tested this by uninstalling Qt4, and having only a package qt5-base, changing the preferred Qt version to 5 in CMakeLists.txt (set(DESIRED_QT_VERSION 4... -> 5). I don't know the deeper cause for the problem, but at least having both Qt4 and Qt5, and then compiling OpenMW with Qt4 results in a broken build.

Post Reply