I have shadows enabled (properly) but they arent showing up

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
crshbndct
Posts: 2
Joined: 29 Jul 2019, 03:15

I have shadows enabled (properly) but they arent showing up

Post by crshbndct » 29 Jul 2019, 03:24

I have followed the Total Overhaul for OpenMW, installing everything (except the two mods that make dwemer more difficult, since I'm a noob).

I have enabled shadows using the following options:

Code: Select all

[Shadows]
enable shadows = true                        # This defaults to false
number of shadow maps = 3
split point uniform logarithmic ratio = 0.5  # This has a default of 0.5, but at that setting shadows look odd
split point bias = 0.0
enable debug hud = false
enable debug overlay = false
compute tight scene bounds = false
shadow map resolution = 1024                 # Or up to 4096 if you have a powerful GPU
minimum lispsm near far ratio = 0.25
polygon offset factor = 1.1
polygon offset units = 4.0
normal offset distance = 1.0
use front face culling = true
actor shadows = true                         # This defaults to false
player shadows = true                        # This defaults to false
terrain shadows = true                       # This defaults to false
object shadows = true                        # This defaults to false
enable indoor shadows = true
And I have no shadows.

My system is Pop_OS 19.04 with openmw-daily ppa. I wasn't getting shadows before either though. I can post my openmw log and cfg files if needed.

My hardware is an i5-3550, GTX1060 6GB, nvidia 430.34 driver, 16gb ram, and Im running from a crucial mx500 480gb ssd.

I am not sure what to try.

testman
Posts: 82
Joined: 30 Nov 2015, 15:05

Re: I have shadows enabled (properly) but they arent showing up

Post by testman » 29 Jul 2019, 15:06

What happens if you enable the debug overlay (line 6 in the config you posted), does that show anything useful?

I am not familiar with daily PPA, I always built from source, and I always managed to get shadows working. Can you maybe try building from source, to see if that behaves any differently than the one from PPA?

crshbndct
Posts: 2
Joined: 29 Jul 2019, 03:15

Re: I have shadows enabled (properly) but they arent showing up

Post by crshbndct » 29 Jul 2019, 20:19

I will try both of those things tonight.

I might just go back to the standard openmw ppa first though, see if it works and if not, I'll try a source build.

Post Reply