[Solved] Installing on a Pi4?

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
bomblord
Posts: 14
Joined: 18 Jul 2019, 22:34

Re: Installing on a Pi4?

Post by bomblord » 23 Aug 2019, 16:41

psi29a wrote:
23 Aug 2019, 16:20
Okay.. VC6 then ;) Anyway, Can you post the full output of glxinfo please? :D

Regardless, the real issue is OSG. You need to make sure it is compiled for desktop GL and not GLES.

When you run openmw though, do you see anything in the console or log file?
I will take a look at this once I get home and have some free time thank you.

bomblord
Posts: 14
Joined: 18 Jul 2019, 22:34

Re: Installing on a Pi4?

Post by bomblord » 24 Aug 2019, 00:13

Full output of glxinfo
https://pastebin.com/C0S09Mp3

Terminal log when opening morrowind
https://pastebin.com/PWTJjYyG

User avatar
AnyOldName3
Posts: 1565
Joined: 26 Nov 2015, 03:25

Re: Installing on a Pi4?

Post by AnyOldName3 » 24 Aug 2019, 02:03

Try setting the OPENMW_DECOMPRESS_TEXTURES environment variable to 1 to work around the no-s3tc issue.
AnyOldName3, Master of Shadows

bomblord
Posts: 14
Joined: 18 Jul 2019, 22:34

Re: Installing on a Pi4?

Post by bomblord » 24 Aug 2019, 12:27

AnyOldName3 wrote:
24 Aug 2019, 02:03
Try setting the OPENMW_DECOMPRESS_TEXTURES environment variable to 1 to work around the no-s3tc issue.
I will try that thank you for the suggestion :D

bomblord
Posts: 14
Joined: 18 Jul 2019, 22:34

Re: Installing on a Pi4?

Post by bomblord » 24 Aug 2019, 20:04

AnyOldName3 wrote:
24 Aug 2019, 02:03
Try setting the OPENMW_DECOMPRESS_TEXTURES environment variable to 1 to work around the no-s3tc issue.
Hey, sorry where do I set that exactly?

User avatar
AnyOldName3
Posts: 1565
Joined: 26 Nov 2015, 03:25

Re: Installing on a Pi4?

Post by AnyOldName3 » 25 Aug 2019, 02:21

It's an environment variable, so you can either set it for the current session of a Bash terminal or you can set it permanently in a few ways. You'll need to google your OS and environment variables to see how.
AnyOldName3, Master of Shadows

User avatar
psi29a
Posts: 4644
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: Installing on a Pi4?

Post by psi29a » 26 Aug 2019, 15:42

Extended renderer info (GLX_MESA_query_renderer):
Vendor: Broadcom (0x14e4)
Device: V3D 4.2 (0xffffffff)
Version: 19.1.4
Accelerated: yes
Video memory: 3754MB
Unified memory: yes
Preferred profile: compat (0x2)
Max core profile version: 0.0
Max compat profile version: 2.1
Max GLES1 profile version: 1.1
Max GLES[23] profile version: 3.0
OpenGL vendor string: Broadcom
OpenGL renderer string: V3D 4.2
OpenGL version string: 2.1 Mesa 19.1.4
OpenGL shading language version string: 1.20
Looks good to me, yeah... OpenGL 2.1 with V3D (and not LLVM)
Error loading textures/water/ripple00.dds: no S3TC texture compression support installed
Setting the environment variable should be enough.

export OPENMW_DECOMPRESS_TEXTURES=1
openmw
or
OPENMW_DECOMPRESS_TEXTURES=1 openmw

bomblord
Posts: 14
Joined: 18 Jul 2019, 22:34

Re: Installing on a Pi4?

Post by bomblord » 27 Aug 2019, 20:28

Low settings 720p getting 30fps with vsync on!!!

I'm still getting garbled audio though. I assume this is the culprit

Code: Select all

[binkaudio_rdft @ 0x5593b63b30] The deprecated avcodec_decode_* API cannot return all the frames for this decoder. Some frames will be dropped. Update your code to the new decoding API to fix this.
[swscaler @ 0x7f60071be0] No accelerated colorspace conversion found from yuv420p to rgba.
Any clue what that solution to this is?

User avatar
psi29a
Posts: 4644
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: Installing on a Pi4?

Post by psi29a » 27 Aug 2019, 20:55

You should make a youtube video and help spread some propaganda. ;)

bomblord
Posts: 14
Joined: 18 Jul 2019, 22:34

Re: Installing on a Pi4?

Post by bomblord » 27 Aug 2019, 21:26

psi29a wrote:
27 Aug 2019, 20:55
You should make a youtube video and help spread some propaganda. ;)
I got some capture hardware I could borrow maybe when I have an excess amount of free time I could. Would like to solve the audio issue before doing that though because audio is completely unusable had to mute it and turn on subtitles.

Post Reply