Page 1 of 4

Build for Elbrus(VLIW)

Posted: 15 May 2019, 17:05
by DJs3000
Hello. I'm trying to build openmw for Elbrus. Elbrus is Russian computer on an alternative CPU architecture(VLIW). Elbrus use Linux(e2k). e2k this is code name architecture Elbrus. Error:
Spoiler: Show
Which package cannot be found?

Re: Build for Elbrus(VLIW)

Posted: 15 May 2019, 17:08
by sirherrbatka
That's pretty simple, actually. LIBUNSHIELD. It is required by the installer. I suspect that the whole installer target may be optional (it should be anyway).

Re: Build for Elbrus(VLIW)

Posted: 15 May 2019, 17:51
by akortunov
sirherrbatka wrote:
15 May 2019, 17:08
That's pretty simple, actually. LIBUNSHIELD. It is required by the installer. I suspect that the whole installer target may be optional (it should be anyway).
By wizard, not by launcher. There is a BUILD_WIZARD option, which is enabled by default. If disabled, OpenMW will not build the wizard, but in this case you need to setup data manually.

Re: Build for Elbrus(VLIW)

Posted: 15 May 2019, 18:22
by sirherrbatka
Right.

Re: Build for Elbrus(VLIW)

Posted: 15 May 2019, 21:59
by DJs3000
I was able to compile some dependencies:
unshield
OpenSceneGraph
For build mygui, need ogre(open source engine) and problem this step.

Re: Build for Elbrus(VLIW)

Posted: 15 May 2019, 22:02
by AnyOldName3
You're not going to get anywhere if you can't compile OpenSceneGraph. I was also under the impression that there're ways of making MyGUI not actually require OGRE, but can't remember the details or if this is something I dreamt.

Re: Build for Elbrus(VLIW)

Posted: 15 May 2019, 22:10
by DJs3000
AnyOldName3 OpenSceneGraph i have successfully build :)

Re: Build for Elbrus(VLIW)

Posted: 15 May 2019, 22:42
by DJs3000
Thanks for the advice! Found where in MyGUI change the rendering method from ogre to OpenGL 3.x

Re: Build for Elbrus(VLIW)

Posted: 16 May 2019, 12:05
by sirherrbatka
Also, once you manage to run the game I would be very interested to see it. I have no idea what kind of GPU this machine can possibly have, so it would be very difficult to establish any insight into the practical performance, but this stuff is so exotic outside of the Russia that I can't help but check it out :-)

Re: Build for Elbrus(VLIW)

Posted: 16 May 2019, 13:00
by DJs3000
All dependencies build ok. In the process of compiling openmw, crashes with an error:
Spoiler: Show