OpenMW Savegame Files not Detected

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
bapride11
Posts: 4
Joined: 27 Apr 2019, 07:41

OpenMW Savegame Files not Detected

Post by bapride11 » 27 Apr 2019, 07:53

Hello all!

I opened the launcher after having played just last weekend, and it acted as if I had never opened it before. I went through the installation wizard, and none of my profiles were still there. I rebuilt a new profile using the same (or as close to the same) mod selections as before, and launched the game. When I went to load the game, I couldn't find my most recent character (with saves ranging in age of several weeks), only my first character I had made. There were multiple saves of this character ranging about a month of time, and the files are definitely still there. Given the way this is manifesting (by character and not by savefile), I doubt that it's hard drive failure.

Is there some sort of filtering that goes on that would cause the engine not to recognize these save files? Is it a matter of perfectly matching the selected mods to be able to recognize the save file?

Thanks for any help you might be able to provide.

User avatar
AnyOldName3
Posts: 1562
Joined: 26 Nov 2015, 03:25

Re: OpenMW Savegame Files not Detected

Post by AnyOldName3 » 27 Apr 2019, 21:15

You're definitely logged in as the same user and haven't moved your documents directory or anything like that? That's where OpenMW keeps its configuration and saves, so if it can't find them, that type of thing would be the first thing I'd look at.
AnyOldName3, Master of Shadows

bapride11
Posts: 4
Joined: 27 Apr 2019, 07:41

Re: OpenMW Savegame Files not Detected

Post by bapride11 » 28 Apr 2019, 01:56

Nothing has been moved around. I can see a folder for each character under the "saves" folder, and each folder contains a number of save files. It's simply that none of the files for one character are available to load when I run OpenMW.

User avatar
Jemolk
Posts: 191
Joined: 20 Mar 2017, 02:12
Location: Sadrith Mora

Re: OpenMW Savegame Files not Detected

Post by Jemolk » 29 Apr 2019, 15:20

There is a dropdown character selection menu in the load screen that will define which folder you load from. It has your character name in it. This usefully keeps characters separate, but if you're not aware of it, that might be your issue.

bapride11
Posts: 4
Joined: 27 Apr 2019, 07:41

Re: OpenMW Savegame Files not Detected

Post by bapride11 » 01 May 2019, 03:08

Unfortunately, only the first character is listed. In the drop-down menu. This is what surprised me; it wasn't just a single save that disappeared, but a whole character.

User avatar
Jemolk
Posts: 191
Joined: 20 Mar 2017, 02:12
Location: Sadrith Mora

Re: OpenMW Savegame Files not Detected

Post by Jemolk » 01 May 2019, 16:13

bapride11 wrote:
01 May 2019, 03:08
Unfortunately, only the first character is listed. In the drop-down menu. This is what surprised me; it wasn't just a single save that disappeared, but a whole character.
That's really weird. If you're using nightly builds, it might be a regression; I've run into a few of those while running nightlies. Otherwise, I dunno what to say. Reproducing load order is definitely not necessary.

bapride11
Posts: 4
Joined: 27 Apr 2019, 07:41

Re: OpenMW Savegame Files not Detected

Post by bapride11 » 02 May 2019, 03:13

Just 0.44. I understand the curse of one-off, unreproducible bugs, though. Thank you for your help!

Post Reply