openmw-wizard not adding data failes

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
zariamna
Posts: 2
Joined: 24 Apr 2019, 16:51

openmw-wizard not adding data failes

Post by zariamna » 24 Apr 2019, 16:59

I have installed OpenMW version 0.44 in Fedora 30 beta and every time I open the game I have to rerun the installation wizard and select Morrowind.esm in the data files folder from steam. Each time, it does not successfully add the files. I have tried running it as root and it does the same thing. I've been trying to find other people with the same problem for the past hour and I can't find anything. I don't have this problem with any other version of Linux. I looked at the openmw.cfg file and it does save the file path for the data files, but it just doesn't see the Morrowind files there. I also tried running Morrowind in steam with proton and that worked fine, but it didn't help OpenMW. If I skip the wizard and launcher altogether by running

Code: Select all

sudo openmw
then it runs the game. If I do

Code: Select all

sudo openmw-launcher
then it has the same problem as without running as root. If I try to run openmw without sudo then it doesn't work. Youd think that if the game can start with sudo, then running the wizard or launcher as sudo would list the data files, but it doesn't. It acts like they don't exist. Spookiness. I also wanted to add that if there are any dependencies that Fedora did not install, or does not contain in the repos, then I have no problem with compiling them. I'll do anything for Morrowind xD Also, I'm not sure if I formatted this post right or not so sorry if it's a mess. I also want to add that I have both free and non free rpm fusion repos added. I think that's where I installed openmw from. If there is a snap that works, I will use that if I can't get this to work. Thanks ~

testman
Posts: 73
Joined: 30 Nov 2015, 15:05

Re: openmw-wizard not adding data failes

Post by testman » 24 Apr 2019, 19:58

zariamna wrote:
24 Apr 2019, 16:59
If I try to run openmw without sudo then it doesn't work.
Looks like you have some other isses, which might be related to OpenMW not seeing data files.
I do believe that if it was started with sudo, then it would look at /root/.config/openmw/openmw.cfg, so you might want to look at that file.
But what you should really do is figure out why OpenMW doesn't work without sudo for you.
Show us what error you are getting and we might be able to help you.

zariamna
Posts: 2
Joined: 24 Apr 2019, 16:51

Re: openmw-wizard not adding data failes

Post by zariamna » 26 Apr 2019, 05:14

Okay so it’s magically working fine now. A system update might have fixed it yet. If I figure it out, I’ll put it here in case anyone else has the problem. I guess that’s what I get for using a beta version of Fedora lol

fictionalnumber
Posts: 1
Joined: 31 May 2019, 11:49

Re: openmw-wizard not adding data failes

Post by fictionalnumber » 31 May 2019, 11:50

This issue just started for me after updating to Fedora 30. Any idea how you managed to fix it?

coff33bit
Posts: 1
Joined: 04 Aug 2019, 01:37

Re: openmw-wizard not adding data failes

Post by coff33bit » 04 Aug 2019, 01:41

fictionalnumber wrote:
31 May 2019, 11:50
This issue just started for me after updating to Fedora 30. Any idea how you managed to fix it?
I installed the OpenMW from the Gnome Software Center using flathub as the source rather than rpm-fusion, this resolved the issue for me (as well as made it so I was running version 0.45 rather than 0.44)

Post Reply