No audio [Windows 10]

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
Cryleve
Posts: 4
Joined: 04 Apr 2019, 01:44

No audio [Windows 10]

Post by Cryleve » 04 Apr 2019, 01:53

Just recently installed OpenMW and sadly I don't have any audio when I boot it up. Looking through the log when it starts I see this.

Loading config file: C:\Users\Ashcraft\Documents\My Games\OpenMW/openmw.cfg... done.
Loading config file: ./openmw.cfg... done.
TES3MP client 0.7.0-alpha (Windows 64-bit)
Protocol version: 7
Oldest compatible commit hash: 292536439e
------------------------------------------------------------
OpenMW version 0.44.0
Using default (English) font encoding.
[2019-04-03 19:33:52] [INFO]: tes3mp started
Loading settings file: ./tes3mp-client-default.cfg
[2019-04-03 19:33:52] [WARN]: Received ID_CONNECTION_REQUESTED_ACCEPTED from 192.99.245.245|25565
idx: 0 checksum: 7B6AF5B9 file: C:\Program Files (x86)\Bethesda.net Launcher\games\Morrowind\Data Files\Morrowind.esm
idx: 1 checksum: F481F334 file: C:\Program Files (x86)\Bethesda.net Launcher\games\Morrowind\Data Files\Tribunal.esm
idx: 2 checksum: 43DD2132 file: C:\Program Files (x86)\Bethesda.net Launcher\games\Morrowind\Data Files\Bloodmoon.esm
idx: 3 checksum: 3CBEA6EB file: C:\Program Files (x86)\Bethesda.net Launcher\games\Morrowind\Data Files\Accurate Attack v1.2.esp
idx: 4 checksum: 2CEE3ADD file: C:\Program Files (x86)\Bethesda.net Launcher\games\Morrowind\Data Files\FatigueandMagickav1_1.ESP
OSG version: 3.4.1
Loading settings file: ./settings-default.cfg
Loading settings file: C:\Users\Ashcraft\Documents\My Games\OpenMW/settings.cfg
Adding BSA archive C:\Program Files (x86)\Bethesda.net Launcher\games\Morrowind\Data Files\Morrowind.bsa
Adding BSA archive C:\Program Files (x86)\Bethesda.net Launcher\games\Morrowind\Data Files\Tribunal.bsa
Adding BSA archive C:\Program Files (x86)\Bethesda.net Launcher\games\Morrowind\Data Files\Bloodmoon.bsa
Adding data directory C:\Program Files (x86)\Bethesda.net Launcher\games\Morrowind\Data Files
Adding data directory C:\Users\Ashcraft\Documents\My Games\OpenMW/data
Detected unusable controller: vJoy Device
Initializing OpenAL...
Failed to open default audio device
Failed to initialize audio output, sound disabled
Loading content file Morrowind.esm
Loading content file Tribunal.esm
Loading content file Bloodmoon.esm
Loading content file Accurate Attack v1.2.esp
Loading content file FatigueandMagickav1_1.ESP


If you couldn't guess I'm also running te3mp so unless that's what's causing my issues I don't know.

User avatar
akortunov
Posts: 641
Joined: 13 Mar 2017, 13:49
Location: Samara, Russian Federation

Re: No audio [Windows 10]

Post by akortunov » 04 Apr 2019, 06:11

Try to update your OpenAL-Soft: viewtopic.php?f=45&t=5824&p=62415

Cryleve
Posts: 4
Joined: 04 Apr 2019, 01:44

Re: No audio [Windows 10]

Post by Cryleve » 04 Apr 2019, 11:19

I have updated my OpenAL and I'm still getting this error. I don't know if I'll need to reinstall OpenMW and Te3mp in order for it to verify the new installation or if it can be solved otherwise

User avatar
akortunov
Posts: 641
Joined: 13 Mar 2017, 13:49
Location: Samara, Russian Federation

Re: No audio [Windows 10]

Post by akortunov » 04 Apr 2019, 12:06

Can you check if a common OpenMW (not a TES3MP) has this issue?

Cryleve
Posts: 4
Joined: 04 Apr 2019, 01:44

Re: No audio [Windows 10]

Post by Cryleve » 04 Apr 2019, 12:09

Common OpenMW doesn't have the same issue as te3mp. I've renamed my audio device to make it more identifiable, I've switched defaults around I just can't seem to figure out why it won't work.

Cryleve
Posts: 4
Joined: 04 Apr 2019, 01:44

Re: No audio [Windows 10]

Post by Cryleve » 04 Apr 2019, 12:13

I get that same log file no matter what I do. It could be a botched OpenAL install for all I know... hell that's probably what happened

davidcernat
Posts: 209
Joined: 19 Jul 2016, 01:02

Re: No audio [Windows 10]

Post by davidcernat » 04 Apr 2019, 22:21

Consider referring to this similar thread.

Post Reply