Not sure if openmw bug (fatal error signal 6)

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
bipo
Posts: 3
Joined: 02 Jun 2018, 20:54

Not sure if openmw bug (fatal error signal 6)

Post by bipo » 02 Jun 2018, 21:05

I have a mod related crash, but I wonder if it could have something to do with my setup (linux fedora 28)

This mod makes the game crash (only mod activated, fresh install).

Game crashes on start, when loading the mod.

here the crash log

openmw.cfg
(I don't know why commented mod lines went to the top)

settings.cfg
(I made a test character without mods, maybe so the game makes the first config file, I dunno)

openmw.log is blank. should I enable it somewhere?

when searching the error code I found a topic about a font issue, but I reinstalled morrowind and the fonts folder looks ok, so no sure that's it.

It's an omwaddon mod, and no one else seems to have this issue.

I put the omwaddon directy in the data folder, same. I tried the alternate start version of the addon. Tried older releases. Nope.

I tried to read the crash log but lack the skills. I'm posting here in the hope a kind soul sees an obvious fix.

[THIS GAME RUNS BEAUTIFULLY ON A LINUX LAPTOP YOU GUYS ARE GODS]
Last edited by bipo on 03 Jun 2018, 16:19, edited 4 times in total.

LoneWolf
Posts: 26
Joined: 26 Sep 2017, 19:13

Re: Not sure if openmw bug (fatal error signal 6)

Post by LoneWolf » 03 Jun 2018, 11:49

This document will expire in 6 days.
Better put the crash log somewhere else, or extend the time period.

can you add openmw.log , openmw.cfg and settings.cfg ?

User avatar
akortunov
Posts: 475
Joined: 13 Mar 2017, 13:49
Location: Samara, Russian Federation
Github profile: https://github.com/akortunov

Re: Not sure if openmw bug (fatal error signal 6)

Post by akortunov » 03 Jun 2018, 12:12

Judging by log, the crash occurs in the ESM::Script::load(ESM::ESMReader&, bool&) - an engine can not load script.
Looks like one of scripts is malformed.
Also I can not reproduce the crash in upstream master (I tried to use the ncgdMW.omwaddon).

bipo
Posts: 3
Joined: 02 Jun 2018, 20:54

Re: Not sure if openmw bug (fatal error signal 6)

Post by bipo » 03 Jun 2018, 16:20

LoneWolf wrote:
03 Jun 2018, 11:49
This document will expire in 6 days.
Better put the crash log somewhere else, or extend the time period.

can you add openmw.log , openmw.cfg and settings.cfg ?
done, I edited my post. Thanks for helping!

bipo
Posts: 3
Joined: 02 Jun 2018, 20:54

Re: Not sure if openmw bug (fatal error signal 6)

Post by bipo » 03 Jun 2018, 16:21

akortunov wrote:
03 Jun 2018, 12:12
Judging by log, the crash occurs in the ESM::Script::load(ESM::ESMReader&, bool&) - an engine can not load script.
Looks like one of scripts is malformed.
Also I can not reproduce the crash in upstream master (I tried to use the ncgdMW.omwaddon).
So this means a problem with the base game, OpenMW or the mod?

thank you for having tested this (not sure if this sentence is correct)

User avatar
akortunov
Posts: 475
Joined: 13 Mar 2017, 13:49
Location: Samara, Russian Federation
Github profile: https://github.com/akortunov

Re: Not sure if openmw bug (fatal error signal 6)

Post by akortunov » 03 Jun 2018, 16:37

bipo wrote:
03 Jun 2018, 16:21
So this means a problem with the base game, OpenMW or the mod?
I can not tell since I can not reproduce the crash.

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests