[BUG] Rain destroys FPS when leaving building (0.43)

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
Whelp
Posts: 2
Joined: 31 Jan 2018, 19:18

[BUG] Rain destroys FPS when leaving building (0.43)

Post by Whelp » 31 Jan 2018, 19:25

I've noticed that in 0.43, when it starts raining outside while I am still inside a building, my FPS (which is normally around 200) goes down to 20 once I exit the building.

Now this may seem weird, but when it starts raining normally, or when I travel to a zone where it's raining by strider or boat, this does not happen.
It only happens when I enter a cave/building/shrine/whatever while it's still clear outside, then when I exit the building and there's rain, boom: low FPS.

I dunno if I should report this or what, I don't really know how to use the bugtracker.

Could this be a hardware/driver issue on my end?

- Ryzen 5 1500x
- 8GB DDR4
- Radeon RX480 (latest driver, 18.1.1)
- Windows 10

EDIT: Now I'm not 100% on this (and no idea how to reproduce the problem anyway), but the last two times this happened there were bodies of water nearby. Maybe it's related to the water raindrop splash effect somehow?

EDIT2: forgot to mention that this is not a constant thing, fps go back to normal again when I restart the game (loading a save alone doesn't help.)

User avatar
scrawl
Posts: 2152
Joined: 18 Feb 2012, 11:51
Contact:

Re: [BUG] Rain destroys FPS when leaving building (0.43)

Post by scrawl » 31 Jan 2018, 20:45

Apparently, when I fixed #4211, I failed to realize that going inside and coming back will create a similar jump in simulation time, and drop FPS the same way.
Feel free to report a bug while I figure out what to do.

Whelp
Posts: 2
Joined: 31 Jan 2018, 19:18

Re: [BUG] Rain destroys FPS when leaving building (0.43)

Post by Whelp » 01 Feb 2018, 00:25

Interesting, so the game spams a bajillion rain particles when it's minimized and slows down as a result? (I pretty much got it minimized at some point every time I play.)

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests