[Solved] Gamma setting gets overridden

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
User avatar
NKoS
Posts: 4
Joined: 21 Dec 2015, 16:58

[Solved] Gamma setting gets overridden

Post by NKoS » 06 Sep 2016, 00:10

Hey, guys, I'm somewhat baffled here. I don't know whether this is an openMW problem, but openMW is the only game I've noticed it in so far.
My problem is that the nights, and any places that should be dark are annoyingly bright, even though my gamma slider is pretty far left. If I click on the slider, the picture gets accordingly dark for the fraction of a second, but then it gets bright immediately again.
If I change the color settings in the nvidia control panel, the exact same thing happens.
I have f.lux installed, but disabling it for an hour doesn't solve the problem.

Something obviously is interfering with my color settings, but I can't figure out what it is. Does anyone have any quick suggestions?

System:
GPU: 980 G1 gaming
CPU: some i7
OS: Win 7

EDIT: I noticed it is my second monitor. I have a 1440p monitor for games and a 1080p monitor for everything else, and the 1440p monitor has some automatic color correction nonsense or something. It's an Asus VX24A.

Edit2: So my 1440p monitor for some reason doesn't like darkness in openMW or something, but the switch-back-problem I described above affects both of them. So It's not automatic color correction. :x

Edit3: It was f.lux.
It was f.lux all along.
I'll get some sleep now.

User avatar
lysol
Posts: 1041
Joined: 26 Mar 2013, 01:48
Location: Sweden

Re: Gamma setting gets overridden

Post by lysol » 06 Sep 2016, 08:55

Sleep tight! :)
Normal mapped texture replacers, exclusive for OpenMW:
My Nexus page

User avatar
psi29a
Posts: 4173
Joined: 29 Sep 2011, 10:13
Github profile: https://github.com/psi29a/
Contact:

Re: [Solved] Gamma setting gets overridden

Post by psi29a » 06 Sep 2016, 08:59

marked as 'solved' :)

dutchbandit
Posts: 7
Joined: 07 Sep 2016, 22:00

Re: [Solved] Gamma setting gets overridden

Post by dutchbandit » 08 Sep 2016, 00:16

I've been having the same problem, except my game is too dark instead of too bright. The gamma changes when I move the slider but is reset when I take my mouse off of it.

I'm also using f.lux so I'll try playing with that. It doesn't do anything like this for other games though, so I think this is a bug with OpenMW.

Edit: I disabled f.lux and I'm still having this problem.

Edit2: Looks like it works only if I exit f.lux completely, which is rather annoying.

Edit3: f.lux apparently does this with OpenGL games, which might be why this hasn't happened to me before.

pusanghalaw
Posts: 1
Joined: 09 May 2018, 06:12

Re: [Solved] Gamma setting gets overridden

Post by pusanghalaw » 11 May 2018, 21:33

I can't find gamma correction in any of the settings in version 0.43 . A google result to me to this page but it doesn't apply at all:
https://openmw.readthedocs.io/en/master ... video.html
This setting controls the gamma correction for all video in the game. Gamma is an exponent that makes colors brighter if greater than 1.0 and darker if less than 1.0.

This setting can be changed in the Detail tab of the Video panel of the Options menu. It has been reported to not work on some Linux systems, and therefore the in-game setting in the Options menu has been disabled on Linux systems.
Exactly what is and where is the Detail tab of the Video panel of the Options menu? - I can't find it and would appreciate some help. Thanks in advance.

User avatar
AnyOldName3
Posts: 1080
Joined: 26 Nov 2015, 03:25

Re: [Solved] Gamma setting gets overridden

Post by AnyOldName3 » 12 May 2018, 01:23

In the main menu and pause menu, there's an options button. That brings up the options menu. Within that, there's a video tab. You should be able to figure out the rest.
AnyOldName3, Master of Shadows

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests