Only official ESMs loading [Solved]

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Rastem88
Posts: 7
Joined: 13 Jun 2021, 03:51

Only official ESMs loading [Solved]

Post by Rastem88 »

EDIT:: The problem is somewhere with the Luxtorpeda version I had been using. I installed OpenMW thruogh my distro and that version is working. Both appear to be version 0.46.0.




I am unable to load any mods using OpenMW 0.46.0.
The launcher is able to see the esp files I want to use, and the openmw.cfg file shows my load order at the bottom, but when the game loads only Morrowind, Tribunal, and Bloodmoon load. I have tried placing the mod esps in my added data folders and in the "Morrowind/Data Files" with no sucess.

I'm using the steam version of Morrowind. I'm running this on Linux.

I would appreciate any help, I am at my wits end trying to figure this out.

OpenMW.log

Code: Select all

Crash handler installed
Loading config file: /mnt/hdd/New_2TB_LinuxOnly/SteamGames/steamapps/common/Morrowind/openmw.cfg
Loading config file: /home/RS/.config/openmw/openmw.cfg
OpenMW version 0.46.0
Revision: 0abcb54f51
Using default (English) font encoding.
OSG version: 3.4.2
SDL version: 2.0.14
Loading settings file: /mnt/hdd/New_2TB_LinuxOnly/SteamGames/steamapps/common/Morrowind/settings-default.cfg
Loading settings file: /home/RS/.config/openmw/settings.cfg
Adding BSA archive /mnt/hdd/New_2TB_LinuxOnly/SteamGames/steamapps/common/Morrowind/Data Files/Morrowind.bsa
Adding BSA archive /mnt/hdd/New_2TB_LinuxOnly/SteamGames/steamapps/common/Morrowind/Data Files/Tribunal.bsa
Adding BSA archive /mnt/hdd/New_2TB_LinuxOnly/SteamGames/steamapps/common/Morrowind/Data Files/Bloodmoon.bsa
Adding data directory share/games/openmw/resources/vfs
Adding data directory share/games/openmw/data
Adding data directory /mnt/hdd/New_2TB_LinuxOnly/SteamGames/steamapps/common/Morrowind/Data Files
Adding data directory /mnt/hdd/New_2TB_LinuxOnly/MorrowindMods/BethPlugins
Adding data directory /mnt/hdd/New_2TB_LinuxOnly/MorrowindMods/Amdormarne
Loading keybindings file: /home/RS/.config/openmw/input_v3.xml
Initializing OpenAL...
Opened "Built-in Audio Analog Stereo"
  ALC Version: 1.1
  ALC Extensions: ALC_ENUMERATE_ALL_EXT ALC_ENUMERATION_EXT ALC_EXT_CAPTURE ALC_EXT_DEDICATED ALC_EXT_disconnect ALC_EXT_EFX ALC_EXT_thread_local_context ALC_SOFT_device_clock ALC_SOFT_HRTF ALC_SOFT_loopback ALC_SOFT_loopback_bformat ALC_SOFT_output_limiter ALC_SOFT_pause_device
  Vendor: OpenAL Community
  Renderer: OpenAL Soft
  Version: 1.1 ALSOFT 1.21.1
  Extensions: AL_EXT_ALAW AL_EXT_BFORMAT AL_EXT_DOUBLE AL_EXT_EXPONENT_DISTANCE AL_EXT_FLOAT32 AL_EXT_IMA4 AL_EXT_LINEAR_DISTANCE AL_EXT_MCFORMATS AL_EXT_MULAW AL_EXT_MULAW_BFORMAT AL_EXT_MULAW_MCFORMATS AL_EXT_OFFSET AL_EXT_source_distance_model AL_EXT_SOURCE_RADIUS AL_EXT_STEREO_ANGLES AL_LOKI_quadriphonic AL_SOFT_bformat_ex AL_SOFTX_bformat_hoa AL_SOFT_block_alignment AL_SOFTX_callback_buffer AL_SOFTX_convolution_reverb AL_SOFT_deferred_updates AL_SOFT_direct_channels AL_SOFT_direct_channels_remix AL_SOFT_effect_target AL_SOFT_events AL_SOFTX_filter_gain_ex AL_SOFT_gain_clamp_ex AL_SOFT_loop_points AL_SOFTX_map_buffer AL_SOFT_MSADPCM AL_SOFT_source_latency AL_SOFT_source_length AL_SOFT_source_resampler AL_SOFT_source_spatialize
HRTF disabled
Allocated 256 sound sources
Low-pass filter supported
EAX Reverb supported
Enumerated output devices:
  Built-in Audio Analog Stereo  TU106 High Definition Audio Controller Digital Stereo (HDMI)
Enumerated HRTF names:
  Default HRTF  Built-In HRTF
Loading content file Morrowind.esm
Loading content file Tribunal.esm
Loading content file Bloodmoon.esm
Playing music/special/morrowind title.mp3
Quitting peacefully.
End of my openmw.cfg

Code: Select all

data="/mnt/hdd/New_2TB_LinuxOnly/SteamGames/steamapps/common/Morrowind/Data Files"
data="/mnt/hdd/New_2TB_LinuxOnly/MorrowindMods/BethPlugins"
data="/mnt/hdd/New_2TB_LinuxOnly/MorrowindMods/Amdormarne"
content=Morrowind.esm
content=Tribunal.esm
content=Bloodmoon.esm
content=Expansion Delay.ESP
content=levelmult x5.esp
content=adamantiumarmor.esp
content=AreaEffectArrows.esp
content=bcsounds.esp
content=EBQ_Artifact.esp
content=entertainers.esp
content=LeFemmArmor.esp
content=master_index.esp
content=Siege at Firemoth.esp
content=RealSignposts.esp

Last edited by Rastem88 on 16 Jun 2021, 00:58, edited 1 time in total.
User avatar
Husaco
Posts: 40
Joined: 07 Aug 2011, 11:54
Location: Australia

Re: Only official ESMs loading

Post by Husaco »

Have you made sure the mods are enabled under the Data Files tab of the launcher? OpenMW supports multiple mod configurations, so mods are not automatically loaded just because it can see them.
User avatar
AnyOldName3
Posts: 2158
Joined: 26 Nov 2015, 03:25

Re: Only official ESMs loading

Post by AnyOldName3 »

That looks like it's not even trying to load those content files. Are you sure the edits you're making to openmw.cfg are sticking and also that it's the one in .config/openmw/ that you're editing? 0.46 wouldn't properly compose content lists if you had them in multiple config files.
AnyOldName3, Master of Shadows
Rastem88
Posts: 7
Joined: 13 Jun 2021, 03:51

Re: Only official ESMs loading

Post by Rastem88 »

Husaco,

Yes I am enabling them in the launcher. I'm sure they are being enabled because they are present at the end of the openmw.cfg.

AnyOldName3,

The only edits I made to the openmw.cfg were adding the 2 data folders "BehtPlugins" and "Amdormarne". I just confirmed that the edits were in the .config/openmw folder. I'm confused by this because in my log file, it shows that it is loading the 2 new data folders, but it is not loading any of the esp/mm files other than the official ones.
User avatar
Jemolk
Posts: 230
Joined: 20 Mar 2017, 02:12
Location: Sadrith Mora

Re: Only official ESMs loading

Post by Jemolk »

The content file section of the cfg doesn't have quotes around the plugin names, and the first one after the official ESMs has a space in its name. Could that be the problem? Because based on the log, it's loading the directories, but not the files, despite the files being listed in the proper place in the cfg.
Rastem88
Posts: 7
Joined: 13 Jun 2021, 03:51

Re: Only official ESMs loading

Post by Rastem88 »

Jemolk,

I just tested disabling the esp files with spaces, and that did not help. I tried adding quotes around the esp files, but when clicking play in the launcher the config is overwritten to no longer have quotes.

Thank you to everyone who's tried to help so far. :)

As an aside, when adding mods, do the individual mods need to have their own directory added, or can you toss a bunch into one mod directory?
User avatar
AnyOldName3
Posts: 2158
Joined: 26 Nov 2015, 03:25

Re: Only official ESMs loading

Post by AnyOldName3 »

Yeah, there aren't meant to be quotes for ESP names. Anyway, you're saying the content files do actually show up in the launcher?
AnyOldName3, Master of Shadows
Rastem88
Posts: 7
Joined: 13 Jun 2021, 03:51

Re: Only official ESMs loading

Post by Rastem88 »

Yes, The esp files show up in the launcher. That is how I've been enabling them. So I think my issue is somewhere between the launcher and the game loading.
User avatar
psi29a
Posts: 5099
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: Only official ESMs loading

Post by psi29a »

Any special characters in the names of your mods? Spaces?
Rastem88
Posts: 7
Joined: 13 Jun 2021, 03:51

Re: Only official ESMs loading

Post by Rastem88 »

There are some mods that have spaces in their names. I have tried running the game with those disabled and had the same problem of only the official ESM files loading.
Post Reply