Sun Glare shinning through walls and other objects

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
InsideSmoke
Posts: 5
Joined: 08 Jun 2021, 19:10

Sun Glare shinning through walls and other objects

Post by InsideSmoke »

Image

How can I fix this?

My system:
Intel(R) Core(TM) i7-5500U
CPU @ 2.40GHz
RAM 8.00 GB
intel(r) HD graphics 5500
User avatar
AnyOldName3
Posts: 2144
Joined: 26 Nov 2015, 03:25

Re: Sun Glare shinning through walls and other objects

Post by AnyOldName3 »

Firstly, what version of OpenMW have you tried? We've made some changes to how the sun glare occlusion queries work since the 0.46 release which have fixed them on some machines.
AnyOldName3, Master of Shadows
InsideSmoke
Posts: 5
Joined: 08 Jun 2021, 19:10

Re: Sun Glare shinning through walls and other objects

Post by InsideSmoke »

Sorry I forgot to mention that. I'm running version 0.47.0
User avatar
AnyOldName3
Posts: 2144
Joined: 26 Nov 2015, 03:25

Re: Sun Glare shinning through walls and other objects

Post by AnyOldName3 »

There isn't a 0.47 yet, so presumably you're using a development build. If it's vaguely recent and you're using Windows, it should have a file called CI-ID.txt in the root directory.
AnyOldName3, Master of Shadows
InsideSmoke
Posts: 5
Joined: 08 Jun 2021, 19:10

Re: Sun Glare shinning through walls and other objects

Post by InsideSmoke »

your right, that text file you mention has this text in it:

CI_COMMIT_REF_NAME master
CI_JOB_ID 1326491497
CI_COMMIT_SHA c7f8a4faae634e66e94e33980b21a775264b2a51

I had low framerates with 0.46 so downloaded the latest nightly build and ive got higher frame rate now, just that weird glitch with the sun now.
User avatar
AnyOldName3
Posts: 2144
Joined: 26 Nov 2015, 03:25

Re: Sun Glare shinning through walls and other objects

Post by AnyOldName3 »

Were you getting the sun issue with 0.46?
AnyOldName3, Master of Shadows
InsideSmoke
Posts: 5
Joined: 08 Jun 2021, 19:10

Re: Sun Glare shinning through walls and other objects

Post by InsideSmoke »

No, just to make sure I loaded up 4.6 and checked. the sun actually seems brighter in 4.7 as if there is more glare coming off it, not sure if that's just my imagination.
User avatar
AnyOldName3
Posts: 2144
Joined: 26 Nov 2015, 03:25

Re: Sun Glare shinning through walls and other objects

Post by AnyOldName3 »

There are the changes I made plus some changes in OpenSceneGraph (as we updated our OSG version since 0.46) so this might be a pain to get to the bottom of. I guess one thing that might help would be to send me an APITrace of both 0.46 and the 0.47 dev build. Instructions are here: viewtopic.php?f=8&t=5583. You'll probably get the best results with the shortest traces if you work with a saved game where the camera's aimed such that the sun's half-covered by something and half visible. Make the save in 0.46 so you can load it in both builds - it's much easier to work with two nearly identical traces.
AnyOldName3, Master of Shadows
InsideSmoke
Posts: 5
Joined: 08 Jun 2021, 19:10

Re: Sun Glare shinning through walls and other objects

Post by InsideSmoke »

That's beyond my knowledge. I looked at those guides and it might as well be in French to me.
I've been reading over it trying to wrap my head around how to run Apitrace but its speaking in a language I cant understand.
I really wanted to do my bit and help you to iron out a possible bug. I'm just a Morrowind player.

You guys have done great work with OpenMW and I'm really grateful and i know you all do this work for free.
I can live with the issue and hopefully someone else a bit more experienced with programs like PowerShell encounters it.

If it matters I'm running quite a few mods and I've made a few changes to the morrowind.ini, settings.cfg, and openmw.cfg to get a couple of the mods running correctly.
I thought that might be the problem so I made a fresh install of Morrowind, OpenMw 4.6, and OpenMW 4.7 with files all back to default.
The issue still persists in 4.7 and isn't in 4.6.
there is a definite glare in 4.7 that is not in 4.6 when i load the same save in both.

I apologize if I've wasted any of your time with this issue and thanks for trying to help.
User avatar
psi29a
Posts: 5080
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: Sun Glare shinning through walls and other objects

Post by psi29a »

No worries, any help is appreciated but I would suggest you keep our versioning scheme the same. :D

0.46 and 0.47 and not 4.6 and 4.7
Post Reply