Journal task

Everything about development and the OpenMW source code.
User avatar
Zini
Posts: 5537
Joined: 06 Aug 2011, 15:16

Re: Journal task

Post by Zini » 25 Nov 2011, 13:46

We are talking about MyGUI related resources?

See extern/mygui_3.0.1/CMakeLists.txt. The configure_file lines.

User avatar
gus
Posts: 390
Joined: 11 Aug 2011, 15:41

Re: Journal task

Post by gus » 28 Nov 2011, 16:59

I've commited the code in my journal branch. Right now, i'm not focusing anymore in having the journal in the right place (ie in the center of the screen), but if anyone is willing to help, you just need to look at openmw_journal_layout.xml (it's a very simple XML file).

User avatar
Zini
Posts: 5537
Joined: 06 Aug 2011, 15:16

Re: Journal task

Post by Zini » 28 Nov 2011, 21:14

Does not build for me.
CMakeFiles/openmw.dir/mwgui/window_manager.cpp.o: In function `MWGui::WindowManager::WindowManager(MyGUI::Gui*, MWWorld::Environment&, Compiler::Extensions const&, bool, bool)':
window_manager.cpp:(.text+0x5b8): undefined reference to `MWGui::JournalWindow::JournalWindow(MWGui::WindowManager&)'
CMakeFiles/openmw.dir/mwgui/window_manager.cpp.o: In function `MWGui::WindowManager::WindowManager(MyGUI::Gui*, MWWorld::Environment&, Compiler::Extensions const&, bool, bool)':
window_manager.cpp:(.text+0x1166): undefined reference to `MWGui::JournalWindow::JournalWindow(MWGui::WindowManager&)'
You probably forgot to add the new source files to cmake. Also, the name of the new source files does not match our naming convention (see wiki).

User avatar
gus
Posts: 390
Joined: 11 Aug 2011, 15:41

Re: Journal task

Post by gus » 28 Nov 2011, 23:01

ooops my bad, I indeed completely forgot to add them on CMake. I will correct it soon (and the files name too).

User avatar
gus
Posts: 390
Joined: 11 Aug 2011, 15:41

Re: Journal task

Post by gus » 01 Dec 2011, 13:46

Can you compile now? (i added the file in CMakeList, but for some unknown reason, it has destroyed some setting for Visual Studio and I have some error with boost)

User avatar
Zini
Posts: 5537
Joined: 06 Aug 2011, 15:16

Re: Journal task

Post by Zini » 01 Dec 2011, 14:03

Nope. Doesn't even merge without conflict. Looks like you are using really outdated cmake scripts. No point in trying to resolve these conflicts. I suggest you throw away the changes to the cmake files, merge in my master and then redo them.

User avatar
gus
Posts: 390
Joined: 11 Aug 2011, 15:41

Re: Journal task

Post by gus » 11 Dec 2011, 11:33

Done. Better now?

User avatar
Zini
Posts: 5537
Joined: 06 Aug 2011, 15:16

Re: Journal task

Post by Zini » 11 Dec 2011, 11:50

Well, it merges cleanly and builds too. But it crashes on startup:
Loading config file: /home/marc/.config/openmw/openmw.cfg... done.
Loading config file: ./openmw.cfg... done.
Using default (English) font encoding.
Ignoring all but the first master file (multiple master files not yet supported).
Adding ./data/Bloodmoon.bsa
Adding ./data/Morrowind.bsa
Adding ./data/Tribunal.bsa
Data dir ./data
Loading ESM ./data/Morrowind.esm
player
ERROR: basic_string::at

User avatar
gus
Posts: 390
Joined: 11 Aug 2011, 15:41

Re: Journal task

Post by gus » 11 Dec 2011, 16:25

Strange, it works fine with my computer. Can you give me a stack trace?

Edit: it might also be related to some local language settings. For example, it crash if I add some french accents in the journal.

User avatar
Zini
Posts: 5537
Joined: 06 Aug 2011, 15:16

Re: Journal task

Post by Zini » 11 Dec 2011, 22:43

That might be an explanation. Are you using any journal data from the ESM files yet? I have the German version of Morrowind.esm, so that might explain it.

Post Reply