0.11.1 Release

Everything about development and the OpenMW source code.
User avatar
pvdk
Posts: 523
Joined: 12 Aug 2011, 16:34

Re: 0.11.1 Release

Post by pvdk » 26 Sep 2011, 10:55

Ok I tested it with Windows XP inside VirtualBox and it works. Only, the data= path specified in the config is still ./data. I think we should use a reasonable default, like:

Code: Select all

data=C:\Program Files\Bethesda Softworks\Morrowind\Data Files
Also, we don't have icons for the launcher in Windows. It seems that Windows XP doesn't support the .ico I made. It would be nice if someone could fix this. It looks like it should be working with a valid icon, since there's a launcher.rc and an entry for it in launcher.pro.

User avatar
Zini
Posts: 5537
Joined: 06 Aug 2011, 15:16

Re: 0.11.1 Release

Post by Zini » 26 Sep 2011, 12:24

Only, the data= path specified in the config is still ./data. I think we should use a reasonable default, like:
We have already more elaborate plans for that. See the configuration thread in this forum section.
Also, we don't have icons for the launcher in Windows. It seems that Windows XP doesn't support the .ico I made. It would be nice if someone could fix this. It looks like it should be working with a valid icon, since there's a launcher.rc and an entry for it in launcher.pro.
should go into 0.12.0 too.

User avatar
pvdk
Posts: 523
Joined: 12 Aug 2011, 16:34

Re: 0.11.1 Release

Post by pvdk » 26 Sep 2011, 12:28

Yeah I know but what's the problem with providing just one reasonable default for the 0.11.1 release, as the only thing that happens right now with a badly configured OpenMW is a silently crashing launcher, no error messages or such. Only when the launcher is started from the command-line one can see the problem and I think no-one reads ReadMe's.

User avatar
Ace (SWE)
Posts: 834
Joined: 15 Aug 2011, 14:56

Re: 0.11.1 Release

Post by Ace (SWE) » 26 Sep 2011, 13:10

Which is why I said that the launcher should give a warning message or even a chooser where the user can graphically choose the data folder.
For 0.12.0 I suppose we're going to check the registry for the Morrowind install path?

User avatar
pvdk
Posts: 523
Joined: 12 Aug 2011, 16:34

Re: 0.11.1 Release

Post by pvdk » 26 Sep 2011, 13:13

Ace (SWE) wrote:Which is why I said that the launcher should give a warning message or even a chooser where the user can graphically choose the data folder.
As discussed above: this is a problem with the file collection component, not the launcher. It does give a warning message when there are no data= entries found, but currently does not check their validity. But maybe you're right, maybe the launcher should handle this.

User avatar
Zini
Posts: 5537
Joined: 06 Aug 2011, 15:16

Re: 0.11.1 Release

Post by Zini » 26 Sep 2011, 13:41

Yeah I know but what's the problem with providing just one reasonable default for the 0.11.1 release, as the only thing that happens right now with a badly configured OpenMW is a silently crashing launcher, no error messages or such.
The 0.11.1 release is done. We are only waiting for the announcement post. Can't change it any more without delaying it even further. Also, manual setting of the data path was required since the first version and we have it even described in the readme file.
For 0.12.0 I suppose we're going to check the registry for the Morrowind install path?
That is one of the thing we will be doing. Please read the thread I mentioned. It is all explained there.
But maybe you're right, maybe the launcher should handle this.
As I wrote before that is not necessary. We have these problems already covered. Or at least we will once the configuration improvements for 0.12.0 are fully implemented.

User avatar
raevol
Posts: 3054
Joined: 07 Aug 2011, 01:12
Location: Caldera

Re: 0.11.1 Release

Post by raevol » 26 Sep 2011, 17:18

Zini wrote:The 0.11.1 release is done. We are only waiting for the announcement post.
Posted! Eeee!

User avatar
Zini
Posts: 5537
Joined: 06 Aug 2011, 15:16

Re: 0.11.1 Release

Post by Zini » 26 Sep 2011, 19:43

Good. Then we need the video and we will be done with 0.11. Let's hope we will never get into that much trouble with a release again.

btw. I suggest that in the future release discussions are held in the general forum instead of the development forum (I had already made a thread for it). These kinds of discussions are more about organisation that about actual development.

User avatar
Rhys
Posts: 113
Joined: 06 Aug 2011, 01:51
Location: Australia

Re: 0.11.1 Release

Post by Rhys » 27 Sep 2011, 00:12

The updated .7z file on the googlecode site does not contain the .dll or updated readme.
This version does though:
Ace (SWE) wrote:I've reuploaded the windows release with the Readme.txt and, possibly, missing DirectX DLL.
http://ace.haxalot.com/projects/OpenMW/ ... 1-win32.7z

User avatar
raevol
Posts: 3054
Joined: 07 Aug 2011, 01:12
Location: Caldera

Re: 0.11.1 Release

Post by raevol » 27 Sep 2011, 00:20

Rhys wrote:The updated .7z file on the googlecode site does not contain the .dll or updated readme.
Are you sure your browser didn't have it cached? They look identical to me...

Post Reply