Windows Binaries for 0.37

Everything about development and the OpenMW source code.
Post Reply
User avatar
openmwfan27
Posts: 113
Joined: 23 Apr 2015, 22:11

Windows Binaries for 0.37

Post by openmwfan27 » 02 Dec 2015, 20:10

Are there any windows binaries for the latest 0.37 version of openmw?

I can only see 0.36.1 here: https://downloads.openmw.org/windows/ and the 32bit installer found here: https://github.com/OpenMW/openmw/releases claims it's version 0.36.1 when you run it (not sure if this is just a typo)

User avatar
lysol
Posts: 1401
Joined: 26 Mar 2013, 01:48
Location: Sweden

Re: Windows Binaries for 0.37

Post by lysol » 02 Dec 2015, 20:36

First: Wrong forum :)


Anyway: here is a link that works. Just scroll down the massive changelog. The download page says this:

"Executables and packages are available at:

GitHub OpenMW Download Page
or here, on downloads.openmw.org"


For some reason, only the github page was updated. Seems downloads.openmw.org page wasn't.

Someone fix maybe? ;)

EDIT: Sorry I'm tired. Read your post a bit too fast.

I would guess it's just a typo. Otherwise someone would have noticed already. If you want to, try it and see. If you have shadows working, then it's 0.36.1. If not, it's 0.37.0.
Normal mapped texture replacers, exclusive for OpenMW:
My Nexus page

User avatar
openmwfan27
Posts: 113
Joined: 23 Apr 2015, 22:11

Re: Windows Binaries for 0.37

Post by openmwfan27 » 02 Dec 2015, 20:48

Thanks lysol :) , i did try the version from the github page anyway, after the installer openmw launches fine but it still refer's to itself as 0.36.1 even in game, however i suspect that really it is the OSG version as i never managed to get the OGRE build to launch on my windows tablet.

I tried an earlier build of 0.37 before it was released and i could run it although the framerate was fairly low. The version from the github page also launches and the frame rate is much much better (even though it's hovering at around 8-12 FPS outside and about 15-20 inside). The tablet is not a powerfull one so i'm not expecting much with framerate but it makes it just about playable now :)

I think the references to 0.36.1 must just be a typo.

User avatar
psi29a
Posts: 4805
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: Windows Binaries for 0.37

Post by psi29a » 02 Dec 2015, 21:25

You mean this:
https://github.com/OpenMW/openmw/releas ... -win64.exe
or
https://github.com/OpenMW/openmw/releas ... -win32.exe

?

Are you saying that openmw-launcher declares itself as 0.36.1 ? Post a screenshot? Try uninstalling the previous release?

User avatar
openmwfan27
Posts: 113
Joined: 23 Apr 2015, 22:11

Re: Windows Binaries for 0.37

Post by openmwfan27 » 02 Dec 2015, 21:37

I used https://github.com/OpenMW/openmw/releas ... -win32.exe

I'm getting 0.36.1 in the installer, launcher and on the main menu of the game. I uninstalled all the previous versions of OpenMW before installing the build above.

The windows tablet im testing on doesn't have a keyboard plugged in and for some reason the print-screen button is not working (i'm using Synergy to control the tablet over the LAN from my main PC). I'll see if i can get some screenshots though and post them here.

User avatar
Lazaroth
Posts: 220
Joined: 30 May 2012, 05:04

Re: Windows Binaries for 0.37

Post by Lazaroth » 02 Dec 2015, 21:44

That file installs 0.37 here, visible in both the launcher and in-game. Try reinstalling again.
openmwfan27 wrote: print-screen button is not working
You can rebind the screenshot button in options.

User avatar
Ace (SWE)
Posts: 843
Joined: 15 Aug 2011, 14:56

Re: Windows Binaries for 0.37

Post by Ace (SWE) » 03 Dec 2015, 08:20

Checked myself just to be sure, and the download is for 0.37.0 indeed, maybe a trouble with upgrading?

Check if there's a OpenMW folder in "Program Files" / "Program Files (x86)" on 64-bit, and in that case delete it after uninstalling. The launcher and game read the version info from a file called resources\version, and that file states 0.37.0, so I'm guessing that file fails to install for you.

Post Reply