[Android port] Incorrect Texture Placement

For new and upcoming OpenMW branches and ports; move fast and break things!
Post Reply
WolfsLegionary
Posts: 5
Joined: 13 Mar 2019, 08:35

[Android port] Incorrect Texture Placement

Post by WolfsLegionary » 13 Mar 2019, 08:43

Hey, Im fairly new to OpenMW and so far have loved it! However I ran into a rather strange, and from what I can gather, a rather unknown or un-discussed problem. Whenever I switch from Glesv1 To Glesv2 for some reason my textures in game get all screwed up, the terrain texture seems to not blend leaving straight boxes of varius texture lying all around aswell as each of those random texture boxes seem to appear in the wrong locations, Ill have path textures show up off the side of roads and such. Its really dissappointing because in Glesv1 The water shader doesnt seem to work, and Glesv2 the water shaders work however the terrain textures are all over the place. Ive searched everywhere and couldnt find any topics on this problem. Please help?

User avatar
wareya
Posts: 338
Joined: 09 May 2015, 13:07

Re: Incorrect Texture Placement

Post by wareya » 13 Mar 2019, 09:16

Post a screenshot?
paying attention to #1751 #2473 #3609 #3862/#3929 #3807 #4297 #4623

User avatar
psi29a
Posts: 4915
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: Incorrect Texture Placement

Post by psi29a » 13 Mar 2019, 09:30

This is a android question...

WolfsLegionary
Posts: 5
Joined: 13 Mar 2019, 08:35

Re: [Android port] Incorrect Texture Placement

Post by WolfsLegionary » 13 Mar 2019, 15:52

Screenshot_20190313-035619_OpenMW.jpg
Screenshot_20190313-035619_OpenMW.jpg (105.93 KiB) Viewed 1387 times
Screenshot_20190313-035609_OpenMW.jpg
Screenshot_20190313-035609_OpenMW.jpg (116.12 KiB) Viewed 1387 times

WolfsLegionary
Posts: 5
Joined: 13 Mar 2019, 08:35

Re: [Android port] Incorrect Texture Placement

Post by WolfsLegionary » 13 Mar 2019, 23:44

Screenshot_20190312-000532_OpenMW.jpg
Screenshot_20190312-000532_OpenMW.jpg (61.61 KiB) Viewed 1345 times

Post Reply