Page 39 of 50

Re: Android part 2

Posted: 06 Oct 2019, 19:44
by xyzz
https://github.com/xyzz/openmw-android/ ... 27-nightly
- Minor UI improvements
- Updated OpenMW to 9a2771476621effd47d4dd0ee22dde0f2584c06b
- Updated gl4es to v1.1.2

Re: Android part 2

Posted: 07 Oct 2019, 05:35
by Destroyer5150
Thanks! Please change the app icon to the Morrowind icon. And it'll be cool to make the app launch the game and not the openmw menu at launch besides the first use. Change it to long press to give an option for the openmw menu. Just to make it look prettier lol.

Re: Android part 2

Posted: 08 Oct 2019, 09:49
by lysol
Destroyer5150 wrote:
07 Oct 2019, 05:35
Thanks! Please change the app icon to the Morrowind icon. And it'll be cool to make the app launch the game and not the openmw menu at launch besides the first use. Change it to long press to give an option for the openmw menu. Just to make it look prettier lol.
Bad idea due to Bethesda not wanting OpenMW to market the android port running Morrowind. Hence the name "OpenMicroWave".

Re: Android part 2

Posted: 12 Oct 2019, 13:29
by Rygorlios
Figured out why no esp's and no esm's were being loaded. It appears that for some reason in my case, due to having a customized openmw.cfg file, I need to disable all entries in the OMW mod manager. After unchecking everything there (though it only lists the base game things) and choosing 'proceed anyway' when given the warning that nothing is enabled on startup, it works perfectly again :) .

Re: Android part 2

Posted: 13 Oct 2019, 16:28
by Rygorlios
One thing I've been noticing for a while with OpenMW that's missing on Android is any kind of glare/flare when you look at the sun. I was surprised to see it when I finally tried OpenMW on PC because I had never seen it on my phone. I've not seen it in anyone's OpenMW Android screenshots either so I assume it's not just my device?

Re: Android part 2

Posted: 13 Oct 2019, 22:07
by Capostrophic
No, it's not just your device, it can also happen on the PC. Android port uses OSG 3.6.4 which has broken backward compatibility of occlusion query nodes usage which are used for the sun glare. It can't use 3.4.1.

Re: Android part 2

Posted: 14 Oct 2019, 18:53
by Rygorlios
Capostrophic wrote:
13 Oct 2019, 22:07
No, it's not just your device, it can also happen on the PC. Android port uses OSG 3.6.4 which has broken backward compatibility of occlusion query nodes usage which are used for the sun glare. It can't use 3.4.1.
Interesting, does this also affect culling? Because whenever performance drags on my device (primarily in very detailed Tamriel Rebuilt areas), it seems to be CPU-limited due to draw calls (educated guess since I get same performance at low resolutions as I do at qhd).

Re: Android part 2

Posted: 14 Oct 2019, 19:37
by AnyOldName3
We don't do occlusion culling, just view frustum culling. Excessive draw calls are a problem on the PC, too.

Re: Android part 2

Posted: 14 Oct 2019, 20:52
by Laicus
AnyOldName3 wrote:
14 Oct 2019, 19:37
...
Is there any chance that shadows will work on the port?

Re: Android part 2

Posted: 15 Oct 2019, 20:35
by Rygorlios
AnyOldName3 wrote:
14 Oct 2019, 19:37
We don't do occlusion culling, just view frustum culling. Excessive draw calls are a problem on the PC, too.
Ah yes I read that before somewhere. Is there any foreseeable solution on the horizon or anything that would mitigate this? It's just about the only problem I have with OpenMW on Android.