Android part 2

For new and upcoming OpenMW branches and ports; move fast and break things!
burgerrito
Posts: 3
Joined: 12 Aug 2018, 07:56

Cannot install the latest update (v0.46.0-15)

Post by burgerrito » 04 May 2019, 12:27

Cannot install the latest update (v0.46.0-15) on my device (Nokia 6 2017 TA-1021, with Android 9.0 Pie). It says "App not installed." with warning sign over it

xyzz
Posts: 154
Joined: 14 Jan 2018, 22:25

Re: Android part 2

Post by xyzz » 04 May 2019, 12:50

Xlo wrote:
04 May 2019, 02:56
Updated to 0.46.15
Tried running game got to posted picture again.
Reset config files
Game crashes upon hitting play now.
log says no content files loaded.

config file only has "# This is the user openmw.cfg. Feel free to modify it as you wish."

Replace with a back up of my old cofig file and once again getting the fatal error after load order is done loading before entering title screen.

All in all I am missing 3 items from what i gathered from the crash report.
*resources/shaders/shadowcasting_vertex.glsl (seems to be ignored)
*resources/shaders/shadowcasting_fragment.glsl (ignored)
*Error: MyGUI EXCEPTION : widget name 'DeleteSpellButton' in layout 'openmw_spell_window.layout' not found.
in MyGUI at /mnt/android-port/buildscripts/build/arm/openmw-prefix/src/openmw/apps/openmw/mwgui/layout.cpp (line 77) [This one is the one crasing me out
You need to reset config files and also enable some mods in the mod manager, otherwise it would exit as there is nothing to load. If you want to use your own setup with a custom user openmw.cfg instead of the mod manager that also works but you need to delete all lines from it except the mod related ones (content, fallback-archive and data). Currently you have a stale “resources” line which points to an invalid folder and conflicts with the proper location.

Xlo
Posts: 4
Joined: 04 May 2019, 00:41

Re: Android part 2

Post by Xlo » 04 May 2019, 13:23

Reuploaded my morrowind.ini from my pc and everything works as should. Thanks for all the help Xyzz, Amazing work your doing.

Mod manager doesn't pick up my mods but as im loading through the custom config file i can keep my mods organized in diffrent folders so thats probbally my issue there.

Glad I can play again, game runs smoother on 0.46.15 as well.

Thanks agains Xyzz your a godsend with your quick responses and helping to resolve everyones issues with your fork.

xyzz
Posts: 154
Joined: 14 Jan 2018, 22:25

Re: Cannot install the latest update (v0.46.0-15)

Post by xyzz » 04 May 2019, 13:24

burgerrito wrote:
04 May 2019, 12:27
Cannot install the latest update (v0.46.0-15) on my device (Nokia 6 2017 TA-1021, with Android 9.0 Pie). It says "App not installed." with warning sign over it
Can you get adb logcat from a pc and PM the log to me?

burgerrito
Posts: 3
Joined: 12 Aug 2018, 07:56

Re: Cannot install the latest update (v0.46.0-15)

Post by burgerrito » 04 May 2019, 14:53

xyzz wrote:
04 May 2019, 13:24
burgerrito wrote:
04 May 2019, 12:27
Cannot install the latest update (v0.46.0-15) on my device (Nokia 6 2017 TA-1021, with Android 9.0 Pie). It says "App not installed." with warning sign over it
Can you get adb logcat from a pc and PM the log to me?
Nevermind, this was fixed after I restarted my device. I will make sure to restart my device if there is an issue next time. Sorry for the confusion and also thanks for your hardwork, xyzz :D

reddragon72
Posts: 40
Joined: 06 Apr 2019, 20:11

Re: Android part 2

Post by reddragon72 » 04 May 2019, 16:25

Tecumseh1976 wrote:
03 May 2019, 02:09
The message I am getting with the last two APK uploads.

Please select a directory which contains both the Morrowind ini file and the data file directory.
If you have installed the latest openMW for PC it asks for the ini file as well as the data directory.

The first time I installed OpenMWA I was looking for the place to put the ini file but it never asked but now it does. Just try putting the ini file in the same dir as the data files and point it towards there.

Sonny101
Posts: 12
Joined: 11 Apr 2018, 13:06

Re: Android part 2

Post by Sonny101 » 04 May 2019, 16:51

sweet, tried out the new option to optimize graphics and I believe I have about 10 FPS increase in Balmora, I don't even drop under 30FPS now with max view distance (Nokia 8, Pie)
played it for only a while but I haven't run into any crashes or bugs

gaialily
Posts: 8
Joined: 04 May 2019, 20:30

Re: Android part 2

Post by gaialily » 04 May 2019, 20:39

Hi everyone,
First thank you to xyzz for this port, it's awesome.
I just wanted to know, the new option to improve performance, it's the option "preloading" in the menu, right ?
And I don't see the new "mouse" UI button.
Thanks.

Sonny101
Posts: 12
Joined: 11 Apr 2018, 13:06

Re: Android part 2

Post by Sonny101 » 04 May 2019, 21:15

gaialily wrote:
04 May 2019, 20:39
Hi everyone,
First thank you to xyzz for this port, it's awesome.
I just wanted to know, the new option to improve performance, it's the option "preloading" in the menu, right ?
And I don't see the new "mouse" UI button.
Thanks.
first of all, always make sure you actually have the newest version, second of all,it's called "Enable unsafe graphics optimizations" under "Performance"
the mouse button is near the top-center of the screen (when in-game), between the Save button and Keyboard

gaialily
Posts: 8
Joined: 04 May 2019, 20:30

Re: Android part 2

Post by gaialily » 04 May 2019, 22:49

OK. I had the new version but changes didn't appear since I reboot my tel.
Thank you.

Post Reply