Page 1 of 1

Water not display.

Posted: 02 Oct 2018, 14:23
by Zanarkan
Glesv2
Missing Textures
2 Img ⬇
https://ibb.co/fHUkBx
https://ibb.co/c8DCrx
Glesv1
No water display
1 Img ⬇
https://ibb.co/inGnPH
Water display if i look down
1 Img ⬇
https://ibb.co/htUwJc
Glesv1 modify openmw.cfg (All Land Fog Lines - Values set to 0)
Located here ➡ com.libopenmw.openmw/config/openmw/openmw.cfg
1 Img ⬇
https://ibb.co/cf4rjH

I do a fresh install and remove all mod do a lot modification (openmw.cfg).
Try old and new version of openmw.apk even try to change some option
in my Tab (i have rooted tab).

I have replace every water files in openmw ressource folder.
I am now back to the original new install...
nothing seems to work.

This is not a big problem only water not display...
but it is not possible for me to play like this (i now this is better then nothing).

Still i can't enjoy the game because
if i chose to have water i have no fog only white wall its ugly
and if i chose to have normal fog (better experience more imermersive)
i have no water -_-

Feels like the anwser is so close but i can't reach it.
Please Help me by advance Thank You.

Re: Water not display.

Posted: 04 Oct 2018, 11:13
by mojoswagger1980
Zanarkan wrote:
02 Oct 2018, 14:23
Glesv2
Missing Textures
2 Img ⬇
https://ibb.co/fHUkBx
https://ibb.co/c8DCrx
Glesv1
No water display
1 Img ⬇
https://ibb.co/inGnPH
Water display if i look down
1 Img ⬇
https://ibb.co/htUwJc
Glesv1 modify openmw.cfg (All Land Fog Lines - Values set to 0)
Located here ➡ com.libopenmw.openmw/config/openmw/openmw.cfg
1 Img ⬇
https://ibb.co/cf4rjH

I do a fresh install and remove all mod do a lot modification (openmw.cfg).
Try old and new version of openmw.apk even try to change some option
in my Tab (i have rooted tab).

I have replace every water files in openmw ressource folder.
I am now back to the original new install...
nothing seems to work.

This is not a big problem only water not display...
but it is not possible for me to play like this (i now this is better then nothing).

Still i can't enjoy the game because
if i chose to have water i have no fog only white wall its ugly
and if i chose to have normal fog (better experience more imermersive)
i have no water -_-

Feels like the anwser is so close but i can't reach it.
Please Help me by advance Thank You.
Hi,
Did you enable the water shader? Its broken if you did and it would cause the water to completely disapear.
****edit**** yeah thats what it looks like when your using the broken shader (i just saw your pics) its missing all textures, you just have meshes rendering. Disable any shaders for now. You can disable via the settings.cfg but you will need to copy the default-settings.cfg from /sdcard/data/android/com.libopenmw.openmw/openmw/ to the directory with the opemw.cfg rename it settings.cfg deleting or renaming the original. This is a complete settings list. Resolution cant be changed however, and the shaders (pretty much any setting involving shading) is non functional and/or broken.

Re: Water not display.

Posted: 04 Oct 2018, 15:09
by Zanarkan
No bro i dont have any shaders on.
This is the first trick i try change in game option but
if i put shader ON nothing change exept if i put reflection ON in the same time.
In this case the water become Withe.
Thank you anyway because you try to help !

Re: Water not display.

Posted: 05 Oct 2018, 01:05
by Zanarkan
I find this but i really dont now what to do whit it.

If you read my previous post, check this out. I notice that viewing distance (fog) affect water surface, so if I set longer distance 26666 from default 6666, water is no longer bugged by fog. On the other hand if I load a cell up to 2 or 3 its not performance fps friendly. So I hope it could be figured out in future updates somehow :).
On first gif 6666, second one 26666,
https://imgur.com/gallery/36JlA

And

The issue with the water is caused by the large faces of the water surface messing with per-vertex fog. It's worked around here by applying a shader so that fog is always per pixel, but for some reason the previous android port developer #if'd out that part. https://github.com/OpenMW/openmw/blob/m ... r.cpp#L504

Re: Water not display.

Posted: 05 Oct 2018, 18:11
by mojoswagger1980
Zanarkan wrote:
04 Oct 2018, 15:09
No bro i dont have any shaders on.
This is the first trick i try change in game option but
if i put shader ON nothing change exept if i put reflection ON in the same time.
In this case the water become Withe.
Thank you anyway because you try to help !
Hmm i have white water only on gles1. Admitably i cant seem to get the texture on the ship to disapear like yours does in pic. Not sure, thought it must be shader when i saw you floating where water should be . Just in case you inadeverntly messed with a setting, i would reset the config (3 dot menu in launcher) just so you are back to square 1 and try again. Is there any chance of file corruption ? did you zip the game data to transfer it to your phone? maybe somthing didnt transfer, look in the data-files folder of the installation, find the texture folder, inside there should be 2 folders partaining to water. Are they both present?

Re: Water not display.

Posted: 05 Oct 2018, 23:20
by Zanarkan
In my install folder in pc i dont have any texture folder... i looking in google for this problem but the texture are here because i can see the water when i look down.

Re: Water not display.

Posted: 06 Oct 2018, 00:54
by Zanarkan
The issue with the water is caused by the large faces of the water surface messing with per-vertex fog. It's worked around here by applying a shader so that fog is always per pixel, but for some reason the previous android port developer #if'd out that part.

Anyway to fix this ⬆ ?

Re: Water not display.

Posted: 06 Oct 2018, 02:12
by Zanarkan
Problem solve !
I got lucky now i will not modify anything.

Here is my fix
First i do like you said ⬇

but you will need to copy the default-settings.cfg from /sdcard/data/android/com.libopenmw.openmw/openmw/ to the directory with the opemw.cfg rename it settings.cfg deleting or renaming the original.

Then i set ➖ viewing distance = 50000.0
No water problem now but fps is very bad so i try some change and there is the best part only modify this lines ⬇

small feature culling = true
small feature culling pixel size = 16.0
exterior cell load distance = 1
preload instances = true
preload cell cache min = 7
preload cell cache max = 7
preload cell expiry delay = 5
prediction time = 1
cache expiry delay = 5
target framerate = 30
pointers cache size = 40
anisotropy = 0
texture mag filter = nearest
texture min filter = nearest
texture mipmap = nearest

Now morrowind run like it is on pc all right 30 fps outside inside
(i think i can set to 60 but like i said i will change nothing ☺).

I really think change linear to nearest settings HELP a lot
for performance.

Thank you for your help mojoswagger1980 😆 ++
I will not leave this forum (now then my mw is working great).
Be shure i will keep trying to help as many folk as i can !