[WIP] Android port testing

For new and upcoming OpenMW branches and ports; move fast and break things!
mojoswagger1980
Posts: 193
Joined: 04 May 2018, 05:16

Re: [WIP] Android port testing

Post by mojoswagger1980 » 26 Jun 2018, 05:14

Starsheep wrote:
25 Jun 2018, 04:19
mojoswagger1980 wrote:
25 Jun 2018, 03:46
actually if your device can handle it, raising the thread count would cause cells to load faster, which could help stability in cases where it crashes when changing cells.
Just in case, for reference, so that you know which value you want exactly
preload num threads
Type: integer
Range: >=1
Default: 1
Controls the number of worker threads used for preloading operations. In addition to the preloading threads, OpenMW uses a main thread, a sound streaming thread, and a graphics thread. Therefore, the default setting of one preloading thread will result in a total of 4 threads used which should work well with quad-core CPUs. If you have additional cores to spare, consider increasing the number of preloading threads to 2 or 3 for a boost in preloading performance. Faster preloading will reduce the chance that a cell could not be completely loaded before the player moves into it, and hence reduce the chance of seeing loading screens or frame drops. This may be especially relevant when the player moves at high speed and/or a large number of cells are loaded in via ‘exterior cell load distance’.

A value of 4 or higher is not recommended. With 4 or more threads, improvements will start to diminish due to file reading and synchronization bottlenecks.
oh yeah lol proabably should have explaine that a little better. anyway the value 1 actually indicates there are 4 seperate threads running so 2 would be 8 and so on and so forth. 2 is proabably pushing the envelope but who knows ?

mojoswagger1980
Posts: 193
Joined: 04 May 2018, 05:16

Re: [WIP] Android port testing

Post by mojoswagger1980 » 26 Jun 2018, 05:41

Pelayo wrote:
25 Jun 2018, 14:59
Just tested it in my 5.1 intel tablet, seems to load the initial cell perfectly (the ship in vanilla startup), then crashes when exiting the ship hatch. Same thing happens when using two different alternate start mods (which I tried just in case there was something wrong with the seyda neen cell and my tablet). So it happens when changing cells apparently. Other than that, I'm amazed at how fast it seems to be while it works.
decrease view distance and run opengl2 library. lots of people had trouble there and the first building, but reported it working better afterwards. do you have the steam or GoG version ? the cut scenes (.bik) can be a problem , they are not needed and can be simply deleted. they dont play with the goty edition released by bethesda. i tried it after the GoG version wouldnt stop crashing when changing from outdoor to indoor cells and found the original to be way way stabler (its a lighter install too) the GoG version came bundled with all the official bethesda plugins already installed but needed to be loaded to activate but all the meshes and junk were already in the data-files folder.

VinnyHaw
Posts: 3
Joined: 20 Jun 2018, 09:07

Re: [WIP] Android port testing

Post by VinnyHaw » 26 Jun 2018, 08:58

mojoswagger1980 wrote:
26 Jun 2018, 05:41
Pelayo wrote:
25 Jun 2018, 14:59
Just tested it in my 5.1 intel tablet, seems to load the initial cell perfectly (the ship in vanilla startup), then crashes when exiting the ship hatch. Same thing happens when using two different alternate start mods (which I tried just in case there was something wrong with the seyda neen cell and my tablet). So it happens when changing cells apparently. Other than that, I'm amazed at how fast it seems to be while it works.
decrease view distance and run opengl2 library. lots of people had trouble there and the first building, but reported it working better afterwards. do you have the steam or GoG version ? the cut scenes (.bik) can be a problem , they are not needed and can be simply deleted. they dont play with the goty edition released by bethesda. i tried it after the GoG version wouldnt stop crashing when changing from outdoor to indoor cells and found the original to be way way stabler (its a lighter install too) the GoG version came bundled with all the official bethesda plugins already installed but needed to be loaded to activate but all the meshes and junk were already in the data-files folder.
Hello, I have the steam goty edition.
I've been playing this for awhile and it runs just fine. Crashing only comes up when I enter/exit doors. I tried deleting the video folder and loaded up the game then walked up to a building. I entered/exit/entered and when I tried to exit again the game crashed.

Playing on my pixel 2

Oh and one last thing. I've made some changes in game to my controls (using the 0-9 keys and changing the onscreen "always run" button into my next spell button). Problem is whenever I'm done playing and reload the game I have to reconfigure the hotkeys. Do you know how to save them so they stick?

KeepBotting
Posts: 4
Joined: 26 Jun 2018, 16:06

Re: [WIP] Android port testing

Post by KeepBotting » 26 Jun 2018, 16:27

Hi,

The Android port of OpenMW crashes immediately on startup for me. A black screen with UI elements appears, hangs for a few seconds, then the app crashes and I receive an "Unfortunately, OpenMW has stopped" error from Android. A tiny bit of audio output can be heard before the crash occurs. It is too brief to make out.

I have a Samsung Galaxy J7 Sky Pro SM-S727VL running Android 6.0.1. I am using the GOTY edition of the game. My directory structure looks like this:

Code: Select all

total 574129
-rw------- 1 branon branon 118425318 Jun 22  2013 Bloodmoon.bsa
-rw------- 1 branon branon   9631798 Jun 22  2013 Bloodmoon.esm
drwx------ 1 branon branon         0 Jun 20 22:05 Fonts
-rw------- 1 branon branon 310459500 Jun 22  2013 Morrowind.bsa
-rw------- 1 branon branon  79837557 Jun 22  2013 Morrowind.esm
drwx------ 1 branon branon         0 Jun 20 22:05 Music
drwx------ 1 branon branon         0 Jun 20 22:05 Sound
drwx------ 1 branon branon         0 Jun 20 22:05 Splash
-rw------- 1 branon branon  64986032 Jun 22  2013 Tribunal.bsa
-rw------- 1 branon branon   4565686 Jun 22  2013 Tribunal.esm
drwx------ 1 branon branon         0 Jun 20 22:06 Video
Here is the output of running adb logcat before attempting to start OpenMW: http://netherworld.pw:81/files/openmw_log.txt
The log file is very large so I have uploaded it to my web server. I do not know how to interpret ADB logs so I am unsure if this contains the information needed.

Please let me know if there is any more information I should provide, and if there's anything I can do to get OpenMW running.
Thanks!

mojoswagger1980
Posts: 193
Joined: 04 May 2018, 05:16

Re: [WIP] Android port testing

Post by mojoswagger1980 » 26 Jun 2018, 19:14

KeepBotting wrote:
26 Jun 2018, 16:27
Hi,

The Android port of OpenMW crashes immediately on startup for me. A black screen with UI elements appears, hangs for a few seconds, then the app crashes and I receive an "Unfortunately, OpenMW has stopped" error from Android. A tiny bit of audio output can be heard before the crash occurs. It is too brief to make out.

I have a Samsung Galaxy J7 Sky Pro SM-S727VL running Android 6.0.1. I am using the GOTY edition of the game. My directory structure looks like this:

Code: Select all

total 574129
-rw------- 1 branon branon 118425318 Jun 22  2013 Bloodmoon.bsa
-rw------- 1 branon branon   9631798 Jun 22  2013 Bloodmoon.esm
drwx------ 1 branon branon         0 Jun 20 22:05 Fonts
-rw------- 1 branon branon 310459500 Jun 22  2013 Morrowind.bsa
-rw------- 1 branon branon  79837557 Jun 22  2013 Morrowind.esm
drwx------ 1 branon branon         0 Jun 20 22:05 Music
drwx------ 1 branon branon         0 Jun 20 22:05 Sound
drwx------ 1 branon branon         0 Jun 20 22:05 Splash
-rw------- 1 branon branon  64986032 Jun 22  2013 Tribunal.bsa
-rw------- 1 branon branon   4565686 Jun 22  2013 Tribunal.esm
drwx------ 1 branon branon         0 Jun 20 22:06 Video
Here is the output of running adb logcat before attempting to start OpenMW: http://netherworld.pw:81/files/openmw_log.txt
The log file is very large so I have uploaded it to my web server. I do not know how to interpret ADB logs so I am unsure if this contains the information needed.

Please let me know if there is any more information I should provide, and if there's anything I can do to get OpenMW running.
Thanks!
which game of the year edition ? (who distributed it? bethesda, GoG, or Steam)

KeepBotting
Posts: 4
Joined: 26 Jun 2018, 16:06

Re: [WIP] Android port testing

Post by KeepBotting » 26 Jun 2018, 19:19

mojoswagger1980 wrote:
26 Jun 2018, 19:14
KeepBotting wrote:
26 Jun 2018, 16:27
Hi,

The Android port of OpenMW crashes immediately on startup for me. A black screen with UI elements appears, hangs for a few seconds, then the app crashes and I receive an "Unfortunately, OpenMW has stopped" error from Android. A tiny bit of audio output can be heard before the crash occurs. It is too brief to make out.

I have a Samsung Galaxy J7 Sky Pro SM-S727VL running Android 6.0.1. I am using the GOTY edition of the game. My directory structure looks like this:

Code: Select all

total 574129
-rw------- 1 branon branon 118425318 Jun 22  2013 Bloodmoon.bsa
-rw------- 1 branon branon   9631798 Jun 22  2013 Bloodmoon.esm
drwx------ 1 branon branon         0 Jun 20 22:05 Fonts
-rw------- 1 branon branon 310459500 Jun 22  2013 Morrowind.bsa
-rw------- 1 branon branon  79837557 Jun 22  2013 Morrowind.esm
drwx------ 1 branon branon         0 Jun 20 22:05 Music
drwx------ 1 branon branon         0 Jun 20 22:05 Sound
drwx------ 1 branon branon         0 Jun 20 22:05 Splash
-rw------- 1 branon branon  64986032 Jun 22  2013 Tribunal.bsa
-rw------- 1 branon branon   4565686 Jun 22  2013 Tribunal.esm
drwx------ 1 branon branon         0 Jun 20 22:06 Video
Here is the output of running adb logcat before attempting to start OpenMW: http://netherworld.pw:81/files/openmw_log.txt
The log file is very large so I have uploaded it to my web server. I do not know how to interpret ADB logs so I am unsure if this contains the information needed.

Please let me know if there is any more information I should provide, and if there's anything I can do to get OpenMW running.
Thanks!
which game of the year edition ? (who distributed it? bethesda, GoG, or Steam)
Hi,

These files are from the Steam GOTY edition of the game. I also have access to Bethesda's version, on-disc from the TES Anthology boxset. I have not tried those files, though they should(?) be functionally identical.

mojoswagger1980
Posts: 193
Joined: 04 May 2018, 05:16

Re: [WIP] Android port testing

Post by mojoswagger1980 » 26 Jun 2018, 19:45

mojoswagger1980 wrote:
26 Jun 2018, 19:14
KeepBotting wrote:
26 Jun 2018, 16:27
Hi,

The Android port of OpenMW crashes immediately on startup for me. A black screen with UI elements appears, hangs for a few seconds, then the app crashes and I receive an "Unfortunately, OpenMW has stopped" error from Android. A tiny bit of audio output can be heard before the crash occurs. It is too brief to make out.

I have a Samsung Galaxy J7 Sky Pro SM-S727VL running Android 6.0.1. I am using the GOTY edition of the game. My directory structure looks like this:

Code: Select all

total 574129
-rw------- 1 branon branon 118425318 Jun 22  2013 Bloodmoon.bsa
-rw------- 1 branon branon   9631798 Jun 22  2013 Bloodmoon.esm
drwx------ 1 branon branon         0 Jun 20 22:05 Fonts
-rw------- 1 branon branon 310459500 Jun 22  2013 Morrowind.bsa
-rw------- 1 branon branon  79837557 Jun 22  2013 Morrowind.esm
drwx------ 1 branon branon         0 Jun 20 22:05 Music
drwx------ 1 branon branon         0 Jun 20 22:05 Sound
drwx------ 1 branon branon         0 Jun 20 22:05 Splash
-rw------- 1 branon branon  64986032 Jun 22  2013 Tribunal.bsa
-rw------- 1 branon branon   4565686 Jun 22  2013 Tribunal.esm
drwx------ 1 branon branon         0 Jun 20 22:06 Video
Here is the output of running adb logcat before attempting to start OpenMW: http://netherworld.pw:81/files/openmw_log.txt
The log file is very large so I have uploaded it to my web server. I do not know how to interpret ADB logs so I am unsure if this contains the information needed.

Please let me know if there is any more information I should provide, and if there's anything I can do to get OpenMW running.
Thanks!
which game of the year edition ? (who distributed it? bethesda, GoG, or Steam)
mojoswagger1980 wrote:
26 Jun 2018, 19:14
KeepBotting wrote:
26 Jun 2018, 16:27
Hi,

The Android port of OpenMW crashes immediately on startup for me. A black screen with UI elements appears, hangs for a few seconds, then the app crashes and I receive an "Unfortunately, OpenMW has stopped" error from Android. A tiny bit of audio output can be heard before the crash occurs. It is too brief to make out.

I have a Samsung Galaxy J7 Sky Pro SM-S727VL running Android 6.0.1. I am using the GOTY edition of the game. My directory structure looks like this:

Code: Select all

total 574129
-rw------- 1 branon branon 118425318 Jun 22  2013 Bloodmoon.bsa
-rw------- 1 branon branon   9631798 Jun 22  2013 Bloodmoon.esm
drwx------ 1 branon branon         0 Jun 20 22:05 Fonts
-rw------- 1 branon branon 310459500 Jun 22  2013 Morrowind.bsa
-rw------- 1 branon branon  79837557 Jun 22  2013 Morrowind.esm
drwx------ 1 branon branon         0 Jun 20 22:05 Music
drwx------ 1 branon branon         0 Jun 20 22:05 Sound
drwx------ 1 branon branon         0 Jun 20 22:05 Splash
-rw------- 1 branon branon  64986032 Jun 22  2013 Tribunal.bsa
-rw------- 1 branon branon   4565686 Jun 22  2013 Tribunal.esm
drwx------ 1 branon branon         0 Jun 20 22:06 Video
Here is the output of running adb logcat before attempting to start OpenMW: http://netherworld.pw:81/files/openmw_log.txt
The log file is very large so I have uploaded it to my web server. I do not know how to interpret ADB logs so I am unsure if this contains the information needed.

Please let me know if there is any more information I should provide, and if there's anything I can do to get OpenMW running.
Thanks!
which game of the year edition ? (who distributed it? bethesda, GoG, or Steam) the game provides its own log located at /sdcard/android/data/com.libopenmw.openmw/config/, may i see yours? wait that ended on cut-scene(your log) .try deleting the cut-scenes (.bik) and

mojoswagger1980
Posts: 193
Joined: 04 May 2018, 05:16

Re: [WIP] Android port testing

Post by mojoswagger1980 » 26 Jun 2018, 19:53

mojoswagger1980 wrote:
26 Jun 2018, 19:45
mojoswagger1980 wrote:
26 Jun 2018, 19:14
KeepBotting wrote:
26 Jun 2018, 16:27
Hi,

The Android port of OpenMW crashes immediately on startup for me. A black screen with UI elements appears, hangs for a few seconds, then the app crashes and I receive an "Unfortunately, OpenMW has stopped" error from Android. A tiny bit of audio output can be heard before the crash occurs. It is too brief to make out.

I have a Samsung Galaxy J7 Sky Pro SM-S727VL running Android 6.0.1. I am using the GOTY edition of the game. My directory structure looks like this:

Code: Select all

total 574129
-rw------- 1 branon branon 118425318 Jun 22  2013 Bloodmoon.bsa
-rw------- 1 branon branon   9631798 Jun 22  2013 Bloodmoon.esm
drwx------ 1 branon branon         0 Jun 20 22:05 Fonts
-rw------- 1 branon branon 310459500 Jun 22  2013 Morrowind.bsa
-rw------- 1 branon branon  79837557 Jun 22  2013 Morrowind.esm
drwx------ 1 branon branon         0 Jun 20 22:05 Music
drwx------ 1 branon branon         0 Jun 20 22:05 Sound
drwx------ 1 branon branon         0 Jun 20 22:05 Splash
-rw------- 1 branon branon  64986032 Jun 22  2013 Tribunal.bsa
-rw------- 1 branon branon   4565686 Jun 22  2013 Tribunal.esm
drwx------ 1 branon branon         0 Jun 20 22:06 Video
Here is the output of running adb logcat before attempting to start OpenMW: http://netherworld.pw:81/files/openmw_log.txt
The log file is very large so I have uploaded it to my web server. I do not know how to interpret ADB logs so I am unsure if this contains the information needed.

Please let me know if there is any more information I should provide, and if there's anything I can do to get OpenMW running.
Thanks!
which game of the year edition ? (who distributed it? bethesda, GoG, or Steam)
mojoswagger1980 wrote:
26 Jun 2018, 19:14
KeepBotting wrote:
26 Jun 2018, 16:27
Hi,

The Android port of OpenMW crashes immediately on startup for me. A black screen with UI elements appears, hangs for a few seconds, then the app crashes and I receive an "Unfortunately, OpenMW has stopped" error from Android. A tiny bit of audio output can be heard before the crash occurs. It is too brief to make out.

I have a Samsung Galaxy J7 Sky Pro SM-S727VL running Android 6.0.1. I am using the GOTY edition of the game. My directory structure looks like this:

Code: Select all

total 574129
-rw------- 1 branon branon 118425318 Jun 22  2013 Bloodmoon.bsa
-rw------- 1 branon branon   9631798 Jun 22  2013 Bloodmoon.esm
drwx------ 1 branon branon         0 Jun 20 22:05 Fonts
-rw------- 1 branon branon 310459500 Jun 22  2013 Morrowind.bsa
-rw------- 1 branon branon  79837557 Jun 22  2013 Morrowind.esm
drwx------ 1 branon branon         0 Jun 20 22:05 Music
drwx------ 1 branon branon         0 Jun 20 22:05 Sound
drwx------ 1 branon branon         0 Jun 20 22:05 Splash
-rw------- 1 branon branon  64986032 Jun 22  2013 Tribunal.bsa
-rw------- 1 branon branon   4565686 Jun 22  2013 Tribunal.esm
drwx------ 1 branon branon         0 Jun 20 22:06 Video
Here is the output of running adb logcat before attempting to start OpenMW: http://netherworld.pw:81/files/openmw_log.txt
The log file is very large so I have uploaded it to my web server. I do not know how to interpret ADB logs so I am unsure if this contains the information needed.

Please let me know if there is any more information I should provide, and if there's anything I can do to get OpenMW running.
Thanks!
which game of the year edition ? (who distributed it? bethesda, GoG, or Steam) the game provides its own log located at /sdcard/android/data/com.libopenmw.openmw/config/, may i see yours? wait that ended on cut-scene(your log) .try deleting the cut-scenes (.bik) and
i had the GoG but the bethesda goty edition a friend let me use is way lighter and doesnt have the cutscenes installed if you have the time its worth it. idk about steam version but the GoG had all bethesdas patches installed but not loaded by default . the file structure and content very by distributor but i think the steam version is much closer than GoG version including only steams launcher icon and scripts additionally and a slightly different root directory, but no new meshes or anything like the GoG version. check your meshes folder, if its empty its unaltered. not 100% but most of bethesdas patches would have added various meshes

KeepBotting
Posts: 4
Joined: 26 Jun 2018, 16:06

Re: [WIP] Android port testing

Post by KeepBotting » 26 Jun 2018, 23:15

mojoswagger1980 wrote:
26 Jun 2018, 19:53
*snip*
Thanks for your help. After deleting cinematics the game is running flawlessly for me, at more than acceptable fps too. For reference, I went into the Videos directory of my Morrowind installation, and deleted all the .bik files.

Here's a picture: Image

I'll play through it as I have time and report any bugs back here. Many thanks!

pianobadger
Posts: 6
Joined: 25 Jun 2018, 20:03

Re: [WIP] Android port testing

Post by pianobadger » 26 Jun 2018, 23:40

pianobadger wrote:
25 Jun 2018, 20:09
Pelayo wrote:
25 Jun 2018, 14:59
Just tested it in my 5.1 intel tablet, seems to load the initial cell perfectly (the ship in vanilla startup), then crashes when exiting the ship hatch. Same thing happens when using two different alternate start mods (which I tried just in case there was something wrong with the seyda neen cell and my tablet). So it happens when changing cells apparently. Other than that, I'm amazed at how fast it seems to be while it works.
I just tried it on a Kindle Fire running Fire OS 5.6.1.0 and the same exact thing happened to me. Everything went smoothly until I tried to exit the ship hatch at which point it crashed. Also, I am not using the steam version.
I tried again with the steam version and It crashed upon trying to start the game. I deleted the video files and after that I was able to load the game but it crashed again on trying to leave the ship. Lowering view distance had no effect.

I noticed in the log file that a lot of weather related fallback values were not found, but it seemed to work past that. The last entry after unloading the Imperial Prison Ship cell was loading cell -3, -10. I opened the CS and noticed that is not the correct cell. It should be loading Cell -2,-9. I have no idea why it is trying to load the wrong cell or whether that is the cause of the crash. Not sure what to try next.

Post Reply