Page 1 of 1

Simple Picture Frame (Solved)

Posted: 11 Dec 2019, 00:17
by UnderSunandSky
Hi guys

Im trying to make the house I made OpenMW friendly. Theres only one problem, thats a map I made.

Heres what it should look like

Heres what it does look like

Any suggestions? Im an utter beginner, but I have NifSkope, Blendr and

Re: Simple Picture Frame

Posted: 11 Dec 2019, 05:52
by akortunov
Check your openmw.log. Your texture may be missing, or use unsupported data format.

Re: Simple Picture Frame

Posted: 11 Dec 2019, 15:41
by UnderSunandSky
Yep, missing texture.

Failed to open image: Resource 'textures/f:/openmorrowind/data files/textures/usas/' not found

but the texture is definitely in there.

Its saved as a .DDS file, BC1, Linear, DXT1, with BC6H / BC7 Compression Mode. Perceptual Error Metric, no cube maps, no mip maps.
(Im just reading out the export settings on

My Nifskope settings are here

So why does it work in normal'wind, and not OpenMW?

Also, nifskope is saying that the mesh is looking for the texture in F:\OpenMorrowind\Data Files\Textures\USaS\

Does that mean, if someone on the internet downloads my mod, theyll probably be installing it into a different directory and the textures definitely wont work for them? Shouldnt the mesh just look in the Data Files parent directory?

Re: Simple Picture Frame

Posted: 11 Dec 2019, 18:56
by Capostrophic
The path is broken, make it relative, not absolute. It was never going to work on any PC but your own either way.
Remove the part before the second "textures" in the mesh file path.

Re: Simple Picture Frame

Posted: 11 Dec 2019, 19:24
by UnderSunandSky

So I changed the file path. Turns out you can just double click that part and erase the text manually.

It then looked like this

the NifSkope preview couldnt load the textures, but when I loaded OpenMW, I have a map on the wall! I made a mesh work!

Thankyou both for your help. May you walk on warm sands!

Re: Simple Picture Frame (Solved)

Posted: 12 Dec 2019, 10:15
by UnderSunandSky
My house mod is up on Nexus and it works on OpenMW.

Thankyou for your help.