OpenMW 0.45.0

Anything related to PR, release planning and any other non-technical idea how to move the project forward should be discussed here.
User avatar
lysol
Posts: 1401
Joined: 26 Mar 2013, 01:48
Location: Sweden

Re: OpenMW 0.45.0

Post by lysol » 15 Feb 2019, 22:47

Yep, I tested too. They work fine.
Normal mapped texture replacers, exclusive for OpenMW:
My Nexus page

User avatar
raevol
Posts: 3067
Joined: 07 Aug 2011, 01:12
Location: Caldera

Re: OpenMW 0.45.0

Post by raevol » 15 Feb 2019, 23:31

Nice, alright. Paging @Atahualpa how are we looking?

User avatar
Atahualpa
Posts: 1083
Joined: 09 Feb 2016, 20:03

Re: OpenMW 0.45.0

Post by Atahualpa » 16 Feb 2019, 10:56

raevol wrote:
15 Feb 2019, 23:31
Nice, alright. Paging @Atahualpa how are we looking?
As you already noticed, the announcement is proofread (and I'm also halfway through the translation). Still need a bit of time for the videos, so please be patient.

New status should be:
Current Release Status
Windows RCs: tested
Linux Binary RCs: tested
Mac RCs: tested
Changelog: finished
Videos: in process (Atahualpa)

User avatar
raevol
Posts: 3067
Joined: 07 Aug 2011, 01:12
Location: Caldera

Re: OpenMW 0.45.0

Post by raevol » 16 Feb 2019, 18:47

Many thanks!

User avatar
drakovyrn
Posts: 63
Joined: 17 Feb 2017, 03:51
Contact:

Re: OpenMW 0.45.0

Post by drakovyrn » 16 Feb 2019, 22:07

64-bit Windows RCs seem to be working well for my Windows 7 machine, or, as well as usual.

I did notice, however, that the jumping mechanic has changed. The distance covered by a forward jump is now always the same, whether jumping from a walking start or running start. Is this an issue, or intentional? If intentional, this is a pretty big hit on QoL, as I like being able to vary jumping distance by forward momentum (it's the most logical, in any case).

User avatar
drakovyrn
Posts: 63
Joined: 17 Feb 2017, 03:51
Contact:

Re: OpenMW 0.45.0

Post by drakovyrn » 18 Feb 2019, 04:11

I just retested with vanilla MW, jumping is broken in 0.45, at least on the Windows 64-bit RCs that I tested on W7.

EDIT: I tried to download k1ll's Linux RCs to test them, but the links are not working for me. I can't test them as of now.

halcyon
Posts: 8
Joined: 05 Dec 2018, 00:32

Re: OpenMW 0.45.0

Post by halcyon » 19 Feb 2019, 03:06

I hadn't pinned down just what was different, but now that it's pointed out--the macOS version also performs as drakovyrn describes.

User avatar
Capostrophic
Posts: 752
Joined: 22 Feb 2016, 20:32

Re: OpenMW 0.45.0

Post by Capostrophic » 19 Feb 2019, 13:24

I already submitted a fix.

Though learning about the issue so late after I introduced it accidentally in September is mildly infuriating. :oops:

User avatar
psi29a
Posts: 4803
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: OpenMW 0.45.0

Post by psi29a » 19 Feb 2019, 19:37

So... last round of 'fixes' for new RCs? (hit me)

User avatar
psi29a
Posts: 4803
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: OpenMW 0.45.0

Post by psi29a » 19 Feb 2019, 21:32

https://github.com/OpenMW/openmw/pull/2 ... 9e15084b52
https://github.com/OpenMW/openmw/pull/2 ... 8732a8fb42

These two have been pushed to openmw-45 branch, please make new RC builds.

Should fix jumping issues and russian localization issues.

Post Reply