OpenMW 0.39.0

Anything related to PR, release planning and any other non-technical idea how to move the project forward should be discussed here.
User avatar
AnyOldName3
Posts: 1858
Joined: 26 Nov 2015, 03:25

Re: OpenMW 0.39.0

Post by AnyOldName3 » 13 Apr 2016, 15:54

What were you having compatibility issues with? I've only ever had problems with really ancient peripheral drivers, and usually these things only work with software that requires a Windows 98 VM anyway. Most of Windows' dominance of the desktop and laptop market is because Microsoft tend to avoid breaking compatibility with things that worked on older versions of the OS. Also, your RAM (2 x 4GB) is more than a 32-bit OS can address anyway, so you're definitely taking a big hit there.
AnyOldName3, Master of Shadows

User avatar
Atahualpa
Posts: 1127
Joined: 09 Feb 2016, 20:03

Re: OpenMW 0.39.0

Post by Atahualpa » 13 Apr 2016, 21:11

All right, the - hopefully - final engine video has been uploaded. :) Any reviews are appreciated as I changed quite a bit.

------------------------------------------------
>>> https://youtu.be/6SIz0LYWJzQ <<<
------------------------------------------------

The script is to be found here: viewtopic.php?f=20&t=3415&p=38657#p38657
I'm currently finishing the editor video. The long rendering times are slowing me down a lot...

User avatar
ElderTroll
Posts: 499
Joined: 25 Jan 2012, 07:01

Re: OpenMW 0.39.0

Post by ElderTroll » 14 Apr 2016, 00:18

That is the best video you have made so far. You really dealt with those problem areas excellently. The use of wireframe mode was a great idea. :D
“A society grows great when old men plant trees whose shade they know they shall never sit in.”

User avatar
Atahualpa
Posts: 1127
Joined: 09 Feb 2016, 20:03

Re: OpenMW 0.39.0

Post by Atahualpa » 14 Apr 2016, 03:36

Aaaand the editor video has been uploaded. There weren't many text changes but I re-arranged most scenes. Please, have a look.

----------------------------------------------
>>> https://youtu.be/IthswdFkyss <<<
----------------------------------------------

If you like, check out the script: viewtopic.php?f=20&t=3415&p=38667#p38667
I'll do the subtitles and the German translation after getting some sleep.
ElderTroll wrote:That is the best video you have made so far. You really dealt with those problem areas excellently. The use of wireframe mode was a great idea. :D
Thanks a lot, ElderTroll! :)

User avatar
openmwfan27
Posts: 113
Joined: 23 Apr 2015, 22:11

Re: OpenMW 0.39.0

Post by openmwfan27 » 14 Apr 2016, 12:26

DestinedToDie wrote:
openmwfan27 wrote:Screenshots: http://imgur.com/a/U27bl
I´m guessing those are the fake normal maps made for use with MCP, which is why they light so strangely. Since the old engine did not support true normal mapping even with Morrowind Code Patch, there are close to no mods at the moment that use real normal mapping. You could download Lysol´s Vivec Retexture. There were a few normal maps provided by PeterBritt, but don´t know where to download them. I am currently making normal maps for my assets, though it may be a while before I publish anything. OpenMW- Example Suite is supposed to have normal mapped assets.
Morrowind Rebirth has really shiny rocks too in 0.39, this is the same issue as the textures mentioned above?

Image
Image

http://imgur.com/a/ofrJ0

How hard would it be for a mod author to fix or update their mod, is it an automated kind of batch process or are normal maps handled in a completely different way which requires manual 'porting' of the textures?

User avatar
Zini
Posts: 5537
Joined: 06 Aug 2011, 15:16

Re: OpenMW 0.39.0

Post by Zini » 14 Apr 2016, 13:30

The tag has been applied. Please start the release.

User avatar
Atahualpa
Posts: 1127
Joined: 09 Feb 2016, 20:03

Re: OpenMW 0.39.0

Post by Atahualpa » 14 Apr 2016, 13:40

Zini wrote:The tag has been applied. Please start the release.
Does this imply the final videos are accurate? Just asking because if there are any objections it will take me some time to apply changes (rendering times). The sooner you complain the better for me.

User avatar
Zini
Posts: 5537
Joined: 06 Aug 2011, 15:16

Re: OpenMW 0.39.0

Post by Zini » 14 Apr 2016, 13:50

Just finished watching. Looks good.

User avatar
lysol
Posts: 1425
Joined: 26 Mar 2013, 01:48
Location: Sweden

Re: OpenMW 0.39.0

Post by lysol » 14 Apr 2016, 14:09

openmwfan27 wrote:
DestinedToDie wrote:
openmwfan27 wrote:Screenshots: http://imgur.com/a/U27bl
I´m guessing those are the fake normal maps made for use with MCP, which is why they light so strangely. Since the old engine did not support true normal mapping even with Morrowind Code Patch, there are close to no mods at the moment that use real normal mapping. You could download Lysol´s Vivec Retexture. There were a few normal maps provided by PeterBritt, but don´t know where to download them. I am currently making normal maps for my assets, though it may be a while before I publish anything. OpenMW- Example Suite is supposed to have normal mapped assets.
Morrowind Rebirth has really shiny rocks too in 0.39, this is the same issue as the textures mentioned above?

How hard would it be for a mod author to fix or update their mod, is it an automated kind of batch process or are normal maps handled in a completely different way which requires manual 'porting' of the textures?
Yes.

No idea how these fake bump maps are made though, so I have no idea if it could be an automated process or not.
Normal mapped texture replacers, exclusive for OpenMW:
My Nexus page

K1ll
Posts: 153
Joined: 06 Aug 2011, 21:54

Re: OpenMW 0.39.0

Post by K1ll » 14 Apr 2016, 15:10

OpenMW 0.39.0 Release Linux targz packages:

32 Bit
64 Bit

Post Reply