OpenMW 0.39.0

Anything related to PR, release planning and any other non-technical idea how to move the project forward should be discussed here.
aesylwinn
Posts: 243
Joined: 14 Dec 2015, 20:30

Re: OpenMW 0.39.0

Post by aesylwinn » 08 Apr 2016, 03:26

1. The verifier for the Topic Infos table doesn't check if the NPC assigned to a record exists. I don't know if that is beyond the purpose of that particular verifier but it seems that error isn't catched anywhere else.
If you are referring to the Actor field, an error message should be generated if the referenced record isn't an npc, or a creature. Otherwise, its a bug.

I'll mention this just in case because I can't reproduce the issue. The journal and topic error messages are sort of hidden at the end of the list beneath the script verifier output. Unfortunately, no sorting or filtering is implemented at the moment.
2. How am I supposed to check the Journal Infos table verifier's functionality? I tried a negative Quest Index but that didn't result in an error message.
Is it illegal to have a negative quest index? It certainly goes against convention, but does it break the game? If so, then it was overlooked. The Journal verifier will check for duplicated journal indices, multiple quests with a named status, a missing description, and journal stubs without infos.

Cramal
Posts: 186
Joined: 19 Sep 2014, 13:37

Re: OpenMW 0.39.0

Post by Cramal » 08 Apr 2016, 06:15

For negative quest entry, if I remember correctly it was not intended but there is still some that exist in the vanilla+extension esm because management of quest entries before Tribunal was really bad.

User avatar
Zini
Posts: 5537
Joined: 06 Aug 2011, 15:16

Re: OpenMW 0.39.0

Post by Zini » 08 Apr 2016, 08:27

#3 and #4 look like bugs. Please file a bug report.

User avatar
Atahualpa
Posts: 1127
Joined: 09 Feb 2016, 20:03

Re: OpenMW 0.39.0

Post by Atahualpa » 08 Apr 2016, 11:19

Zini wrote:#3 and #4 look like bugs. Please file a bug report.
Done. Is the Start Scripts issue a blocker for the current release?
aesylwinn wrote: If you are referring to the Actor field, an error message should be generated if the referenced record isn't an npc, or a creature. Otherwise, its a bug.

I'll mention this just in case because I can't reproduce the issue. The journal and topic error messages are sort of hidden at the end of the list beneath the script verifier output. Unfortunately, no sorting or filtering is implemented at the moment.
You're right. I made a mistake while testing this issue. The verifier seems to work fine. :)
aesylwinn wrote: Is it illegal to have a negative quest index? It certainly goes against convention, but does it break the game? If so, then it was overlooked. The Journal verifier will check for duplicated journal indices, multiple quests with a named status, a missing description, and journal stubs without infos.
Thanks for your help. I managed to produce a decent error message.

User avatar
openmwfan27
Posts: 113
Joined: 23 Apr 2015, 22:11

Re: OpenMW 0.39.0

Post by openmwfan27 » 08 Apr 2016, 11:21

Is anyone running into some tree's being neon green?

I'm not sure if this is a mod or stock textures for tree's, i can't remember installing any tree-specific mod's but they could have been added by another mod.

The last two images show the same type of tree but in 0.38, the other screenshots are from 0.39.

Not sure if this is a bug or related to the texture issue's i mentioned earlier. The neon green on the tree's also effects the map preview as well.

Not all tree's are effected either, it's only this type of tree as far as i can see however, i've not looked too hard for other tree's with this issue.

Screenshots: http://imgur.com/a/pyUVC

MacKom
Posts: 43
Joined: 26 Mar 2013, 13:00

Re: OpenMW 0.39.0

Post by MacKom » 08 Apr 2016, 12:29

Those are custom/mod trees. Taking a peek inside the nifs should show what`s different from vanilla trees (ie shader settings or custom maps).

User avatar
Zini
Posts: 5537
Joined: 06 Aug 2011, 15:16

Re: OpenMW 0.39.0

Post by Zini » 08 Apr 2016, 14:44

Done. Is the Start Scripts issue a blocker for the current release?
Nope.

User avatar
raevol
Posts: 3077
Joined: 07 Aug 2011, 01:12
Location: Caldera

Re: OpenMW 0.39.0

Post by raevol » 09 Apr 2016, 22:57

Hi all, sorry I am running a little behind on this. I have a big project due for school. I should be able to get to this in the next few days though. My apologies!

User avatar
Atahualpa
Posts: 1127
Joined: 09 Feb 2016, 20:03

Re: OpenMW 0.39.0

Post by Atahualpa » 09 Apr 2016, 23:44

raevol wrote:Hi all, sorry I am running a little behind on this. I have a big project due for school. I should be able to get to this in the next few days though. My apologies!
Buys me some time to optimise the release videos. Good luck with your project! :)

@scrawl, @Zini: Is there anything else to complain about in the WIP videos? If not I'll start work on the final videos this evening (Sunday). This may take more time than expected (including some script refinement, @ElderTroll), so the videos should be ready on Tuesday.

User avatar
ElderTroll
Posts: 499
Joined: 25 Jan 2012, 07:01

Re: OpenMW 0.39.0

Post by ElderTroll » 10 Apr 2016, 02:13

@ raevol, good luck with your project. We still luv ya. @atahualpa, I'll check my email now.
“A society grows great when old men plant trees whose shade they know they shall never sit in.”

Post Reply