OpenMW Game Template

Anything related to PR, release planning and any other non-technical idea how to move the project forward should be discussed here.
Post Reply
User avatar
psi29a
Posts: 4637
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: OpenMW Game Template

Post by psi29a » 25 Jul 2015, 21:28

I'm using win7 with openmw 0.36.1, can you try deleting your cache directory?

User avatar
DestinedToDie
Posts: 1149
Joined: 29 Jun 2015, 09:08

Re: OpenMW Game Template

Post by DestinedToDie » 25 Jul 2015, 21:56

Deleted. And no difference. Does not work on Windows 7 either.

User avatar
psi29a
Posts: 4637
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: OpenMW Game Template

Post by psi29a » 25 Jul 2015, 22:06

What does it say in the crash log?

User avatar
DestinedToDie
Posts: 1149
Joined: 29 Jun 2015, 09:08

Re: OpenMW Game Template

Post by DestinedToDie » 25 Jul 2015, 22:12

There's a crashlog? I didn't know there was one. Where can I find it?

If you meant OpenMW.log, then:

OpenMW version 0.36.1 (revision e8e3407062)
Loading config file: C:\Users\Veiko\Documents\My Games\OpenMW/openmw.cfg... done.
Loading config file: ./openmw.cfg... done.
Using default (English) font encoding.
Data dir C:\openmw-template
Data dir C:\Users\Veiko\Documents\My Games\OpenMW/data
Sound output: OpenAL
Sound decoder: FFmpeg
Enumerated output devices:
Generic Software on Speakers (Realtek High Definition Audio)
Generic Software on Realtek Digital Output (Realtek High Definition Audio)
Opened "Generic Software on Speakers (Realtek High Definition Audio)"
Failed to play video: OGRE EXCEPTION(6:FileNotFoundException): Cannot locate resource video\bethesda logo.bik in resource group General or any other group. in ResourceGroupManager::openResource at B:\Programming\Libraries\Ogre\Source\OgreMain\src\OgreResourceGroupManager.cpp (line 756)
Removing outdated shader: "C:\Users\Veiko\Documents\My Games\OpenMW/cache\openmw_shadowcaster_fragment_3005401705981720424"
Removing outdated shader: "C:\Users\Veiko\Documents\My Games\OpenMW/cache\openmw_shadowcaster_fragment_46082713231544159"
Removing outdated shader: "C:\Users\Veiko\Documents\My Games\OpenMW/cache\openmw_shadowcaster_vertex_3005401705981720424"
Removing outdated shader: "C:\Users\Veiko\Documents\My Games\OpenMW/cache\openmw_shadowcaster_vertex_46082713231544159"
Removing outdated shader: "C:\Users\Veiko\Documents\My Games\OpenMW/cache\sun_fragment_2654435770"
Removing outdated shader: "C:\Users\Veiko\Documents\My Games\OpenMW/cache\sun_vertex_2654435770"
No loading screens found!
Loading content file openmw-template.omwgame
No loading screens found!
Playing Music/Special/morrowind title.mp3
Music Error: OGRE EXCEPTION(6:FileNotFoundException): Cannot locate resource Music/Special/morrowind title.mp3 in resource group General or any other group. in ResourceGroupManager::openResource at B:\Programming\Libraries\Ogre\Source\OgreMain\src\OgreResourceGroupManager.cpp (line 756)
Failed to play video: OGRE EXCEPTION(6:FileNotFoundException): Cannot locate resource video\mw_logo.bik in resource group General or any other group. in ResourceGroupManager::openResource at B:\Programming\Libraries\Ogre\Source\OgreMain\src\OgreResourceGroupManager.cpp (line 756)


However all of this is generated BEFORE i hit "New" button. When I hit new button, no extra lines come up in the console and the game simply stops working without a reason given. The game does work when I include Morrowind BSAs, so I can only guess that it is not loading the data at all. Everything comes back to this line:

data="C:\openmw-template"

It doesn't work. Well, it does point where to look, since if I include Fallback BSAs into that folder, it will load them, but it will not load the nifs and other stuff you made.

Loriel
Posts: 145
Joined: 28 May 2015, 00:44

Re: OpenMW Game Template

Post by Loriel » 25 Jul 2015, 23:56

Appears to work correctly for me, using the OSG branch 0.36, on Windows 8.1.

New starts a new game, with no errors, though little to see or do - which I presume is the intention.

Loriel

User avatar
psi29a
Posts: 4637
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: OpenMW Game Template

Post by psi29a » 26 Jul 2015, 00:16

Thanks Loriel for testing it! Yes, not much to do really... which is the intention of the template. You get to fill in the blanks for there on in. Obviously we can always improve it.

Thank you DestinedToDie for testing this as well, we'll figure out the problem eventually. Can you post your openmw.cfg to pastbin so we can have a look? I mean, it is loading the OpenMW title screen which indicates that it is indeed reading the assets. It looks like there is something happening while loading the meshes, like a collision.

@Zini and @Ace: is there a crash log, dump or traceback to be found when something like happens in windows? Where would it be located?

User avatar
Greendogo
Posts: 1383
Joined: 26 Aug 2011, 02:04

Re: OpenMW Game Template

Post by Greendogo » 26 Jul 2015, 05:27

I'm glad this is being worked on. As has been commented, this will make creating the example suite much easier!


User avatar
psi29a
Posts: 4637
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: OpenMW Game Template

Post by psi29a » 26 Jul 2015, 08:39

DestinedToDie wrote:http://pastebin.com/GDPiArsY
Looks like mine. I wish ace and zini would give their wisdom here, as OpenMW shouldn't just tank like this without a big fat explanation why.

Have you tride replacing c:/openmw-template/meshes/*.nif with bethesda's? Does the new game work then? I want to know if it is specific to my stripped down NIFs or not.

User avatar
DestinedToDie
Posts: 1149
Joined: 29 Jun 2015, 09:08

Re: OpenMW Game Template

Post by DestinedToDie » 26 Jul 2015, 08:47

psi29a wrote:
DestinedToDie wrote:http://pastebin.com/GDPiArsY
Have you tride replacing c:/openmw-template/meshes/*.nif with bethesda's? Does the new game work then? I want to know if it is specific to my stripped down NIFs or not.

Aaaaaaand we're in business again! With those 5 Bethesda nifs it works! I'll be checking for which ones in particular in 5 minutes.

Edit: The sky meshes do not crash the game, however both Base_Anim.1st.nif and Base_Anim do. It is convenient that I am recreating them, since I'll have to make ones that won't crash the game.

I do wonder though why it worked for Loriel. Loriel, did you have the fallback BSAs included? Did you see stars in the sky?

Post Reply