OpenMW 0.29.0

Anything related to PR, release planning and any other non-technical idea how to move the project forward should be discussed here.
User avatar
cc9cii
Posts: 518
Joined: 28 Mar 2013, 04:01

Re: OpenMW 0.29.0

Post by cc9cii » 20 Feb 2014, 14:09

Went through the whole start again, and outside the office I can see "save" option but no "load" option.

If I save once more, a file named "0" is put in "Documents\My Games\openmw\saves\2" directory, and I can suddenly see a "load" option.

The previous file in "Documents\My Games\openmw\saves\1" directory, also named "0", is actually opened by openmw and won't let me re-name it until I exit openmw.

I'll see if I can get to the save part with a debug build to see what is happening during a load.

EDIT: figured out how to copy from the console, too late now :oops:

EDIT2: as soon as I step out of the office the slaughter fish pathfinding thing kills openmw in debug mode - is there a quick workaround for this?

User avatar
gus
Posts: 390
Joined: 11 Aug 2011, 15:41

Re: OpenMW 0.29.0

Post by gus » 20 Feb 2014, 14:55

just change the line to:

if(mPathFinder.empty()) return;
ESM::Pathgrid::Point lastPt = mPathFinder.getPath().back();

User avatar
gus
Posts: 390
Joined: 11 Aug 2011, 15:41

Re: OpenMW 0.29.0

Post by gus » 20 Feb 2014, 15:22

I also change statemanagerimp.cpp around line 167 to:

Code: Select all

    int screenshotW = 512, screenshotH = 256; // *2 to get some nice antialiasing
    Ogre::Image screenshot;
    Ogre::uchar* mPixels = new Ogre::uchar[screenshotW * screenshotH * 3];
    screenshot.loadDynamicImage(mPixels, screenshotW, screenshotH, 1, Ogre::PixelFormat::PF_R8G8B8A8);

    
    //world.screenshot(screenshot, screenshotW, screenshotH);
    //screenshot.save("bla.jpg");
    Ogre::DataStreamPtr encoded = screenshot.encode("jpg");
    profile.mScreenshot.resize(encoded->size());
    encoded->read(&profile.mScreenshot[0], encoded->size());
It's very hacky, just to eliminate the possiblity of bugs comming from screenshots. But as loading seems to work for me, maybe there is something there.

User avatar
raevol
Posts: 3088
Joined: 07 Aug 2011, 01:12
Location: Caldera

Re: OpenMW 0.29.0

Post by raevol » 20 Feb 2014, 18:08

I know you guys are still working on this issue, and again, I'll be gone starting today and probably won't get to the release until next week, but:
Zini wrote:Notes for the release: Load/Save is still missing a few parts. Most of it is less important, but the following should be mentioned:
- Some creature state (also used for NPCs) is missing, including magic and AI
- Moving objects (other than the player) between cells is not handled properly

In the release message it should also be explicitly stated that the saved game format is not final yet. Until 1.0 it can be changed at any time, which may break compatibility with older saves.
and
Zini wrote:Notes for the release: Load/Save is still missing a few parts. Most of it is less important, but the following should be mentioned:
- Some creature state (also used for NPCs) is missing, including magic and AI
- Moving objects (other than the player) between cells is not handled properly

In the release message it should also be explicitly stated that the saved game format is not final yet. Until 1.0 it can be changed at any time, which may break compatibility with older saves.
noted!

corristo
Posts: 495
Joined: 12 Aug 2011, 08:29

Re: OpenMW 0.29.0

Post by corristo » 20 Feb 2014, 18:20

@Zini @scrawl @Chris
Gentlemen, let's just rollback this one: 51fb9f65ea5086433fa0d1db12197b133a9b27fd
Implementation in previous commit is asynchronous, so it should work just fine.

User avatar
Zini
Posts: 5538
Joined: 06 Aug 2011, 15:16

Re: OpenMW 0.29.0

Post by Zini » 20 Feb 2014, 19:26

Which issue is that supposed to fix? the video crash? I thought we had that fixed already via the revert chris suggested.

User avatar
cc9cii
Posts: 518
Joined: 28 Mar 2013, 04:01

Re: OpenMW 0.29.0

Post by cc9cii » 20 Feb 2014, 21:52

gus wrote:just change the line to:

if(mPathFinder.empty()) return;
ESM::Pathgrid::Point lastPt = mPathFinder.getPath().back();
I assumed a typo, i.e.

if(mPathFinder.getPath().empty()) return;

But that moves the problem to PathFinder::getDistToNext()

Is there a way to manually execute the startup scripts so that the character can get to a saveable state? If I teleport out of the Census Office (after teleporting in from the ship to avoid the slaughterfish), say to Balmora, the script is not quite finished and I don't think I can save.

EDIT: ok, my brain is not engaged. I'll create a save using a release version and attempt to load the save using a debug version (I deleted the old saves while trying various things)

User avatar
Zini
Posts: 5538
Joined: 06 Aug 2011, 15:16

Re: OpenMW 0.29.0

Post by Zini » 20 Feb 2014, 22:28

You can bypass the regular char gen by running OpenMW with the --skip-menu switch. If you want to just enable saving during the normal char gen, you can open the console (F2) and then type: set chargenstate to -1

User avatar
cc9cii
Posts: 518
Joined: 28 Mar 2013, 04:01

Re: OpenMW 0.29.0

Post by cc9cii » 20 Feb 2014, 23:19

Will try, but I won't have access to my dev box for another 9 hours or so (doing my regular gig).

This morning I tried putting a breakpoint on ESM reader but for some reason openmw starts without triggering on the break... obviously I'm doing something wrong. I was going to try to step through the part of reading the save to see which record is causing the issue.

corristo
Posts: 495
Joined: 12 Aug 2011, 08:29

Re: OpenMW 0.29.0

Post by corristo » 21 Feb 2014, 04:53

Zini wrote:Which issue is that supposed to fix? the video crash? I thought we had that fixed already via the revert chris suggested.
Ah well, sorry then, haven't seen that message probably.
Image

Post Reply