Debian Experimental Packages

Anything related to PR, release planning and any other non-technical idea how to move the project forward should be discussed here.
maqifrnswa
Posts: 180
Joined: 14 Jan 2013, 03:57

Re: Debian Experimental Packages

Post by maqifrnswa » 17 Jan 2014, 15:08

K0kt409P wrote:
maqifrnswa wrote: Thanks -one thing though, everyone needs mygui from unstable. It won't be in testing for a little while until gcc4.8 is default compiler on SPARC and PowerPC. EDIT: never mind I'll do some magic and try to force it through it may take a few days
Perhaps I am misreading something, but it looks like it's already there: http://packages.debian.org/source/jessie/mygui
Also apt pinning openmw in experimental to >500 allows it to auto update. Without pinning experimental packages need explicit apt-get install every release. It's a quirk of experemtal.
Interesting, I did not know that. I'll update the wiki to include it.

It's the wrong version, built against ogre 1.8. Ogre 1.9 needs gcc4.8 and that's why the mugui we want is stuck in unstable.

K0kt409P
Posts: 148
Joined: 06 Aug 2013, 09:14

Re: Debian Experimental Packages

Post by K0kt409P » 17 Jan 2014, 15:13

I see.

User avatar
scrawl
Posts: 2152
Joined: 18 Feb 2012, 11:51

Re: Debian Experimental Packages

Post by scrawl » 17 Jan 2014, 15:13

Ogre 1.9 needs gcc4.8
Huh? Not aware of that. And I've built it with 4.6 just fine.

maqifrnswa
Posts: 180
Joined: 14 Jan 2013, 03:57

Re: Debian Experimental Packages

Post by maqifrnswa » 17 Jan 2014, 15:18

scrawl wrote:
Ogre 1.9 needs gcc4.8
Huh? Not aware of that. And I've built it with 4.6 just fine.
On PowerPC and SPARC. I know, it's funny how we have to worry about that, but Debian strives to be universal
Brotherbrick and I are looking forward to someone playing morrowind on a raspberrypi or SGI system;)

Since PowerPC and SPARC are minor architectures for us I'll request they be removed until gcc4.8 is their default

K0kt409P
Posts: 148
Joined: 06 Aug 2013, 09:14

Re: Debian Experimental Packages

Post by K0kt409P » 31 Jan 2014, 10:04

Updated installation instructions since mygui 3.2.0-5 was migrated to testing.

User avatar
psi29a
Posts: 4630
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: Debian Experimental Packages

Post by psi29a » 06 Feb 2014, 13:55

Lgro: Can you (or someone) update the download page to reflect that Debian no longer uses the PPA but is now in Debian proper?

http://packages.debian.org/experimental/openmw

Thanks!

User avatar
lgromanowski
Site Admin
Posts: 1193
Joined: 05 Aug 2011, 22:21
Location: Wroclaw, Poland
Contact:

Re: Debian Experimental Packages

Post by lgromanowski » 06 Feb 2014, 14:16

BrotherBrick wrote:Lgro: Can you (or someone) update the download page to reflect that Debian no longer uses the PPA but is now in Debian proper?

http://packages.debian.org/experimental/openmw

Thanks!
Sure, done :)
best regards,
Lukasz

Post Reply