Decal Textures and Normal Maps

General discussion regarding the OpenMW project.
For technical support, please use the Support subforum.
Post Reply
concurrent
Posts: 4
Joined: 29 Jun 2020, 22:06

Decal Textures and Normal Maps

Post by concurrent »

It seems that if there is a decal texture defined in a .nif, the normal map texture for the diffuse texture is not applied in game. I'm not sure if this is some limitation of OpenMW or user error on my part (or maybe exporter error).

Pictures will probably explain better.
Meshes here are Robert's Oblivion Body - not the existing conversion for Morrowind, but one I am working on.
textures are I think Slof's.

Mr. Hairy Nord here has the hair as a decal texture
Image

Our hairless chested friend has no decal, and a crappy normal map that I made with paint.net. (crappy map better illustrates the issue here)
Image

I thought it would be cool to have like hair / tattoos / scars as decals.
This is a very minor issue - can find workarounds here. It's a curious issue though. Maybe someone knows what's going on?
User avatar
AnyOldName3
Posts: 2251
Joined: 26 Nov 2015, 03:25

Re: Decal Textures and Normal Maps

Post by AnyOldName3 »

Looking at the shaders, I can't see any reason why this would be the case, but there's clearly something weird going on in those screenshots. We definitely don't handle decals the same way the original engine did, and that causes issues sometimes, but I doubt this would be one of them.
AnyOldName3, Master of Shadows
User avatar
wazabear
Posts: 73
Joined: 13 May 2020, 19:31
Gitlab profile: https://gitlab.com/glassmancody.info

Re: Decal Textures and Normal Maps

Post by wazabear »

I can't reproduce this with latest master, decals work fine with normal maps.

Which version of OpenMW are you running?
Fade away and radiate
concurrent
Posts: 4
Joined: 29 Jun 2020, 22:06

Re: Decal Textures and Normal Maps

Post by concurrent »

wazabear wrote: 13 Oct 2021, 20:01 I can't reproduce this with latest master, decals work fine with normal maps.

Which version of OpenMW are you running?
I just switched to one of the RC versions - I think this might somehow be hardware related - or maybe just some settings on my part. I'm on some old Radeon HD GPU in this desktop for now - that might be relevant?

I tried different lighting and shading settings to see if It changed anything, but didn't pin it down yet. I'll let you guys know when I find the issue.
User avatar
wazabear
Posts: 73
Joined: 13 May 2020, 19:31
Gitlab profile: https://gitlab.com/glassmancody.info

Re: Decal Textures and Normal Maps

Post by wazabear »

I did not test with a skinned body, it's possible that could be an issue. Did you also try with a static (like a wall) and get same results? I was using a test sphere.
Fade away and radiate
concurrent
Posts: 4
Joined: 29 Jun 2020, 22:06

Re: Decal Textures and Normal Maps

Post by concurrent »

I tried with a door, and still the same behavior.

Very strange, I've tried multiple settings, no change. The parallax effect works correctly with decals if I change the name to the _nh suffix though.

???
Post Reply